Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: What package needed for 'Make'

  1. #1

    Default What package needed for 'Make'

    I am trying to install a driver and need to use make and make load. I am using openSUSE11.4. I went to YAST to install the software needed for make but I am not sure which package I need to install.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: What package needed for 'Make'

    On 2012-07-16 22:56, kwestcobb wrote:
    >
    > I am trying to install a driver and need to use make and make load. I am
    > using openSUSE11.4. I went to YAST to install the software needed for
    > make but I am not sure which package I need to install.


    Development pattern.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: What package needed for 'Make'

    Am 16.07.2012 22:56, schrieb kwestcobb:
    >
    > I am trying to install a driver and need to use make and make load. I am
    > using openSUSE11.4. I went to YAST to install the software needed for
    > make but I am not sure which package I need to install.
    >
    >

    The package which contains the command make has itself the name make.

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10



  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: What package needed for 'Make'

    Quote Originally Posted by kwestcobb View Post
    I am trying to install a driver and need to use make and make load. I am using openSUSE11.4. I went to YAST to install the software needed for make but I am not sure which package I need to install.
    And apart from the usefull answers above, next time you could try yourself by using YaST > Software > Software management; then type make in the search field. In this case it would show, because the program make is part from the package make. Else you could check the "provides" box to search for a package that provides the file make.

    And please do not type Make when you mean make. This is Unix/Linux and every typo counts.
    Henk van Velden

  5. #5

    Default Re: What package needed for 'Make'

    I searched for development pattern within YaST and was unable to find it. Is it called development pattern in 11.4?

    @Martin and Henk I have already installed the make package (the obvious solution) and I am still encountering issues which is why I posted this question.

    Here is a summary of what I've done:
    - installed make package
    - in terminal, entered the directory where the make file was saved
    - typed make
    - received the following error:

    make -C /lib/modules/2.6.37.1-1.2-desktop/build SUBDIRS= 'pwd' modules
    make: *** /lib/modules/2.6.37.1-1.2-desktop/build: No such file or directory. Stop.
    make: *** [driver] Error 2.

    All I am trying to to do is set install the drivers for an accessory board to my stack.

  6. #6
    dd@home.dk NNTP User

    Default Re: What package needed for 'Make'

    On 07/17/2012 03:56 PM, kwestcobb wrote:
    > I searched for development pattern within YaST and was unable to find
    > it. Is it called development pattern in 11.4?


    open YaST Software Management, when the Software Manager window opens it
    is on the "Search" tab and a search window is open (left side), click on
    the "Patterns" tab and the left pane changes...scroll down to the
    "Development" section and click (if necessary to expand that section,
    then) select (single left click) on "Base Development" and "C/C++
    Development" sub-sections, then click the "Accept" button in the lower
    right corner..

    those two take care of my (and maybe your) build from source needs..

    --
    dd


  7. #7

    Default Re: What package needed for 'Make'

    Carlos, I figured out what to do in order to install the basic packages to build. For anyone else encountering the same issues do the following:

    YaST > Software > Software Management > Sort by Patterns > Select C/C++ Development > Install appropriate packages

    alternatively, in the terminal type: zypper install -t patten devel_C_C++

    Despite installing these packages, I am still running into the error mentioned above when trying to use make.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: What package needed for 'Make'

    On 2012-07-17 15:56, kwestcobb wrote:
    >
    > I searched for development pattern within YaST and was unable to find
    > it. Is it called development pattern in 11.4?


    Open up yast package manager. Select the "patterns" tab. On the left panel search for
    "development", click on the base development pattern. It is not a package, it is a pattern, a
    group of packages.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: What package needed for 'Make'

    I am on 11.4.

    YaST > Software > Software management. Use the View menu (somewhere upper-left) and choose Patterns. Scroll down to Developement and check Basic developement for installation. Do you realy not have that?

    And you should not make a story like:
    - in terminal, entered the directory where the make file was saved
    - typed make
    - received the following error:
    You should simply copy/paste that and the errors you get in one sweep of the mouse into your post between CODE tags (http://forums.opensuse.org/english/i...ags-guide.html ). No story needed, we can all read a computer session.

    And the error message seems to be clear enough to me: that file is needed, but it does not exist.

    How do think we can know more? You only know what software product you have there, where you got it and what the instructions say. Is there a README file coming with it? Are there instructions on a web page of the product telling what the prerequisits are?

    You saying "All I am trying to to do is set install the drivers for an accessory board to my stack. " gives me theimpression that you think that building yourself is easier then installing from an openSUSE repo. It is not. Developers tend to make a lot of mistakes in generating make files, etc. And you have to identify them and cure them. either by repairing yourself, or ny contavting the developer.

    Are you sur there is no openSUSE ready package of your product in a repo? Again we can not help as long as you do not tell us anything about that product.
    Henk van Velden

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: What package needed for 'Make'

    During my typing the above post, new posts were added, inmclusing yours.

    You seem to think that the error is saying that make is not complete. It is not. It is telling that your environment is not complete for the product your want to build.

    Do you understand what make is supposed to do?
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •