Results 1 to 3 of 3

Thread: Disable dead keys under gnome3 or international layout without them

  1. #1

    Default Disable dead keys under gnome3 or international layout without them

    Hello,
    i'm wondering if there is some nice way using the keyboard configuration to disable dead keys explicitly. I am using the us international layout which uses dead keys for the accents as a default, instead of just ' and " as the non-international variant.
    I can set the layout using setxkbmap -layout us -variant altgr-intl -option nodeadkeys but i would prefer to not bypass gnome3, so i still can use the layout selection applet.

    The background of using us international without dead keys is the following: i'm a software developer, so i'd like to use the us layout, but i'm also german and like to have umlauts and such. But in neither programming or german there is a need for dead keys and having to use AltGr combinations to produce single and double quotes is just as painfull as using the german layout, where you need AltGr to produce brackets and braces.

  2. #2
    Join Date
    Dec 2009
    Location
    Buenos Aires
    Posts
    20

    Default Re: Disable dead keys under gnome3 or international layout without them

    I would like to know how to do it too. I can't disable them under Plasma 5.

  3. #3

    Default Re: Disable dead keys under gnome3 or international layout without them

    Quote Originally Posted by nicovai View Post
    I would like to know how to do it too. I can't disable them under Plasma 5.
    You are aware that thread is about GNOME?
    Why didn't you start a new one with your question about Plasma5, and instead resurrect this 3 year old one?

    Plasma5 should just take the standard system keyboard settings, so disable them in YaST->Hardware->System Keyboard Layout.
    If that doesn't help, configure the keyboard layout in Plasma5's systemsettings->Input Devices->Keyboard->Layouts, that overrides the system's layout for this particular user.
    Last edited by wolfi323; 02-Apr-2015 at 09:39.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •