Results 1 to 4 of 4

Thread: Meta (alt) key not working in emacs

  1. #1

    Default Meta (alt) key not working in emacs

    Hi all,

    This stopped working on my computer a few months ago and I ignored it. Now I'm finally trying to track it down.

    If I try and use the alt key in emacs, e.g.: alt+x it simply doesn't work on one of my computers.

    The obvious thought is that something is hijacking the alt key so I went looking for what could be doing it. Here's what I found:

    Computer A has the problem.
    Computer B does not.
    Both opensuse 11.4 with all the latest updates.

    However, if I ssh into B from A then emacs on B won't work.

    From this I would say that the terminal app. has the Alt key defined somewhere. So, I looked at it's keyboard shortcuts, couldn't find Alt by itself being used. I then compare all the settings of terminal (through the terminal window menus) between computer A & B and found no difference.

    I then went looking around everything in my control panel on A for anything that did keyboard mapping and couldn't find anything that looked like it was hijacking the alt key.

    Then, just as a thought I disabled all Desktop Effects, no difference.

    However while looking around I found that under:
    Asisstive Technologies: Preferred Applications: System
    I could change the terminal from "gnome" to "standard xterminal" so I did and tried it and sure enough, now the meta key works in emacs in the xterminal. This lead me to believe that the hijacking was occurring in Gnome Terminal itself but again, I checked all the shortcut keys and could find nothing out of the ordinary.

    I have since looking into this found that I can use the ESC key in place of the ALT key so I am not stuck but I still would like to know what's going on.

    Does anyone have any ideas?

    Thanks,
    Reg

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Meta (alt) key not working in emacs

    On 2012-06-29 12:26, Reg gie wrote:

    > From this I would say that the terminal app. has the Alt key defined
    > somewhere. So, I looked at it's keyboard shortcuts, couldn't find Alt by
    > itself being used. I then compare all the settings of terminal (through
    > the terminal window menus) between computer A & B and found no
    > difference.


    Try keyboard shortcuts, disable menu access keys. But frankly, I would use
    xterm instead.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



  3. #3

    Default Re: Meta (alt) key not working in emacs

    Quote Originally Posted by robin_listas View Post
    Try keyboard shortcuts, disable menu access keys. But frankly, I would use
    xterm instead.
    Thanks but I went through every setting. Shortcuts and menu access keys are already disabled. What's the advantage of xterm?

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Meta (alt) key not working in emacs

    On 2012-06-29 20:56, Reg gie wrote:

    > What's the advantage of xterm?


    That it leaves all keys to the application.
    It only has three menus tied to alt + mouse key. It is an apparently
    minimalistic terminal, features are reached differently. What is important
    is your application, not the terminal.

    I can not test it, because in my machine "emacs" is a graphical application
    with its own display.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •