Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Flash Player requires HAL for DRM content

  1. #1
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Flash Player requires HAL for DRM content

    I don`t know why Adobe hates so much linux users but here it is: Problems playing protected video content | Ubuntu Linux, Flash Player 11

    Using the search site i have found the following repo that offers HAL Index of /repositories/home:/flowabcd but it seems that is not working as it should.

    A bug report was filled here https://bugzilla.novell.com/show_bug.cgi?id=768562 but closed in a VERY stupid way i dare to say. Hal is present in the repo`s of distro`s like Ubuntu or Mageia but not in the openSUSE repo. Before saying that is deprecated (i know that ) the openSUSE developers must take in consideration that Adobe will not adjust his program just because most linux distro`s dropped HAL. So IMHO the package HAL should be present in the OSS repo for Flash to use when rendering DRM content.
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Flash Player requires HAL for DRM content

    It is available from the KDE3 repo, have you tried it?
    http://download.opensuse.org/repositories/KDE:/KDE3

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10



  3. #3

    Default Re: Flash Player requires HAL for DRM content

    Quote Originally Posted by creatura85 View Post
    Using the search site i have found the following repo that offers HAL Index of /repositories/home:/flowabcd but it seems that is not working as it should.

    A bug report was filled here https://bugzilla.novell.com/show_bug.cgi?id=768562 but closed in a VERY stupid way i dare to say. Hal is present in the repo`s of distro`s like Ubuntu or Mageia but not in the openSUSE repo. Before saying that is deprecated (i know that ) the openSUSE developers must take in consideration that Adobe will not adjust his program just because most linux distro`s dropped HAL. So IMHO the package HAL should be present in the OSS repo for Flash to use when rendering DRM content.
    a) Nonsense.
    b) HAL is available in KDE:KDE3 and the sample from Adobe works just fine with it.

  4. #4
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Flash Player requires HAL for DRM content

    Martin tried that, adobe flash player fails to play after HAL is installed, see the bug report. But don`t worry i have seen that HAL is available on other distro`s so there is always another option.
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Flash Player requires HAL for DRM content

    Am 25.06.2012 21:36, schrieb creatura85:>
    > Martin tried that, adobe flash player fails to play after HAL is
    > installed, see the bug report. But don`t worry i have seen that HAL is
    > available on other distro`s so there is always another option.
    >
    >

    I tried it now myself with the hal rpm from the kde3 repo and have not
    the simplest problem to play the drm content on the test page referenced
    in your link.

    Are you sure that you started the hal daemon after installing hal?

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10


  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Flash Player requires HAL for DRM content

    On 2012-06-25 18:36, creatura85 wrote:

    > A bug report was filled here
    > https://bugzilla.novell.com/show_bug.cgi?id=768562 but closed in a VERY
    > stupid way i dare to say. Hal is present in the repo`s of distro`s like
    > Ubuntu or Mageia but not in the openSUSE repo. Before saying that is
    > deprecated (i know that ) the openSUSE developers must take in
    > consideration that Adobe will not adjust his program just because most
    > linux distro`s dropped HAL. So IMHO the package HAL should be present in
    > the OSS repo for Flash to use when rendering DRM content.


    Yes, a typical sample of how the opensource side tries to ignore the closed
    source side. On the other hand, it is also typical of how closed source can
    not keep pace with the fast cycle of open source software.

    It is also funny how even openSUSE devs and packagers "ignore" that kde3 is
    maintained in openSUSE and that it also uses HAL. Intentionally, I guess >:-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



  7. #7
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Flash Player requires HAL for DRM content

    Martin, i had retested Hal this morning and it seems that is working; i can`t explain why yesterday the darn thing did not worked...

    Robin, we live in strange times
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  8. #8

    Default Re: Flash Player requires HAL for DRM content

    Quote Originally Posted by robin_listas View Post
    Yes, a typical sample of how the opensource side tries to ignore the closed
    source side. On the other hand, it is also typical of how closed source can
    not keep pace with the fast cycle of open source software.
    "opensource side" ignores the two pieces of software that use a deprecated software. Your KDE 3 example shows is not related to being closed source.
    In fact KDE 3 is more "ignored". Flash would actually have been fixed by someone if it would be open source. Adobe is the one ignoring Flash here.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Flash Player requires HAL for DRM content

    On 2012-06-26 08:46, creatura85 wrote:
    >
    > Martin, i had retested Hal this morning and it seems that is working; i
    > can`t explain why yesterday the darn thing did not worked..*.


    Maybe a reboot was needed after the installation.

    > *Robin, we live in strange times


    Indeed. :-)


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



  10. #10

    Default Re: Flash Player requires HAL for DRM content

    To completely understand the situation. HAL is not in the main repo because nobody able to maintain it wants to.
    Is not a decision from the corporate Suse. Is not a decision from the openSUSE Board. Is not a decision from the secret dark "opensource side" Wisemen's Committee hidden in dark side of the moon (ups! perhaps I shouldn't have said that...).

    There was only a decision taken, from Danny Kukawka. He was maintaining HAL and he decided that *he* didn't want to continue doing it.

    *Anybody* can go and say: "Hey, I will do the work!" and HAL will be back in openSUSE. As simple as that.

    It's interesting that the only people seeing a problem here are in the group of the ones without the knowledge to maintain HAL.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •