Results 1 to 3 of 3

Thread: PyCapsule_Import error

  1. #1

    Default PyCapsule_Import error

    Hello

    I've installed crossover office and even though it installs there is an error message which I think is affecting the way programmes work within crossover as some of the programmes don't work properly where they did on a previous installation of crossover. the error message is:-

    kde-config: error while loading shared libraries: libkdecore.so.4: cannot open shared object file: No such file or directory
    /usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
    from gtk import _gtk
    ImportError: PyCapsule_Import could not import module "gi"
    kde-config: error while loading shared libraries: libkdecore.so.4: cannot open shared object file: No such file or directory
    /usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
    from gtk import _gtk
    ImportError: PyCapsule_Import could not import module "gi"

    I've googled this and there are references to compriz etc. I've noticed that I don't have libkdecore.so.4 in user/lib but I have libkdecore.so.5 instead.

    anyone got an idea how to correct this.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: PyCapsule_Import error

    My guess is that you would make it much easier for people to help you when you in the first place mention which version of openSUSE you use and in this case also which version of KDE. I hope you agree.
    Henk van Velden

  3. #3

    Default Re: PyCapsule_Import error

    Sorry hcvv not thinking straight been a long time trying to work this out.

    I'm running opensuse 11.4 with KDE 4.8.00 (4.8.0 "release 2")

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •