Results 1 to 7 of 7

Thread: Where's Tomcat 7 pacakge for Opensuse 12.1?

  1. #1

    Default Where's Tomcat 7 pacakge for Opensuse 12.1?

    I need to re-install up-to-date Tomcat7 for Opensuse 12.1.

    I can't find it in the repositories anywhere.

    This

    Code:
      http://en.opensuse.org/openSUSE:Upcoming_features#Apache_Tomcat_7
    Says

    Code:
      Apache Tomcat 7
      New major version of popular servlet container has been added to openSUSE. It implements the Servlet 3.0 and JavaServer Pages 2.2 and many more.
      As we maintain only one major version of Apache Tomcat in openSUSE, tomcat6 has been dropped. In addition we dropped the jpackage.org naming scheme we have used for last couple of years (tomcat5, tomcat55, tomcat6) to emphasize this fact. So tomcat 7 (and all future version upgrades) is packaged as tomcat.
    This

    Code:
      http://software.opensuse.org/package/tomcat
    only shows it's available for "Opensuse Factory" and "Fedora 16".

    This

    Code:
      https://build.opensuse.org/package/show?package=tomcat&project=openSUSE%3AFactory
    says

    Code:
      Developed at Java:packages
    and this,

    Code:
    https://build.opensuse.org/package/show?package=tomcat&project=Java%3Apackages
    says Building for Opensuse 12.1 is *disabled*.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: Where's Tomcat 7 pacakge for Opensuse 12.1?

    Quote Originally Posted by guest69878
    says Building for Opensuse 12.1 is *disabled*.
    Hi
    That would be a question you need to ask the maintainer/bug owner;
    https://build.opensuse.org/project/u...ava%3Apackages

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.31-0.9-default
    up 2 days 6:20, 5 users, load average: 0.40, 0.44, 0.45
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  3. #3

    Default Re: Where's Tomcat 7 pacakge for Opensuse 12.1?

    I contacted the maintainer & bugowner 'mvyskocil' from here.

  4. #4
    Join Date
    Feb 2009
    Location
    Prague
    Posts
    2

    Default Re: Where's Tomcat 7 pacakge for Opensuse 12.1?

    Hallo,

    I have disabled the build to save some build power for jdk7 transition. As it's now finished, I will enable 12.1 as well. There is only one drawback as packages now expect jdk7 and I have no idea if they will work with jdk6, so I will add java-1_7_0-openjdk to repo.

  5. #5

    Default Re: Where's Tomcat 7 pacakge for Opensuse 12.1?

    Quote Originally Posted by mvyskocil View Post
    Hallo,

    I have disabled the build to save some build power for jdk7 transition. As it's now finished, I will enable 12.1 as well. There is only one drawback as packages now expect jdk7 and I have no idea if they will work with jdk6, so I will add java-1_7_0-openjdk to repo.
    Thanks for the answer!

    I already use

    Code:
        rpm -qa | grep -i jdk
            java-1_7_0-openjdk-demo-1.7.0.0_147-14.1.x86_64
            java-1_7_0-openjdk-javadoc-1.7.0.0_147-14.1.x86_64
            java-1_7_0-openjdk-devel-1.7.0.0_147-14.1.x86_64
            java-1_7_0-openjdk-src-1.7.0.0_147-14.1.x86_64
            java-1_7_0-openjdk-1.7.0.0_147-14.1.x86_64
    installed from this repo

    Code:
        http://download.opensuse.org/repositories/Java:/openjdk6:/Factory/openSUSE_12.1
    Will I need to change that source of the jdk to some other repo to use 'this' tomcat?

  6. #6

    Default Re: Where's Tomcat 7 pacakge for Opensuse 12.1?

    As it's now finished, I will enable 12.1 as well
    I checked here for it,

    https://build.opensuse.org/package/s...ava%3Apackages

    and it still says "unresolvable" for the tomcat package.

    Maybe I'm looking in the wrong place for this? Is the 'new' package moved somewhere else?

  7. #7
    Join Date
    Feb 2009
    Location
    Prague
    Posts
    2

    Default Re: Where's Tomcat 7 pacakge for Opensuse 12.1?

    Quote Originally Posted by guest69878 View Post
    I checked here for it,

    https://build.opensuse.org/package/s...ava%3Apackages

    and it still says "unresolvable" for the tomcat package.

    Maybe I'm looking in the wrong place for this? Is the 'new' package moved somewhere else?
    Hallo,

    no, you've looked at the right place. The unresolvable was because all Factory packages now expects jdk7, which I built yesterday for 12.1 in Javapenjdk6:Factory. I've added it to 12.1 repository and triggered the complete rebuild. If nothing bad happens, tomcat will be available in a few hours. If not, please ask me again as this is not on my TOP list.

    Regards
    Michal Vyskocil

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •