Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: semi-busted cron entries

  1. #1
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default semi-busted cron entries

    Hello Community:

    my user cron has stopped executing any cron jobs except one.

    Code:
    MAILTO=jj@domain.com
    */1 * * * * /home/jj/Documents/cirrhus9/Accounts/Norveld/3WeekTest/norveldchk2.sh > /dev/null 2>&1
    30 23 * * * /home/jj/bin/baculasql.sh > /dev/null 2>&1
    00 08 * * 6  /home/jj/bin/ftb.sh  > /dev/null 2>&1
    59 23 * * * /home/jj/bin/c9internalS3_du.sh
    only the norveldchk2.sh is being run says
    Code:
    tail -f /var/log/messages | grep -i cron
    all .sh scripts are 700.

    I just recently added the MAILTO=jj@domain.com to my crontab, so I may have some email on this subject soon.

    I can't tell when this started.

    Any ideas?
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: semi-busted cron entries

    Hi
    So the email is working, as in use mailx to send a test message?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: semi-busted cron entries

    Yes, email is working.
    Tested with
    Code:
    echo TEST| mail user@domain.com
    whether or not the cron mailto works, I will know tomorrow morning.

    Thanks Malcom!
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: semi-busted cron entries

    On 2012-06-19 22:36, Habitual wrote:
    >
    > Hello Community:
    >
    > my user cron has stopped executing any cron jobs except one.
    >
    >
    > Code:
    > --------------------
    >
    > MAILTO=jj@domain.com
    > */1 * * * * /home/jj/Documents/cirrhus9/Accounts/Norveld/3WeekTest/norveldchk2.sh > /dev/null 2>&1
    > 30 23 * * * /home/jj/bin/baculasql.sh > /dev/null 2>&1
    > 00 08 * * 6 /home/jj/bin/ftb.sh > /dev/null 2>&1
    > 59 23 * * * /home/jj/bin/c9internalS3_du.sh
    >
    > --------------------



    Whose crontab is that?

    Well, the first thing to do is removing those devnull thingies. How do you
    expect to debug cron job problems with no output?

    Then you have to make sure that plain mail command sending to
    "jj@domain.com" works. The plain "mail" command, mind, not thunderbird.

    > have some email on this subject soon.


    It should be instantly, less than a second. And the line typically is:

    Code:
    MAILTO="localusername"
    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: semi-busted cron entries

    Robin and Co:

    whoami
    jj

    updated cron:
    Code:
    MAILTO="jj"
    */1 * * * * /home/jj/Documents/cirrhus9/Accounts/Norveld/3WeekTest/norveldchk2.sh > /dev/null 2>&1
    30 23 * * * /home/jj/bin/baculasql.sh
    00 08 * * 6  /home/jj/bin/ftb.sh 
    59 23 * * * /home/jj/bin/c9internalS3_du.sh
    I left norveldchk2.sh alone since it is working.
    Code:
    whoami && mail
    jj
    No mail for jj

    A full 5 minutes after editing.

    It's late here. see you all tomorrow.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: semi-busted cron entries

    On 2012-06-20 03:56, Habitual wrote:

    >
    > jj
    > No mail for jj
    >
    > A full 5 minutes after editing.


    but the entries run at 23:30, 08:00 and 23:59, you have to wait until the
    corresponding hour for each entry. If the time passes and you see no email,
    check the messages log and the mail log.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: semi-busted cron entries

    Quote Originally Posted by robin_listas View Post
    ...but the entries run at 23:30, 08:00 and 23:59, you have to wait until the
    corresponding hour for each entry. If the time passes and you see no email,
    check the messages log and the mail log....
    Understood.
    Subject: Cron <jj@MyKung-Fu> /home/jj/bin/c9internalS3_du.sh
    From: jj@linux.local (Cron Daemon)

    Progress. I can't believe I pulled a dunce move and didn't remove the redirection and/or piping first.
    Too many terminals, so little time, I guess.

    Thanks!
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: semi-busted cron entries

    On 2012-06-20 14:26, Habitual wrote:

    > -Understood-.
    > Subject: Cron <jj@MyKung-Fu> /home/jj/bin/c9internalS3_du.sh
    > From: jj@linux.local (Cron Daemon)


    :-)

    > Progress. I can't believe I pulled a dunce move and didn't remove the
    > redirection and/or piping first.
    > Too many terminals, so little time, I guess.


    It happens.

    > Thanks!


    Welcome :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: semi-busted cron entries

    Well, progress is subjective, I guess.

    Code:
    Jun 20 23:59:01 localhost /USR/SBIN/CRON[11201]: (jj) CMD (/home/jj/bin/c9internalS3_du.sh)
    ran but no email.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  10. #10

    Default Re: semi-busted cron entries

    Habitual wrote:
    > Well, progress is subjective, I guess.
    >
    >
    > Code:
    > --------------------
    > Jun 20 23:59:01 localhost /USR/SBIN/CRON[11201]: (jj) CMD (/home/jj/bin/c9internalS3_du.sh)
    > --------------------
    > ran but no email.


    IIRC, when a job produces no output, no email is sent. Could that be the
    reason? Also IIRC, it's possible to override that so an empty email is
    sent. Or you can add 'echo date' to your command, or somesuch.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •