Results 1 to 2 of 2

Thread: Cups saying job complete but nothing prints from applications

  1. #1
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Cups saying job complete but nothing prints from applications


    Not sure if this is right place to ask this. I installed a new Brothers
    printer last night. It is a Model MFC6710DW printer. I installed the
    Brothers lpr and CUPSwrapper rpms. I can print test pages from CUPS and
    YaST2.

    When I try to print a .odt or pdf document I can see it go from CUPS to
    the printer, but it never prints. The test pages go thru CUPS just fine.
    And CUPS shows all jobs sent to it as complete.

    On boot I see the following error in DMESG:

    Code
    ---------
    9.408716] udev-configure-printer[797]: add
    /devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0
    [ 9.409362] udev-configure-printer[797]: device devpath is
    /devices/pci0000:00/0000:00:1a.7/usb1/1-4
    [ 9.409440] udev-configure-printer[797]: Device vendor/product is
    04F9:0263
    [ 9.411861] usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto
    2 vid 0x04F9 pid 0x0263
    [ 9.411879] usbcore: registered new interface driver usblp
    [ 9.415164] udev-configure-printer[800]: add
    /devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/usb/lp0
    [ 9.611242] udev-configure-printer[797]: failed to claim interface
    [ 9.611873] udev-configure-printer[800]: device devpath is
    /devices/pci0000:00/0000:00:1a.7/usb1/1-4
    [ 9.611935] udev-configure-printer[800]: MFG:Brother MDL:MFC-J6710DW
    SERN:- serial:BROC2F147665
    /Code
    ---------

    Following is only entry in Cups Page Log:
    Code
    ---------
    MFCJ6710DW root 336 [19/Jun/2012:07:53:48 -0700] 1 1 - localhost Print
    Self-Test Page - -
    MFCJ6710DW anonymous 339 [19/Jun/2012:07:59:58 -0700] 1 1 - localhost
    Print Self-Test Page - -
    MFCJ6710DW finemanruss 344 [19/Jun/2012:11:11:35 -0700] 1 1 - localhost
    Guest-Book.odt - -
    MFCJ6710DW root 345 [19/Jun/2012:11:24:02 -0700] 1 1 - localhost Guest-
    Book.odt - -
    MFCJ6710DW root 346 [19/Jun/2012:11:48:54 -0700] 1 1 - localhost Guest-
    Book.odt - -
    MFCJ6710DW root 347 [19/Jun/2012:11:51:24 -0700] 1 1 - localhost Guest-
    Book.odt - -
    MFCJ6710DW root 348 [19/Jun/2012:11:55:08 -0700] 1 1 - localhost Guest-
    Book.odt - -
    /Code
    -----------

    Access log has no error messages.

    Any ideas how to test this further?

    Thanks in advance


    Russ
    openSUSE 12.1(3.1.10-1.9-desktop x86_64)|KDE Platform Version
    4.8.3 (4.8.3) "release 504"|Intel core2duo 2.5 MHZ,|8GB
    DDR3|GeForce 8400GS(NVIDIA-Linux-x86_64-295.53)


  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,714
    Blog Entries
    1

    Default Re: Cups saying job complete but nothing prints from applications

    There are other recent similar threads concerning printing under 12.1 . Could well be due to a bug with CUPS. For example:

    http://forums.opensuse.org/english/g...s-coupons.html

    The general advice has been to print to file, then try viewing the file with gv. This might assist with determining where the problem lies more specifically. It is also worthwhile checking for any bug reports concerning this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •