Results 1 to 4 of 4

Thread: Problem with KDE GUI fonts

  1. #1

    Default Problem with KDE GUI fonts

    Hi,
    I just installed a software abaqus suse 12.1; the installation was successful. However, I see some garbage fonts appear on the GUI instead of regular fonts (Image - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting). I have the same problem with other softwares like matlab and tecplot. Could some one point out the solution please.

    Thanks,
    Syed

  2. #2
    Join Date
    May 2012
    Location
    Thessaloniki, Greece
    Posts
    114

    Default Re: Problem with KDE GUI fonts

    It has happened to me too when using Matlab. I think it's because Matlab uses the Helvetica font which is not included in openSUSE right now. So you can either find the font and install it, or change the used font.

    To do that in Matlab, you should do the following:
    a) In Matlab, go to 'File' -> 'Preferences' -> 'Fonts' (and 'Custom' subtab) and make change the fonts to something else.
    b) In your Matlab installation path (eg '/usr/local/MATLAB/R2011b/') go to 'toolbox/local' folder. Then, create a file named 'startup.m'. This file is executed every time you launch Matlab. There, I have added the following lines
    Code:
    set(0,'defaultAxesFontName', 'Droid Sans')
    set(0,'defaultTextFontName', 'Droid Sans')
    I'm not aware about a specific solution for the rest of your programs, I hope the Matlab instructions help...

  3. #3

    Default Re: Problem with KDE GUI fonts

    Thanks for the hint.

    The problem is solved by installing the following package: xorg-x11-fonts

  4. #4
    Join Date
    May 2012
    Location
    Thessaloniki, Greece
    Posts
    114

    Default Re: Problem with KDE GUI fonts

    Didn't know that, seems I've been doing things the hard way.. Thanks for the feedback

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •