Recently Adobe "improved" Flash Player to use SSE2 extension, so it does not work anymore on CPU-s earlier than P4 or Atlon64. The last version that is working for me is 11.1.
Is it possible to package older version (if I remember well, there was 10.3 maitenance release recently) for older computers?
Or is it possible to replace flash player with gnash?