Results 1 to 10 of 10

Thread: Ktorrent not launching

  1. #1

    Default Ktorrent not launching

    Hi,

    I am having a problem where ktorrent has stopped working. Everytime I run it, I get a KDE crash handler pop-up saying ktorrent has crashed.

    I have tried restarting it, killing the process and re-installing ktorrent but to no avail.

    Can anyone help me on this?

    Regards,
    Prad

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Ktorrent not launching

    And what version of openSUSE are you using? And is that the version of KDE that came with it, or did you install another (newer) versiion of KDE.
    Information please!
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Ktorrent not launching

    hcvv wrote:

    > And what version of openSUSE are you using? And is that the version of
    > KDE

    And even what version of ktorrent?

    Start ktorrent from a konsole
    What feedback do you get?

  4. #4

    Default Re: Ktorrent not launching

    @hcvv,i am running opensuse 12.1 and kde is what came with it. have not upgraded to 4.8 yet.@caf4926,this is the output from konsole:
    KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work Warning: QWidget::insertAction: Attempt to insert null actionWarning: QWidget::insertAction: Attempt to insert null actionWarning: QWidget::insertAction: Attempt to insert null actionviking@Viking:~> KCrash: Application 'ktorrent' crashing...KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinitsock_file=/home/viking/.kde4/socket-Viking.site/kdeinit4__0

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Ktorrent not launching

    Thanks for the info. Next time, please copy/paste computer text from your console between CODE tags: http://forums.opensuse.org/english/i...ags-guide.html
    It is now difficult to read.
    Henk van Velden

  6. #6

    Default Re: Ktorrent not launching

    hcvv,

    oops, I wanted to use CODE tags but typed in the QUOTE tags. my bad.

    the forum somehow is very slow at my end, taking me a min of 3 tries to even reply to a post.

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,927

    Default Re: Ktorrent not launching

    You could also look into switching to qbittorrent. It's much better than ktorrent IMHO. It's available from the network repo :
    Index of /repositories/network/openSUSE_11.4
    Best regards,
    Greg

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Ktorrent not launching

    Not much help from me I am afraid. Seems to be wrong something inside KDE that has to do with internationalisation (i18n). Thats should of course be a minor point only worth a warning and then the program should continue in a default language.

    BTW I have no problem runniing Ktorrent 4.1.0 on openSUSE 11.4.
    Henk van Velden

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: Ktorrent not launching

    I think the settings for ktorrent got corrupted, one way or another. What you can do, is clean out the ktrorrent config and data, reconfigure and see what happens:
    Code:
    rm ~/.kde4/share/config/ktorrent* && rm -rf ~/.kde4/share/apps/ktorrent*
    Another option is, to create a new user, start ktorrent as that new user and see if you get the same crashes. If not, the previous should solve the issue, if it does we would have to make some further investigations.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: Ktorrent not launching

    Quote Originally Posted by Knurpht View Post
    I think the settings for ktorrent got corrupted, one way or another. What you can do, is clean out the ktrorrent config and data, reconfigure and see what happens:
    Code:
    rm ~/.kde4/share/config/ktorrent* && rm -rf ~/.kde4/share/apps/ktorrent*
    Another option is, to create a new user, start ktorrent as that new user and see if you get the same crashes. If not, the previous should solve the issue, if it does we would have to make some further investigations.
    Thanks a ton. This worked.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •