Results 1 to 3 of 3

Thread: Disabling tracker

  1. #1

    Default Disabling tracker

    I have noticed that tracker-store and tracker-miner-fs together take almost 60-70% of the CPU all the time leaving nothing for the other applications (openSUSE 12.1 64 bit, KDE 4.8.3. I have disabled nepomuk from auto starting, but haven't been able to find yet how to disable these, so i have to just suspend/kill both these processes manually every time on login. Does anyone know how to disable them?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,486
    Blog Entries
    3

    Default Re: Disabling tracker

    Tracker should not be taking that much cpu time. Well, I guess it depends on how much data you have under your home directory. I think you can configure tracker to restrict where it will look.

    As far as I know, tracker is part of Gnome, so should not be there unless you installed more than just KDE.

    I installed KDE, Gnome, XFCE and LXDE (because I like to experiment).

    I have found that if I log into XFCE, go into settings, open the "Session and Startup" application, then I can find a tab that lists programs that are automatically started. I then uncheck the two entries that are related to tracker. Thereafter, tracker does not start when using XFCE, KDE or LXDE. It does still start when using Gnome.

    If I look in "$HOME/.config/autostart", I find two files:

    tracker-miner-fs.desktop
    tracker-store.desktop

    The two files are identical. They contain 3 lines:
    Code:
    [Desktop Entry]
    Hidden=true
    OnlyShowIn=GNOME;KDE;XFCE;
    I'm pretty sure that's how XFCE stops tracker from running.

    For a purely KDE based solution, this might work:
    Go into "Personal Settings" --> "Startup and Shutdown" --> "Autostart"
    and create an autostart entry for each of the tracker processes. Then uncheck the "enabled" box. That might stop tracker from starting in KDE and perhaps elsewhere. I remember experimenting with running "nm-applet" (the Gnome networkmanager applet) in KDE, and I created such an autostart entry. When I unchecked the "enabled" box, nm-applet stopped running in XFCE and LXDE, and I think it also stopped running in Gnome.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Disabling tracker

    thank you!
    yes, I also have all these - KDE, XFCE, LXDE, Gnome and QT Razor installed. I had the tracker disabled in LXDE already, and since Gnome isn't working for now, i couldn't check it. then on running tracker-preferences under KDE, Indexing Preferences open up.. and i found that monitoring was again disabled there though some folders were still listed under the locations tab, and probably, it was tracking those despite the monitoring was switched off. So i removed those folders and added tracker-search, tracker-needle (this shows up as desktop search), tracker-stats and tracker-control in autostart and disabled them, and it seems it is working fine now.

    p.s. i didn't find anything in $HOME/.config/autostart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •