Results 1 to 6 of 6

Thread: Apache/2.2.15 (Linux/SUSE) Upgrade

  1. #1

    Default Apache/2.2.15 (Linux/SUSE) Upgrade

    Hello,

    Is there anyway to upgrade Apache/2.2.15 (Linux/SUSE) to Apache 2.2.22 on openSUSE 11.3 (x86_64) VERSION = 11.3

    If so can you please provide me with the steps.

    Thanks,
    Madhav

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,270

    Default Re: Apache/2.2.15 (Linux/SUSE) Upgrade

    Welcome here.

    You post this in the subforum about Virtualisation. Can you please explain what your question has to do with Virtualisation? Is this openSUSE 11.3 on a virtual system?

    I hope you are aware of the fact that openSUSE11.3 is no longer supported. That means that when you seach on software.opensuse.org: Download openSUSE 12.1 you will find versions for openSUSE 21.1 (Apach2 2.2.21 en even 2.2.22) and 11.4 (Apache 2.2.17), but none for 11.3.

    I personaly would advice against installing for the wrong openSUSE version.
    Henk van Velden

  3. #3

    Default Re: Apache/2.2.15 (Linux/SUSE) Upgrade

    Hello Henk,

    Yes, openSUSE 11.3 on a virtual system. The issue is that opensuse 11.3 has apache 2.2.15 contain a vulnerability, and I am looking for steps to update the apache version :-
    ===============
    Apache HTTP Server prior to version 2.2.22 contain a vulnerability that could allow an attacker to discover HTTP-only cookies by making a request with an extremely long cookie header field. This could be performed by script running in a victim user's browser.

    This issue was fixed with the release of version 2.2.22 of Apache HTTP Server. However, it is strongly recommended that the latest stable version with all of the appropriate patches be installed.
    ====================

    Can you please help me on this ?

    Madhav

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,270

    Default Re: Apache/2.2.15 (Linux/SUSE) Upgrade

    Well, it is basicaly very simple, but I am afraid you will not love my solution.

    You should upgrade to openSUSE12.1. asap (and then get Apache 2.2.21 as a bonus). As long as you use a nonsupported version, you will have many more vulnarabilities the just the one you mention here.
    Henk van Velden

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Apache/2.2.15 (Linux/SUSE) Upgrade

    On 2012-06-04 15:16, htbsupport wrote:

    > Can you please help me on this ?


    11.3 is not supported. If you want to keep using it, you have to create the
    updates yourself, and for that, you need to be an expert not needing to ask
    such questions.

    Basically, you need to download the sources and compile them.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Apache/2.2.15 (Linux/SUSE) Upgrade

    On 2012-06-04 17:01, Carlos E. R. wrote:
    > On 2012-06-04 15:16, htbsupport wrote:
    >
    >> Can you please help me on this ?

    >
    > 11.3 is not supported. If you want to keep using it, you have to create the
    > updates yourself, and for that, you need to be an expert not needing to ask
    > such questions.
    >
    > Basically, you need to download the sources and compile them.


    Forgot to mention, that you also need to plug the security holes in the
    rest of the system, not only apache. Ie, maintain it completely and wholly
    on your own.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •