Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Missing applications from launcher menu after update of LXDE

  1. #1
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Missing applications from launcher menu after update of LXDE

    Hello All

    I'm using openSuse 12.1, with LXDE desktop.
    I updated the latest updates of LXDE, and now all the applications from the launch menu dissapered. all i have is Accessories with 3 applications, Run and Logout.

    Any way to get them back ?

    thanks
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Missing applications from launcher menu after update of LXDE

    Argoson wrote:

    > I updated the latest updates of LXDE,


    How did you do this

    Post result of
    zypper lr -d

  3. #3
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Missing applications from launcher menu after update of LXDE

    Quote Originally Posted by caf4926 View Post
    Argoson wrote:

    > I updated the latest updates of LXDE,


    How did you do this

    Post result of
    zypper lr -d
    I have to mention that the applications where not actualy deleted, hust the menu entries - the shortcuts.
    I have the LXDE repo enabled and i ran a zypper ref->up
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Missing applications from launcher menu after update of LXDE

    Argoson wrote:

    > i ran a zypper ref->up

    Is not sufficient

    You should use the package switcher on that repo from in software management
    or do
    zypper dup -r <reponame>

  5. #5
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Missing applications from launcher menu after update of LXDE

    Quote Originally Posted by caf4926 View Post
    Argoson wrote:

    > i ran a zypper ref->up

    Is not sufficient

    You should use the package switcher on that repo from in software management
    or do
    zypper dup -r <reponame>
    No, that's not the solution. it just makes things worst.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,202
    Blog Entries
    15

    Default Re: Missing applications from launcher menu after update of LXDE

    Quote Originally Posted by Argoson
    caf4926;2466330 Wrote:
    > Argoson wrote:
    >
    > > i ran a zypper ref->up

    > Is not sufficient
    >
    > You should use the package switcher on that repo from in software
    > management
    > or do
    > zypper dup -r <reponame>


    No, that's not the solution. it just makes things worst.

    Hi
    Rebuild the database and icon cache;
    Code:
    update-desktop-database --quiet /usr/share/applications
    gtk-update-icon-cache --quiet --force /usr/share/icons/<your_theme_directory>
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 4:05, 4 users, load average: 0.01, 0.02, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  7. #7
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Missing applications from launcher menu after update of LXDE

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Rebuild the database and icon cache;
    Code:
    update-desktop-database --quiet /usr/share/applications
    gtk-update-icon-cache --quiet --force /usr/share/icons/<your_theme_directory>
    No, still not resolved.

    I checked the ~/.cache directory, and i found one file with a very long name made from numbers and characters. it is a text file containing the entire tree of shortcuts for the start menu. it containes all the missing application shortcuts.
    i renamed it and rebooted. the file was recreated and it is exactly the same as the old one. but still, the shortcuts are not shown.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,202
    Blog Entries
    15

    Default Re: Missing applications from launcher menu after update of LXDE

    Quote Originally Posted by Argoson
    malcolmlewis;2466694 Wrote:
    > Hi
    > Rebuild the database and icon cache;
    > >

    Code:
    --------------------
    > >

    > update-desktop-database --quiet /usr/share/applications
    > gtk-update-icon-cache --quiet

    --force /usr/share/icons/<your_theme_directory> >
    --------------------
    > >

    >


    No, still not resolved.

    I checked the ~/.cache directory, and i found one file with a very long
    name made from numbers and characters. it is a text file containing the
    entire tree of shortcuts for the start menu. it containes all the
    missing application shortcuts.
    i renamed it and rebooted. the file was recreated and it is exactly
    the same as the old one. but still, the shortcuts are not shown.

    Hi
    Create a test user login and just check if the issue is still present.
    If it is then did you run the updating on the system, else do you have
    and custom icon's or themes running?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 4:51, 3 users, load average: 0.01, 0.02, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  9. #9
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Missing applications from launcher menu after update of LXDE

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Create a test user login and just check if the issue is still present.
    If it is then did you run the updating on the system, else do you have
    and custom icon's or themes running?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 4:51, 3 users, load average: 0.01, 0.02, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU
    I created a test user and it is the same - all the shortcut icons, except for 3 under Accessories are gone. I do not use a custom theme and icons. just the standard ones.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Missing applications from launcher menu after update of LXDE

    Argoson wrote:

    > I created a test user and it is the same -

    But you never showed us

    zypper lr -d

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •