Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problems when trying to update packages (again)

  1. #1

    Default Problems when trying to update packages (again)

    I was doing a system update (after a long while since last time) by applying package switch to my repos and leaving Packman at last. But when finally trying to apply switch to Packman I got these warnings:

    Code:
    libavcodec53-0.10.2-2.1.x86_64 requires libavutil51 = 0.10.2, but this requirement cannot be met
        deleted providers: libavutil51-0.10.2-2.1.x86_64
        *uninstallation of libavcodec53-0.10.2-2.1.x86_64
        *keep old libavutil51-0.10.2-2.1.x86_64
        *break libavcodec53 ignoring some of its dependencies
    
    libavformat53-0.10.2-2.1.x86_64 requires libavfilter2 = 0.10.2, but this requirement cannot be met
        deleted providers: libavfilter2-0.10.2-2.1.x86_64
        *uninstallation of libavformat53-0.10.2-2.1.x86_64
        *keep old libavfilter2-0.10.2-2.1.x86_64
        *break libavformat53 ignoring some of its dependencies
    
    libavdevice53-0.10.2-2.1.x86_64 requires libavformat.so.53()(64bit), but this requirement cannot be met
        deleted providers: libavformat53-0.10.2-2.1.x86_64
        *uninstallation of libavdevice53-0.10.2-2.1.x86_64
        *keep old libswscale2-0.10.2-2.1.x86_64
        *break libavdevice53 ignoring some of its dependencies
    
    libavcodec53-0.10.2-2.1.x86_64 requires libavutil51 = 0.10.2, but this requirement cannot be met
        deleted providers: libavutil51-0.10.2-2.1.x86_64
        *uninstallation of ffmpeg-0.10.2-2.1.x86_64
        *uninstallation of libopencv2_3-2.3.1a-4.1.2.x86_64
        *keep old ffmpeg-0.10.2-2.1.x86_64
        *keep old ffmpeg-0.10.2-2.1.x86_64
        *break libavcodec53 ignoring some of its dependencies
    I remember I had a similar issue before and was suggested to keep old package, but back then there was only one package warning (I don't remember which one was), now I'm getting several, and the last one seems a bit more weird. Not only more available options, but 2 of them are repeated for some reason.

    What should I do? Keep all old packages again? I assume I'm getting this because Packman's changing as well as its packages, and probably some of them were deleted... But then how can I know what to do when I get these warning again?

    Also, what should I do first, try to update Packman and the rest of system packages, or updating GNOME to 3.4 by adding repo and applying switch?
    Thanks for your help.

    P.D: is there a place where the above package warnings are stored? Translating can be a bit tedious, since I don't like to use Google or Babelfish translators...

  2. #2

    Default Re: Problems when trying to update packages (again)

    If you need ffmpeg/libav* 0.10.x, in the cases where it says "Y requires libavutil51 = 0.10.x" answer "break Y ignoring some of its dependencies". Otherwise just remove those libav* 0.10.x.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Problems when trying to update packages (again)

    F style wrote:

    > uninstallation of libavcodec53-0.10.2-2.1.x86_64

    *uninstallation of libavformat53-0.10.2-2.1.x86_64
    uninstallation of libavdevice53-0.10.2-2.1.x86_64

    See where that gets you
    That's what I did

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems when trying to update packages (again)

    On 2012-05-30 07:06, F style wrote:
    >
    > I was doing a system update (after a long while since last time) by
    > applying package switch to my repos and leaving Packman at last. But
    > when finally trying to apply switch to Packman I got these warnings:


    Wait.
    Then
    Wait longer.

    :-)

    > P.D: is there a place where the above package warnings are stored?
    > Translating can be a bit tedious, since I don't like to use Google or
    > Babelfish translators...


    Code:
    LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8  zypper whatever...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: Problems when trying to update packages (again)

    I recently saw this thread, from more than 2 days ago. Seemingly Packman was (or is still) suffering changes and updates in its packages, and they said the repo would be stable again by now (or yesterday).

    I tried again updating Packman applying switch and the only difference is, from the 4 warnings mentioned above, now I'm not getting the last one, but the other 3 I'm still. Is this still due to what the mentioned thread is about? Or is Packman already "fixed" and should I try the uninstallation option, or just wait?

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Problems when trying to update packages (again)

    F style wrote:

    > should I try the
    > uninstallation option, or just wait?
    >

    If you can't figure it out, just wait

  7. #7

    Default Re: Problems when trying to update packages (again)

    Sorry to bring this again. I first decided to wait and see if something changed. But it's been a fair while since last time I did a general update and I recently tried again and I'm still getting the 3 first warnings I mentioned in the first post of this thread. I searched again in the forums and found that apparently libavcodec53 (and probably the other lib's 53) became obsolete, being replaced by version 54, and I thought that can be the reason of the dependency problems.

    So, can I just go for the uninstalling option? Also, can I do it by applying switch in Software Manager or by using Zypper up in console?

    Finally, and probably is a bit offtopic, but if I want to also upgrade to GNOME 3.4 by adding its repo and applying switch to it, what should I do first? Update Packman or GNOME?

    Thanks for your help.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems when trying to update packages (again)

    On 2012-07-14 21:46, F style wrote:
    > So, can I just go for the uninstalling option? Also, can I do it by
    > applying switch in Software Manager or by using Zypper up in console?


    My preferred method of using packman is by clicking on every single package in yast and trigger
    its update. Tedious, but it works. Once switched, I right click and select update to newer
    version if available.


    > Finally, and probably is a bit offtopic, but if I want to also upgrade
    > to GNOME 3.4 by adding its repo and applying switch to it, what should I
    > do first? Update Packman or GNOME?


    As you have problems with packman, don't try a different upgrade with a new set of problems ;-)


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



  9. #9

    Default Re: Problems when trying to update packages (again)

    Quote Originally Posted by robin_listas View Post
    My preferred method of using packman is by clicking on every single package in yast and trigger
    its update. Tedious, but it works. Once switched, I right click and select update to newer
    version if available.
    Detail is, the 3 packages that are giving me trouble (libavcodec, libavformat, libavdevice) are one of the many to be updates (highlighted in blue). Right now I have installed version 52 for the 3 of them, I guess there's a problem to update them to version 53, and maybe asking to "uninstall" them to be replaced by version 54?
    The ones highlighted in red (downgrades) seem to be only lower compilations, not lower versions...

    Quote Originally Posted by robin_listas View Post
    As you have problems with packman, don't try a different upgrade with a new set of problems ;-)
    So if I manage to solve Packman, can I go for GNOME 3.4? I heard 3.4 is now stable to upgrade...

  10. #10

    Default Re: Problems when trying to update packages (again)

    Quote Originally Posted by F_style View Post
    libavcodec53 (and probably the other lib's 53) became obsolete, being replaced by version 54, and I thought that can be the reason of the dependency problems.

    So, can I just go for the uninstalling option? Also, can I do it by applying switch in Software Manager or by using Zypper up in console?
    Not really replaced. But yes, you can uninstall them.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •