Results 1 to 8 of 8

Thread: The following package updates will NOT be installed:

  1. #1

    Default The following package updates will NOT be installed:

    I've been getting this for awhile but never really thought much of it but I get a long list of packages when I do an update with zypper. I didn't know if my situation was similiar to the post http://forums.opensuse.org/english/g...installed.html because our packages aren't the same.


    Code:
    Repository 'Kernel Builds for stable (standard)' is up to date.
    Repository 'Main Repository (NON-OSS)' is up to date.
    Repository 'Main Repository (OSS)' is up to date.
    Repository 'Main Update Repository' is up to date.
    Repository 'kde-extra' is up to date.
    Repository 'kde48' is up to date.
    Repository 'Mozilla based projects (openSUSE_12.1)' is up to date.
    Repository 'Packman Repository' is up to date.
    All repositories have been refreshed.
    static2k@laptop:~> zu
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      bootsplash-branding-openSUSE branding-openSUSE ffmpeg gfxboot-branding-openSUSE ggz-client-libs gimp-branding-openSUSE 
      gstreamer-0_10-plugin-gnomevfs kdebase4-openSUSE kdebase4-runtime-branding-openSUSE kdebase4-workspace-branding-openSUSE 
      kdelibs4-branding-openSUSE kdm-branding-openSUSE kernel-default-devel kernel-desktop kernel-desktop-devel kernel-devel 
      kernel-firmware kernel-source kernel-syms kernel-xen-devel kio_sysinfo kio_sysinfo-branding-openSUSE 
      ksplashx-branding-openSUSE liba52-0 libavfilter2 libavutil51 libfaac0 libfaad2 libfreebl3 libfreebl3-32bit libggz2 
      libgstapp-0_10-0 libmms0 libmp3lame0 libnsssharedhelper0 libopencore-amrnb0 libopencore-amrwb0 libpostproc52 libquicktime0 
      libsoftokn3 libsoftokn3-32bit libswresample0 libswscale2 libtwolame0 libvlc5 libvlccore5 libwavpack1 libxine2-codecs 
      mjpegtools MozillaFirefox-branding-openSUSE mozilla-kde4-integration mozilla-nspr mozilla-nspr-32bit mozilla-nss 
      mozilla-nss-32bit mozilla-nss-certs mozilla-nss-certs-32bit sox susegreeter-branding-openSUSE vlc vlc-aout-pulse vlc-gnome 
      vlc-noX vlc-qt wallpaper-branding-openSUSE yast2-qt-branding-openSUSE
    List of repos.

    Code:
    ---+-------------------------------+----------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
     1 | Kernel_stable                 | Kernel Builds for stable (standard)    | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/standard/                 |        
     2 | download.opensuse.org-non-oss | Main Repository (NON-OSS)              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/non-oss/                       |        
     3 | download.opensuse.org-oss     | Main Repository (OSS)                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/oss/                           |        
     4 | download.opensuse.org-update  | Main Update Repository                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.1/                                          |        
     5 | kde-extra                     | kde-extra                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/ |        
     6 | kde48                         | kde48                                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/          |        
     7 | mozilla                       | Mozilla based projects (openSUSE_12.1) | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_12.1/                   |        
     8 | packman.inode.at-suse         | Packman Repository                     | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.1/                                                 |        
     9 | repo-debug                    | openSUSE-12.1-Debug                    | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.1/repo/oss/                     |        
    10 | repo-debug-update             | openSUSE-12.1-Update-Debug             | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.1/                                    |        
    11 | repo-source                   | openSUSE-12.1-Source                   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.1/repo/oss/                    |

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,044

    Default Re: The following package updates will NOT be installed:

    On Sun, 27 May 2012 18:26:03 +0000, Static2k wrote:

    > I've been getting this for awhile but never really thought much of it
    > but I get a long list of packages when I do an update with zypper


    In my experience, this happens when the updated package is in a different
    repository. You can override it by going into YaST's software management
    and electing to install the updated packages.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: The following package updates will NOT be installed:

    I have no problem receiving updated packages when I do an update I just always see those listed under "The following package updates will NOT be installed:".

    From the referenced post I tried zypper dup -r pacman and received

    Code:
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    14 Problems:
    Problem: nothing provides libSDL-1.2.so.0 needed by mjpegtools-2.0.0-42.1.i586
    Problem: nothing provides libQtCore.so.4 needed by kscd-4.7.2-3.1.7.i586
    Problem: nothing provides libQtCore.so.4 needed by kio_audiocd-4.7.2-3.1.7.i586
    Problem: nothing provides libftgl.so.2()(64bit) needed by libprojectM2-2.0.1-5.4.x86_64
    Problem: nothing provides libftgl.so.2()(64bit) needed by libprojectM2-2.0.1-5.4.x86_64
    Problem: nothing provides libftgl.so.2()(64bit) needed by libprojectM2-2.0.1-5.4.x86_64
    Problem: nothing provides libftgl.so.2()(64bit) needed by libprojectM2-2.0.1-5.4.x86_64
    Problem: nothing provides libid3tag.so.0()(64bit) needed by libsox2-14.4.0-28.2.x86_64
    Problem: nothing provides libftgl.so.2()(64bit) needed by libprojectM2-2.0.1-5.4.x86_64
    Problem: libavcodec53-0.10.3-1.1.x86_64 requires libavutil51 = 0.10.3, but this requirement cannot be provided
    Problem: libavformat53-0.10.3-1.1.x86_64 requires libavfilter2 = 0.10.3, but this requirement cannot be provided
    Problem: nothing provides libftgl.so.2()(64bit) needed by libprojectM2-2.0.1-5.4.x86_64
    Problem: libavformat53-0.10.3-1.1.x86_64 requires libavfilter2 = 0.10.3, but this requirement cannot be provided
    Problem: nothing provides libbz2.so.1 needed by libavformat54-32bit-0.11-3.1.x86_64
    
    Problem: nothing provides libSDL-1.2.so.0 needed by mjpegtools-2.0.0-42.1.i586
     Solution 1: keep obsolete mjpegtools-1.9.0-24.1.2.x86_64
     Solution 2: break mjpegtools by ignoring some of its dependencies

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: The following package updates will NOT be installed:

    On 2012-05-27 21:36, Static2k wrote:
    >
    > I have no problem receiving updated packages when I do an update I just
    > always see those listed under "The following package updates will NOT be
    > installed:".


    For example, because updating would mean a change of vendor. No problem. It
    is just informing you.

    >
    > From the referenced post I tried zypper dup -r pacman and received


    You like living dangerously...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: The following package updates will NOT be installed:

    Quote Originally Posted by robin_listas View Post
    On 2012-05-27 21:36, Static2k wrote:
    >
    > I have no problem receiving updated packages when I do an update I just
    > always see those listed under "The following package updates will NOT be
    > installed:".


    For example, because updating would mean a change of vendor. No problem. It
    is just informing you.

    >
    > From the referenced post I tried zypper dup -r pacman and received


    You like living dangerously...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    I was just doing what was recommended in the referenced thread that actually fixed the issue...

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,044

    Default Re: The following package updates will NOT be installed:

    On Sun, 27 May 2012 19:36:02 +0000, Static2k wrote:

    > I have no problem receiving updated packages when I do an update I just
    > always see those listed under "The following package updates will NOT be
    > installed:".


    Well, yes, and that's because they're from a different repo than they
    were originally updated from.

    As for why the zypper dup fails, it seems that some dependencies aren't
    met and that's why it fails.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: The following package updates will NOT be installed:

    Am 27.05.2012 21:36, schrieb Static2k:
    > From the referenced post I tried zypper dup -r pacman


    I think what you really want is "zypper dup --from pacman" it is not
    exactly the same as with -r.

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.3 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.3 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: The following package updates will NOT be installed:

    On 2012-05-27 22:26, Static2k wrote:

    > I was just doing what was recommended in the referenced thread that
    > actually fixed the issue...


    You must remember that the message "The following package updates will NOT
    be installed:" is not a problem. It is as if you take your car to the
    repair shop and they tell you that they will not replace the wheels. So
    what? Do they need replacing? It just means that he has wheels of titanium
    type but you have not authorized titanium explicitly.

    A zypper dup to packman will replace all sort of packages, not just
    multimedia, to the packman version, and that is not necessarily good.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •