Results 1 to 5 of 5

Thread: GNOME 3.4 problem

  1. #1

    Default GNOME 3.4 problem

    Hi,

    recently upgraded my 12.1 to use GNOME 3.4 from the repository located at Index of /repositories/GNOME:/STABLE:/3.4

    the upgrade seem to have gone allright.
    but after i login, i start to notice issues.

    First i cant start nautilus, i get :
    (nautilus:4445): GLib-GObject-WARNING **: specified class size for type `NautilusApplication' is smaller than the parent type's `GtkApplication' class size

    (nautilus:4445): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

    (nautilus:4445): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

    (nautilus:4445): GLib-GIO-CRITICAL **: g_application_run: assertion `G_IS_APPLICATION (application)' failed

    (nautilus:4445): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

    When i try to start eog, problems aswell.

    Anyone running this repository without problems? how did u upgrade?
    did you do like i did, add repo, zypper dup?!


    sry didnt know if this was supposed to go in Beta or here...

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: GNOME 3.4 problem

    smurfd wrote:

    >
    > Hi,
    >
    > recently upgraded my 12.1 to use GNOME 3.4 from the repository located
    > at 'Index of /repositories/GNOME:/STABLE:/3.4'
    > (http://download.opensuse.org/reposit...:/STABLE:/3.4/)
    >
    > the upgrade seem to have gone allright.
    > but after i login, i start to notice issues.
    >
    > First i cant start nautilus, i get :
    > (nautilus:4445): GLib-GObject-WARNING **: specified class size for type
    > `NautilusApplication' is smaller than the parent type's `GtkApplication'
    > class size
    >
    > (nautilus:4445): GLib-CRITICAL **: g_once_init_leave: assertion `result
    > != 0' failed
    >
    > (nautilus:4445): GLib-GObject-CRITICAL **: g_object_new: assertion
    > `G_TYPE_IS_OBJECT (object_type)' failed
    >
    > (nautilus:4445): GLib-GIO-CRITICAL **: g_application_run: assertion
    > `G_IS_APPLICATION (application)' failed
    >
    > (nautilus:4445): GLib-GObject-CRITICAL **: g_object_unref: assertion
    > `G_IS_OBJECT (object)' failed
    >
    > When i try to start eog, problems aswell.
    >
    > Anyone running this repository without problems? how did u upgrade?
    > did you do like i did, add repo, zypper dup?!
    >
    >
    > sry didnt know if this was supposed to go in Beta or here...
    >
    >
    > --
    > smurfd
    > ------------------------------------------------------------------------
    > smurfd's Profile: http://forums.opensuse.org/member.php?userid=7765
    > View this thread: http://forums.opensuse.org/showthread.php?t=475556


    You should have used the package switcher on the new repo- not zypper dup


  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: GNOME 3.4 problem

    Quote Originally Posted by caf4926
    smurfd wrote:

    >
    > Hi,
    >
    > recently upgraded my 12.1 to use GNOME 3.4 from the repository located
    > at 'Index of /repositories/GNOME:/STABLE:/3.4'
    > (http://download.opensuse.org/reposit...:/STABLE:/3.4/)
    >
    > the upgrade seem to have gone allright.
    > but after i login, i start to notice issues.
    >
    > First i cant start nautilus, i get :
    > (nautilus:4445): GLib-GObject-WARNING **: specified class size for
    > type `NautilusApplication' is smaller than the parent type's
    > `GtkApplication' class size
    >
    > (nautilus:4445): GLib-CRITICAL **: g_once_init_leave: assertion
    > `result != 0' failed
    >
    > (nautilus:4445): GLib-GObject-CRITICAL **: g_object_new: assertion
    > `G_TYPE_IS_OBJECT (object_type)' failed
    >
    > (nautilus:4445): GLib-GIO-CRITICAL **: g_application_run: assertion
    > `G_IS_APPLICATION (application)' failed
    >
    > (nautilus:4445): GLib-GObject-CRITICAL **: g_object_unref: assertion
    > `G_IS_OBJECT (object)' failed
    >
    > When i try to start eog, problems aswell.
    >
    > Anyone running this repository without problems? how did u upgrade?
    > did you do like i did, add repo, zypper dup?!
    >
    >
    > sry didnt know if this was supposed to go in Beta or here...
    >
    >
    > --
    > smurfd
    > ------------------------------------------------------------------------
    > smurfd's Profile: http://forums.opensuse.org/member.php?userid=7765
    > View this thread: http://forums.opensuse.org/showthread.php?t=475556


    You should have used the package switcher on the new repo- not zypper
    dup
    Hi
    The correct way to upgrade is via zypper dup but use the --from
    switch eg;
    Code:
    zypper dup --from <your GS34 repo name>
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 16:00, 3 users, load average: 0.03, 0.04, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  4. #4

    Default Re: GNOME 3.4 problem

    Quote Originally Posted by malcolmlewis View Post
    Hi

    The correct way to upgrade is via zypper dup but use the --from
    switch eg;
    Code:
    zypper dup --from <your GS34 repo name>
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 16:00, 3 users, load average: 0.03, 0.04, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU
    allright, i will try that when i get home. Thanks!!

  5. #5

    Default Re: GNOME 3.4 problem

    Quote Originally Posted by malcolmlewis View Post
    Hi
    The correct way to upgrade is via zypper dup but use the --from
    switch eg;
    Code:
    zypper dup --from <your GS34 repo name>
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 16:00, 3 users, load average: 0.03, 0.04, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU
    Is this the console equivalent to use package switcher on Software Manager after adding the repo, as mr. Caf says?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •