Results 1 to 6 of 6

Thread: Bug in GAWK 4.0.0, an update needed in openSUSE 12.1

  1. #1

    Default Bug in GAWK 4.0.0, an update needed in openSUSE 12.1

    Hi,

    There is a bug in GAWK 4.0.0 which prevents many of my scripts to run correctly. (The bug affects the ability of GAWK to skip a header in a text file via using getline in the BEGIN section.) The bug has already been reported and fixed, see e.g. Re: [bug-gawk] getline change of behavior in 4.0.0 . It would make my life much easier if openSUSE 12.1 updated the gawk-4.0.0-*.rpm package in the repository. I know that typically only security holes are fixed via online updates, but this bug is so bad that it should also be fixed via online updates. What can I do to make it happen?

    Regards,
    Alex

  2. #2

    Default Re: Bug in GAWK 4.0.0, an update needed in openSUSE 12.1

    It is available in several projects and in factory (4.0.1). Maybe one of those will work for you.
    https://build.opensuse.org/search/se...29&issue_name=

    Otherwise you can still patch it and build it yourself - I mean create you own repo in OBS and install from there. That's what I would do.

  3. #3

    Default Re: Bug in GAWK 4.0.0, an update needed in openSUSE 12.1

    Quote Originally Posted by amalusek View Post
    I know that typically only security holes are fixed via online updates
    That's not really true. The policy is this: openSUSE:Maintenance policy - openSUSE and it's quite open.

    Quote Originally Posted by amalusek View Post
    but this bug is so bad
    Yeah, well... all bugs are soooooo bad when they affect us.

    Quote Originally Posted by amalusek View Post
    it should also be fixed via online updates. What can I do to make it happen?
    Just report the bug in https://bugzilla.novell.com/ and convince the packager the bug is important enough to make him expend some time releasing an update for 12.1. (Hint: There are a few million users of openSUSE, If let's say... fifty people would report the bug a patch would be released for sure)

  4. #4

    Default Re: Bug in GAWK 4.0.0, an update needed in openSUSE 12.1

    Thanks for the reply. Finally, I've used gawk-4.0.1-1.4.x86_64.rpm from the Factory.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Bug in GAWK 4.0.0, an update needed in openSUSE 12.1

    On 2012-05-22 11:46, amalusek wrote:
    > What can I do to make it
    > happen?


    Report in Bugzilla, of course.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6

    Default Re: Bug in GAWK 4.0.0, an update needed in openSUSE 12.1

    Quote Originally Posted by RedDwarf View Post
    Yeah, well... all bugs are soooooo bad when they affect us.
    This one may silently corrupt user's data. Crashing programs are also bad, but at least you know that something is wrong.

    Quote Originally Posted by RedDwarf View Post
    Just report the bug in https://bugzilla.novell.com/ and convince the packager the bug is important enough to make him expend some time releasing an update for 12.1. (Hint: There are a few million users of openSUSE, If let's say... fifty people would report the bug a patch would be released for sure)
    OK. I've reported the bug: https://bugzilla.novell.com/show_bug.cgi?id=763437

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •