Results 1 to 4 of 4

Thread: Could not start ksmserver. Check your installation.

  1. #1

    Default Could not start ksmserver. Check your installation.

    Whenever I try to login in KDE I get this message: "Could not start ksmserver. Check your installation." I can only login in iceWM and TWM.
    Last thing I did before reboot is that I upgraded some packages ,although I don't think something KDE related, and... I launched qtconfig as root.
    I'm using openSUSE 12.1 x86_64, KDE 4.7.2

  2. #2
    Join Date
    Sep 2009
    Location
    UK
    Posts
    266

    Default Re: Could not start ksmserver. Check your installation.

    Update gstreamer

    Took me ages to find this one ...

    :-)

    M

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,489
    Blog Entries
    48

    Smile Re: Could not start ksmserver. Check your installation.

    Quote Originally Posted by ntasos View Post
    Whenever I try to login in KDE I get this message: "Could not start ksmserver. Check your installation." I can only login in iceWM and TWM.
    Last thing I did before reboot is that I upgraded some packages ,although I don't think something KDE related, and... I launched qtconfig as root.
    I'm using openSUSE 12.1 x86_64, KDE 4.7.2
    If this was me, I would use this as an excuse to upgrade to KDE 4.8.3, the latest stable release of KDE. FIrst, remove any specific and older KDE repositories. Its OK to keep all of the original openSUSE repositories and the Packman repository. Then add in the following two:

    Upstream release aka. KR48 (KDE SC 4.8)

    The latest stable point release of KDE SC 4.8. Use these repositories, if you want to have the latest version of KDE.

    Version: 12.1 (Do Not Copy the quotes)

    Core packages: "http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/"
    Extra: "http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/"
    I normally first go to repositories and add these two, removing any other KDE specific repositories if they have been added then go to Software Management and switch to these two new repositories.

    YaST / Software / Software Management / Select View Button / Repositories / Select KDE:/Release:/48 / Switch system packages / Select View Button / Repositories / KDE:/Extra / Switch system packages


    If you get any package conflicts, always take the new 4.8 KDE version. The only exception are packages from Packman, which I suggest you keep. As general rule I always suggest this:

    To avoid package problems, the most important thing to do is to: **NEVER**
    ignore a dependency, even if YaST/zypper/updater gives you such an option!
    In general, never switch to an >inferior< architecture and the solution is
    most often to just switch Vendor to the >Packman< repository. So changing
    the vendor is OK, but >ignoring< dependencies is never a very good idea!
    Thank You,

    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: Could not start ksmserver. Check your installation.

    Quote Originally Posted by interele View Post
    Update gstreamer

    Took me ages to find this one ...

    :-)

    M
    I upgraded gstreamer to packman versions and everything works now, thanks a lot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •