Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to change number of characters in line in Terminal.

  1. #1

    Question How to change number of characters in line in Terminal.

    I would like to see more then 80 characters in one line, but I did not find where should I change this parameter. Please advice!
    I think it does not matter what version of SUSE I use, because it is a general question related to any versions.
    But if it important I use OpenSUSE 12.1
    Thank you for your time and consideration!

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: How to change number of characters in line in Terminal.

    Quote Originally Posted by garg View Post
    I would like to see more then 80 characters in one line, but I did not find where should I change this parameter. Please advice!
    I think it does not matter what version of SUSE I use, because it is a general question related to any versions.
    But if it important I use OpenSUSE 12.1
    Thank you for your time and consideration!
    You'll have to provide more info, such as which desktop you’re using and which terminal. In the Gnome terminal, for example, you'll find this in Edit->Preferences, but others will be different.

  3. #3

    Default Re: How to change number of characters in line in Terminal.

    System: openSUSE 12.1 (x86_64)
    KDE: 4.7.2 (4.7.2) "release 5"

    I'm not sure what should I provide else... Is it enough?

  4. #4

    Default Re: How to change number of characters in line in Terminal.

    This question stand up, because respond from DB looks little messy,see below:

  5. #5

    Default Re: How to change number of characters in line in Terminal.

    Try typing the following command in your terminal:
    Code:
    resize
    For more info see man resize.

  6. #6
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: How to change number of characters in line in Terminal.

    Whithout having used this, what I think you need to look into is the stty command.
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,733

    Default Re: How to change number of characters in line in Terminal.

    Quote Originally Posted by garg View Post
    System: openSUSE 12.1 (x86_64)
    KDE: 4.7.2 (4.7.2) "release 5"

    I'm not sure what should I provide else... Is it enough?
    Besides that it is allways important which openSUSE level (you doubted about this above) and very often the desktop and it's level, in this case it is of course also which terminal emulator do you use. For KDE, most use Konsole, but there are more.

    And about Konsole:
    I remember it was once possible to start it with options that told it to open with so many chars/lines, but this was dropped in a new version (do not ask me why, I was very upset at the time, and I fell rage allready growing inside me). Since then it is almost impossible to have Konsole at a pecific number of characters/lines. But my experience is that when you resize the window, this is detected
    E.g. when I have a file with a long line and do a cat of it, it wraps at the end. When I then widen the window by pulling the right border, and cat again, the new output will wrap in the new space. Editing that file with vi will even dynamicaly rewrap during the pull/push of the border.
    Henk van Velden

  8. #8
    Join Date
    Jun 2008
    Location
    Schenectady, NY
    Posts
    138

    Default Re: How to change number of characters in line in Terminal.

    Quote Originally Posted by garg View Post
    This question stand up, because respond from DB looks little messy,see below:
    You need to change your sqlplus settings, it ignores your actual terminal size.

    sqlplus pagesize and linesize | Anatta Technologies

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to change number of characters in line in Terminal.

    On 2012-05-16 05:26, garg wrote:
    >
    > This question stand up, because respond from DB looks little messy,see
    > below:
    > [image: http://img254.imageshack.us/img254/3...apshot1oy.png]


    Try another terminal, there are several

    Do you experience the problem with any program, or just with sql? Because
    it may be that software which limits to 80 chars, not the terminal.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10

    Default Re: How to change number of characters in line in Terminal.

    This is good point, b'cause I got the same problem on Windows cmd prompt,
    doesn't matter that I changed size in cmd properties, it was huge size window with 80-char line text inside. Thank you I will try it!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •