Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: поломался Gstreamer

  1. #1
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default поломался Gstreamer

    после последнего обновления из Packman - mp3 не играет.

    Самый адекватный вывод у Rhythmbox:
    Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер MPEG-1 Layer 3 (MP3)|decoder-audio/mpeg, mpegversion=(int)1, layer=(int)3
    Rhythmbox-Message: Automatic missing codec installation not supported (helper script missing)
    Но состав пакетов при этом не менялся/ только обновления. Давненько подобных сюрпризов не встречал!

    Согласно странице плагинов:
    lame Encode MP3s with LAME gst-plugins-ugly 0.10.19.1
    ->
    Plugin Information

    filename
    libgstlame.so

    version
    0.10.19
    А на деле:
    Code:
    > rpm -ql gstreamer-0_10-plugins-ugly 
    /usr/lib/gstreamer-0.10/libgstcdio.so
    /usr/lib/gstreamer-0.10/libgstdvdlpcmdec.so
    /usr/lib/gstreamer-0.10/libgstdvdread.so
    /usr/lib/gstreamer-0.10/libgstdvdsub.so
    /usr/lib/gstreamer-0.10/libgstrmdemux.so
    /usr/lib/gstreamer-0.10/libgstsid.so
    /usr/lib/gstreamer-0.10/libgstsynaesthesia.so
    /usr/share/doc/packages/gstreamer-0_10-plugins-ugly
    /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/AUTHORS
    /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/COPYING
    /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/NEWS
    /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/README
    /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/RELEASE
    /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/REQUIREMENTS

  2. #2
    Join Date
    Aug 2010
    Location
    Russia
    Posts
    995

    Default Re: поломался Gstreamer

    А что mplayer в консоль выдаёт? Заодно вывод rpm -q gstreamer-0_10-plugins-ugly и zypper if gstreamer-0_10-plugins-ugly в студию.

  3. #3
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: поломался Gstreamer

    но mplayer не использует gstreamer, он-то нормально все воспроизводит:

    Playing 02 - Nova Era.mp3.
    libavformat version 54.2.100 (internal)
    Audio only file format detected.
    Clip info:
    <...>
    Load subtitles in ./
    ==========================================================================
    Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
    AUDIO: 44100 Hz, 2 ch, s16le, 320.0 kbit/22.68% (ratio: 40000->176400)
    Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
    ==========================================================================
    Code:
    > rpm -q gstreamer-0_10-plugins-ugly
    gstreamer-0_10-plugins-ugly-0.10.19-34.4.i586
    
    > rpm -q gstreamer-0_10-plugins-ugly
    Сведения — пакет gstreamer-0_10-plugins-ugly:
    
    Репозиторий: @System
    Имя: gstreamer-0_10-plugins-ugly
    Версия: 0.10.19-34.4
    Архитектура: i586
    Производитель: PackMan :: Startseite
    Установлен: Да
    Состояние: актуален
    Размер после установки: 364,0 KiB
    Сводка: GStreamer Streaming-Media Framework Plug-Ins
    Описание: 
    <...>
    (лишнее подсократил)

  4. #4
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: поломался Gstreamer

    нет, кажется не в этом дело:
    посмотрел состав gstreamer-0_10-plugins-ugly-0.10.9-3.1.i586.rpm - такой же.

  5. #5
    Join Date
    Jun 2008
    Location
    Saint-Petersburg, Russia
    Posts
    69

    Default Re: поломался Gstreamer

    А gstreamer-0_10-plugins-ugly-orig-addon установлен?

  6. #6
    Join Date
    Aug 2010
    Location
    Russia
    Posts
    995

    Default Re: поломался Gstreamer

    Проблема со всеми плеерами использующими gstreamer или только с rythmbox?

  7. #7
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,995
    Blog Entries
    1

    Default Re: поломался Gstreamer

    kkirill wrote:

    > А gstreamer-0_10-plugins-ugly-orig-addon установлен?


    У меня установлен этот пакет,и mp3 воспроизводятся.
    libgstlame.so находится именно в нём.


  8. #8
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: поломался Gstreamer

    Lazy_Kent, спасибо, установил- так все Ок.

    Но я не понимаю, как же оно декодировалось раньше, поскольку это пакета совершенно точно не помню у себя в системе, "пруф":
    Code:
    > cat /var/log/zypp/history | grep ugly-orig-addon
    2012-05-11 19:42:42|install|gstreamer-0_10-plugins-ugly-orig-addon|0.10.19-34.4 ..

  9. #9
    Join Date
    Jun 2008
    Location
    Saint-Petersburg, Russia
    Posts
    69

    Default Re: поломался Gstreamer

    С тех пор, как пакет разделили на две части, для поддержки mp3 и др. патентованных кодеков, нужно устанавливать *orig-addon, см. /dev/loki: What's an orig-addon ?
    По поводу проигрывания mp3, то есть ещё пакет gstreamer-0_10-fluendo-mp3 из официального non-oss репозитория.

  10. #10
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: поломался Gstreamer

    Quote Originally Posted by kkirill View Post
    С тех пор, как пакет разделили на две части ..
    Но это явно произошло не вчера. а zypp/history я привел примерно за полгода

    fluendo меня никогда не устраивало итоговым звучанием. Это конечно же чистое имхо и самовнушение, но все же..

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •