Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: yast install/remove software slow?

  1. #1

    Default yast install/remove software slow?

    I remember when 11.4 pop out I commented
    "yast install/remove software is a thunderbolt!!!! very fast :-) "
    is there any reasonable why becouse now is so slow?? about 15minutes and more to show itself in its own amazing beauty seems much more than I waited before 11.4..
    have you the same behaviour??

  2. #2
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: yast install/remove software slow?

    On Tue, 08 May 2012 21:26:02 +0530, pier andreit
    <pier_andreit@no-mx.forums.opensuse.org> wrote:

    >
    > I remember when 11.4 pop out I commented
    > "yast install/remove software is a thunderbolt!!!! very fast :-) "
    > is there any reasonable why becouse now is so slow?? about 15minutes
    > and more to show itself in its own amazing beauty seems much more than I
    > waited before 11.4..
    > have you the same behaviour??
    >


    i suspect it's because of your internet connection. a few things to check:

    * try using google's nameservers, at 8.8.8.8 and 8.8.4.4 instead of those
    provided by your internet provider;

    * are you using IP version 6, and does your provider as well as your rouer
    support this? if provider and/or router don't support IP ver. 6, you can
    disable it on your machine (YAST -> network devices), and then reboot.
    sometimes YAST tries to use IP v.6 addresses, even those aren't
    accessible, and that takes time;

    * try to access the URLs of your repo.s with a browser. most, but not all
    of them can be accessed via a web browser. if that doesn't work either,
    then there's something not working well in your internet connection. (i'm
    often having such issues, living in india. don't know where you are from.)

    --
    phani.

  3. #3

    Default Re: yast install/remove software slow?

    I seem to be getting the same issue.

    Quote Originally Posted by phanisvara View Post
    * try using google's nameservers, at 8.8.8.8 and 8.8.4.4 instead of those
    provided by your internet provider;
    I am using those (set in Network Devices and also in my router)

    Quote Originally Posted by phanisvara View Post
    * are you using IP version 6, and does your provider as well as your rouer
    support this? if provider and/or router don't support IP ver. 6, you can
    disable it on your machine (YAST -> network devices), and then reboot.
    sometimes YAST tries to use IP v.6 addresses, even those aren't
    accessible, and that takes time;
    Done it with and without ipv6 - no difference. And this problem just started occurring in the last few days. Before that there was no issue.

    Quote Originally Posted by phanisvara View Post
    * try to access the URLs of your repo.s with a browser. most, but not all
    of them can be accessed via a web browser. if that doesn't work either,
    then there's something not working well in your internet connection.
    Loads instantly in firefox

  4. #4
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: yast install/remove software slow?

    On Tue, 08 May 2012 22:06:03 +0530, 6tr6tr
    <6tr6tr@no-mx.forums.opensuse.org> wrote:

    >
    > I seem to be getting the same issue.
    >
    > phanisvara;2461369 Wrote:
    >>
    >> * try using google's nameservers, at 8.8.8.8 and 8.8.4.4 instead of
    >> those
    >> provided by your internet provider;
    >>

    > I am using those (set in Network Devices and also in my router)
    >
    > phanisvara;2461369 Wrote:
    >> * are you using IP version 6, and does your provider as well as your
    >> rouer
    >> support this? if provider and/or router don't support IP ver. 6, you
    >> can
    >> disable it on your machine (YAST -> network devices), and then reboot.
    >> sometimes YAST tries to use IP v.6 addresses, even those aren't
    >> accessible, and that takes time;
    >>

    > Done it with and without ipv6 - no difference. And this problem just
    > started occurring in the last few days. Before that there was no issue.
    >
    > phanisvara;2461369 Wrote:
    >>
    >> * try to access the URLs of your repo.s with a browser. most, but not
    >> all
    >> of them can be accessed via a web browser. if that doesn't work
    >> either,
    >> then there's something not working well in your internet connection.

    > Loads instantly in firefox
    >


    weird; this happened a while ago to me, but sue me, i don't remember what
    the problem was

    i've seen it recently here on the forums and also on the mailing list,
    with pretty much the same symptoms. looks as if either zypper insists on
    using ip v. 6, even though some link in the chain, possibly the server,
    doesn't support it, or the redirector ('mirror brain,' i think) messes
    things up.

    only one thing i can think of now, don't access via download.opensuse.org,
    but go to a known good mirror directly, and see if & how that works. if
    that should work ok, i suspect it's the redirection messing things up.

    --
    phani.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: yast install/remove software slow?

    On 2012-05-08 18:36, 6tr6tr wrote:

    >> then there's something not working well in your internet connection.

    > Loads instantly in firefox


    You have to look at zypper logs - there is internal redirection, the url of
    the repos is not the one actually used.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6

    Default Re: yast install/remove software slow?

    Quote Originally Posted by robin_listas View Post
    On 2012-05-08 18:36, 6tr6tr wrote:

    >> then there's something not working well in your internet connection.

    > Loads instantly in firefox


    You have to look at zypper logs - there is internal redirection, the url of
    the repos is not the one actually used.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    From the log file:

    Code:
    2012-05-07 12:38:31 <3> linux-box(7772) [zypp] MediaCurl.cc(doGetFileCopyFile):1410 curl error: 7: Failed to connect to 2001:67c:2178:8::13: Network is unreachable, temp file size 0 bytes.
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 MediaCurl.cc(evaluateCurlCode):1015 THROW:    Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error code: Connection failed
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 MediaCurl.cc(evaluateCurlCode):1019 RETHROW:  Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error code: Connection failed
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 MediaCurl.cc(doGetFileCopyFile):1422 RETHROW:  Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error code: Connection failed
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137
    2012-05-07 12:38:31 <1> linux-box(7772) [zypp] PathInfo.cc(unlink):670 unlink /var/adm/mount/AP_0x00000001/repodata/repomd.xml.new.zypp.35E5R3
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 MediaMultiCurl.cc(doGetFileCopy):1293 RETHROW:  Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error code: Connection failed
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 MediaCurl.cc(getFileCopy):859 RETHROW:  Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error code: Connection failed
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 MediaSetAccess.cc(provide):216 CAUGHT:   Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error code: Connection failed
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: yast install/remove software slow?

    On 2012-05-09 00:36, 6tr6tr wrote:
    > From the log file:
    >
    >
    > Code:
    > --------------------
    > 2012-05-07 12:38:31 <3> linux-box(7772) [zypp] MediaCurl.cc(doGetFileCopyFile):1410 curl error: 7: Failed to connect to 2001:67c:2178:8::13: Network is unreachable, temp file size 0 bytes.
    > 2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 MediaCurl.cc(evaluateCurlCode):1015 THROW: Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
    > 2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error code: Connection failed
    > 2012-05-07 12:38:31 <5> linux-box(7772) [zypp] Exception.cc(log):137 Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    > --------------------


    That is indeed the redirector, ftp.opensuse.org. Possibly above that
    paragraph there is another failed attempt to the IPv4 address of the same
    server.

    Tell you what. Create "/root/.curlrc", and write a line there with "--ipv4"
    only. It might impede curl, which is used by zypper, from attempting IPv6
    addresses. I do not know yet if it works.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  8. #8

    Default Re: yast install/remove software slow?

    where did you find your logs?? in my /var/log/zypper.log the last data is 2012-04-24, of course I used yast/ad-remove software after this data.
    ciao Pier

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: yast install/remove software slow?

    On 2012-05-09 15:46, pier andreit wrote:
    >
    > where did you find your logs?? in my /var/log/zypper.log the last data
    > is 2012-04-24, of course I used yast/ad-remove software after this data.



    /var/log/zypp/history
    /var/log/zypper.log
    /var/log/YaST2/y2log

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10

    Default Re: yast install/remove software slow?

    Quote Originally Posted by robin_listas View Post
    /var/log/zypp/history
    /var/log/zypper.log
    /var/log/YaST2/y2log

    Carlos E. R.
    Thankyou, this is my log of 10may2012, it starts at 19.01 and until about 19.10 no install/remove panel appear, then start to update and install software, I tryed to put this in suse paste too but seems to not works I tryed many times in other days, and it seems to be as slow as when the log refere to.
    Ciao, Pier

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •