Results 1 to 6 of 6

Thread: Suspend/logout problems in OpenSUSE 12.1+Xfce

  1. #1

    Default Suspend/logout problems in OpenSUSE 12.1+Xfce

    [newbie warning]

    Hello.

    When I try to suspend the computer, it does go off, but when I try to come back from suspension, I just get a full-black screen: There, nothing works (keyboard, mouse, soft-poweroff), and I'm forced to do a full poweroff by pressing the button for three seconds, then boot the system again.

    More: When I try to close the desktop session (through the same Xfce panel plugin that I used to suspend --a tooltip says it's linked to the process xfsm-logout-plugin-5), I get to a black screen with some artifacts and a big nVidia logo. I can move the mouse for some seconds (but no right click), then it freezes. No key combination works whatsoever (though there seems to be some "internal activity"), and the only thing I can do is a soft push of the power-off button, which starts the normal shutdown process ("normal" except for the fact that any key press, after shutdown, makes the machine reboot -- a full reboot, with grub, login and all).

    I tried starting a session in IceWM, but the "close session" action there had the same results, so I'm not sure if it has something to do with Xfce or not.

    I'm using OpenSUSE 12.1 and Xfce 4.8. Some hardware details:

    CPU: AMD AThlon XP 2800+
    Motherboard: ASUSTeK A7N8X-VM
    GPU: nVidia GeForce4 MX Integrated

    Some /etc/sysconfig settings are:

    DISPLAYMANAGER: lightdm
    DEFAULT_WM: xfce
    PM_PROFILER_PROFILE: balanced_low_latency
    HALT: auto

    I'm using the nVidia graphics driver for GeForce4 GPUs (x11-video-nvidia).

    Normally I don't use suspension, or close the session that way, so it's not a big problem, but of course I'd like those features to work, and understand a bit better the process, so I'd appreciate any help, or hints about what logs to look at, etc.

    This is my first real post here, you'll find that my nickname is not ironic!

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Suspend/logout problems in OpenSUSE 12.1+Xfce

    On 2012-05-04 19:06, infrauser wrote:
    >
    > [newbie warning]
    >
    > Hello.
    >
    > When I try to suspend the computer, it does go off, but when I try to
    > come back from suspension, I just get a full-black screen: There,
    > nothing works (keyboard, mouse, soft-poweroff), and I'm forced to do a
    > full poweroff by pressing the button for three seconds, then boot the
    > system again.


    Try suspend first from runlevel 3, text mode.

    And kill the splash:

    /etc/suspend.conf:

    Code:
    splash = n

    > This is my first real post here, you'll find that my nickname is not
    > ironic!


    Your login name is fore ever...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Talking Re: Suspend/logout problems in OpenSUSE 12.1+Xfce

    Thanks for the hints:
    Try suspend first from runlevel 3, text mode.
    This led me to this thread: Boot Into Run Level 3

    And to this wiki page: SDBm-utils - openSUSE

    I begin to understand it... I've also read a little bit about the xinitrc file (mine is the original template, untouched), and this thread in Arch forums. Finally, thanks to your...

    And kill the splash: /etc/suspend.conf:
    Code:
    splash = n
    ...I'm reading now my /etc/suspend.conf (which I never did before).

    I really appreciate the short answer, I'll try to follow your instructions and come back with some feedback (tomorrow!!!)

    Your login name is fore ever...
    Ah, but, you know... I'm an infra with attitude...

    It's plain to see, you can't change me
    Cause I'ma be an infra for life

    {*static noise*}

    I'm an infra, he's an infra, she's an infra, we some infraz
    Wouldn't you like to be an infra too?

    05:00Am ¡gracias! see you tomorrow

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Suspend/logout problems in OpenSUSE 12.1+Xfce

    On 2012-05-05 05:26, infrauser wrote:
    >
    > Thanks for the hints:
    >>
    >> Try suspend first from runlevel 3, text mode.
    >>

    > This led me to this thread: 'Boot Into Run Level 3'
    > (http://tinyurl.com/89l3db5)


    A bit old, though. Simply type a 3 on boot.

    Many suspending trouble are video related, so taking it out of the equation
    for a test helps.

    > And to this wiki page: 'SDBm-utils - openSUSE'
    > (http://en.opensuse.org/SDBm-utils)


    Yes, I forgot about that one. See the links there about suspend to disk or
    ram, too.

    > I begin to understand it... I've also read a little bit about the
    > xinitrc file (mine is the original template, untouched), and 'this
    > thread in Arch forums'
    > (https://bbs.archlinux.org/viewtopic.php?id=129623).


    Careful, very few people need to touch it.


    > ..I'm reading now my /etc/suspend.conf (which I never did before).
    >
    > I really appreciate the short answer, I'll try to follow your
    > instructions and come back with some feedback (tomorrow!!!)


    Good!

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: Suspend/logout problems in OpenSUSE 12.1+Xfce

    Ok. As you said, in /etc/suspend.conf I changed this (as root):
    Code:
    ## use splash picture? (default y)
    #splash = y
    for
    Code:
    ## use splash picture? (default y)
    splash = n
    Then I read the pm-suspend manual page. I like to read this documents, but truly understanding them is another thing completely...
    > Try suspend first from runlevel 3, text mode.
    >> This led me to this thread: 'Boot Into Run Level 3'
    >>> A bit old, though. Simply type a 3 on boot.
    Hey, the thread was old but they mentioned that! (thanks, didn't know)

    So I did it. Logged in as user in text mode, typed "su -" and tried the command "pm-suspend".

    It got suspended in 2-3 seconds: then, after a keypress, it seemed to recover (i mean: it made similar noises to the ones of a working system), but the monitor remained idle and i couldn't see anything. Ctrl+Alt+Supr made it reboot (so the system was responsive in some way, but I'd say suspend doesn't work in text mode either, do you agree?).

    After the reboot I entered into text mode again, logged in, typed "startxfce4", and I got an error:

    Code:
    Fatal server error:
    Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"
    
    Please consult the X.Org Foundation support at http://wiki.x.org for help
    
    xinit: giving up
    xinit: unable to connect to X server - connection refused
    xinit: server error
    Next, I tried the command "startx", and got a warning saying I should use a display manager, so I typed "lightdm" and surprisingly (for me at least) this took me to my usual graphical login screen, where I could choose the usual Xfce session, and here I'm typing...

    What should be my next step? You said
    Many suspending trouble are video related, so taking it out of the equation
    for a test helps.
    And from the man-pages of pm-suspend:
    On most hardware putting the video card in the suspend state and recovering from it needs some special quirk handling. With the --quirk-* options of the pm-suspend and pm-suspend-hybrid commands you can select which quirks should be used.
    So I guess it can be something around that, but I'll wait for comments. Thanks (and absolutely no hurries!)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Suspend/logout problems in OpenSUSE 12.1+Xfce

    On 2012-05-06 03:36, infrauser wrote:

    > So I did it. Logged in as user in text mode, typed "su -" and tried the
    > command "pm-suspend".


    A comment. The exception to the rule "do not login as root" is that in text
    mode you can, because there is no difference from doing "su -", except that
    you save typing by directly login as root :-)


    > It got suspended in 2-3 seconds: then, after a keypress, it seemed to
    > recover (i mean: it made similar noises to the ones of a working
    > system), but the monitor remained idle and i couldn't see anything.
    > Ctrl+Alt+Supr made it reboot (so the system was responsive in some way,
    > but I'd say suspend doesn't work in text mode either, do you agree?).


    I think it works, but your display does not recover. It is something, it
    doesn't crash.

    Sometimes it is the backlight that doesn't come on: looking very carefully
    you can see very dim letters.

    Another test: some people can not get suspend to ram working, but suspend
    to disk works - so try "pm-hibernate" instead.

    > After the reboot I entered into text mode again, logged in, typed
    > "startxfce4", and I got an error:


    That will not work nowdays, things have changed. startx may, but you have
    to do a change to "/etc/permissions.local" (look inside the file, it is
    commented out). But you can type "init 5" and start full graphics mode from
    there (and init 3 switches to full text mode).

    > What should be my next step?


    That's the big problem... In my case, using the nouveau video driver
    crashed the system on hibernation, I had to use the proprietary nvidia
    driver instead. That was some years ago, might have changed now. It is
    something to try (if you are using one, try the other).

    >> recovering from it needs some special quirk handling. With the --quirk-*
    >> options of the pm-suspend and pm-suspend-hybrid commands you can select
    >> which quirks should be used.


    They mean these:

    Code:
    Telcontar:~ # pm-suspend --help
    pm-suspend [options]
    
    Options can change how suspend or hibernate is done.
    
    Video quirk handler options:
    
    --quirk-dpms-on
    --quirk-dpms-suspend
    --quirk-radeon-off
    --quirk-reset-brightness
    --quirk-s3-bios
    --quirk-s3-mode
    --quirk-vbe-post
    --quirk-vbemode-restore
    --quirk-vbestate-restore
    --quirk-vga-mode-3
    --quirk-none
    Telcontar:~ #
    I do not know if they'll work for you.


    Something else you should do, specially if nothing works: try the factory
    version. On every machine I use I keep at least a small extra partition
    (even 8 GiB is enough) where I can install the factory version and test
    things. In this case, try suspend/hibernate, and if it fails, report in
    bugzilla. Eventually, it will work. I had to wait some years to get it
    working in mine... many machines failed some years ago.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •