Results 1 to 6 of 6

Thread: 12.1, Gnome 3.2 - problems with file type association

  1. #1
    cfrick NNTP User

    Default 12.1, Gnome 3.2 - problems with file type association

    I want to associate a specific file extension with an application that
    was installed as a self contained entity. ie not through Yast.

    I can create a desktop launcher and add it to the Gnome menu, but if I
    try to associate a file extension with it, it does not show in the list
    of available applications. I used to be able to browse to the executable
    (prior to 12.1), but there is no longer that option. My only choice is
    to search online, which is totally useless.

    There is no option to browse the local file system for the executable.

    Is there some way to do this, or is this a bug?

    Thanks,
    Chris

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: 12.1, Gnome 3.2 - problems with file type association

    Quote Originally Posted by cfrick
    I want to associate a specific file extension with an
    application that was installed as a self contained entity. ie not
    through Yast.

    I can create a desktop launcher and add it to the Gnome menu, but if I
    try to associate a file extension with it, it does not show in the list
    of available applications. I used to be able to browse to the
    executable (prior to 12.1), but there is no longer that option. My only
    choice is to search online, which is totally useless.

    There is no option to browse the local file system for the executable.

    Is there some way to do this, or is this a bug?

    Thanks,
    Chris
    Hi
    You need to add the mime information in the desktop file and also
    update the mime database.... eg MimeType=application/x-.....

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 3 days 9:12, 4 users, load average: 0.00, 0.02, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  3. #3
    cfrick NNTP User

    Default Re: 12.1, Gnome 3.2 - problems with file type association

    On 5/2/2012 10:02 AM, malcolmlewis wrote:
    >
    Quote Originally Posted by cfrick
    I want to associate a specific file extension with an
    > application that was installed as a self contained entity. ie not
    > through Yast.
    >
    > I can create a desktop launcher and add it to the Gnome menu, but if I
    > try to associate a file extension with it, it does not show in the list
    > of available applications. I used to be able to browse to the
    > executable (prior to 12.1), but there is no longer that option. My only
    > choice is to search online, which is totally useless.
    >
    > There is no option to browse the local file system for the executable.
    >
    > Is there some way to do this, or is this a bug?
    >
    > Thanks,
    > Chris
    >
    > Hi
    > You need to add the mime information in the desktop file and also
    > update the mime database.... eg MimeType=application/x-.....
    >

    Hi Malcolm,
    Thanks. I found some references on how to configure the .desktop file
    using gedit, copy it to the correct directory and update the mime
    database. Works perfectly.
    Regards,
    Chris

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: 12.1, Gnome 3.2 - problems with file type association

    Quote Originally Posted by cfrick
    On 5/2/2012 10:02 AM, malcolmlewis wrote:
    >
    Quote Originally Posted by cfrick
    I want to associate a specific file extension with an
    > application that was installed as a self contained entity. ie not
    > through Yast.
    >
    > I can create a desktop launcher and add it to the Gnome menu, but if I
    > try to associate a file extension with it, it does not show in the
    > list of available applications. I used to be able to browse to the
    > executable (prior to 12.1), but there is no longer that option. My
    > only choice is to search online, which is totally useless.
    >
    > There is no option to browse the local file system for the executable.
    >
    > Is there some way to do this, or is this a bug?
    >
    > Thanks,
    > Chris
    >
    > Hi
    > You need to add the mime information in the desktop file and also
    > update the mime database.... eg MimeType=application/x-.....
    >

    Hi Malcolm,
    Thanks. I found some references on how to configure the .desktop file
    using gedit, copy it to the correct directory and update the mime
    database. Works perfectly.
    Regards,
    Chris
    Hi
    During an rpm install there are macros that run to do this, you should
    send some feedback to the application developers on what you did so
    they can perhaps incorporate your steps in the install or install notes.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 9:02, 4 users, load average: 0.00, 0.01, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  5. #5
    cfrick NNTP User

    Default Re: 12.1, Gnome 3.2 - problems with file type association

    On 5/3/2012 9:03 AM, malcolmlewis wrote:
    >
    Quote Originally Posted by cfrick
    On 5/2/2012 10:02 AM, malcolmlewis wrote:
    >>
    Quote Originally Posted by cfrick
    I want to associate a specific file extension with an
    >> application that was installed as a self contained entity. ie not
    >> through Yast.
    >>
    >> I can create a desktop launcher and add it to the Gnome menu, but if I
    >> try to associate a file extension with it, it does not show in the
    >> list of available applications. I used to be able to browse to the
    >> executable (prior to 12.1), but there is no longer that option. My
    >> only choice is to search online, which is totally useless.
    >>
    >> There is no option to browse the local file system for the executable.
    >>
    >> Is there some way to do this, or is this a bug?
    >>
    >> Thanks,
    >> Chris
    >>
    >> Hi
    >> You need to add the mime information in the desktop file and also
    >> update the mime database.... eg MimeType=application/x-.....
    >>

    > Hi Malcolm,
    > Thanks. I found some references on how to configure the .desktop file
    > using gedit, copy it to the correct directory and update the mime
    > database. Works perfectly.
    > Regards,
    > Chris
    >
    > Hi
    > During an rpm install there are macros that run to do this, you should
    > send some feedback to the application developers on what you did so
    > they can perhaps incorporate your steps in the install or install notes.
    >

    The application is Aegisub.
    There is a 2.1.9 version on Packman that does not launch for me -
    segmentation fault.
    It is also available as source code from their site. Compiled on my
    system gives the same result. They do not make Linux packages.

    They had a 2.1.8 version available as a self-contained, no install
    required, version which included all needed libraries. This runs just fine.
    Under openSUSE 11.4, I was able to associate the .ass filetype with the
    executable using Nautilus. That ability is missing in Gnome 3.2/openSUSE
    12.1.

    The problem with the 2.1.9 version may be video driver related, but I
    haven't had a chance to troubleshoot the issue. Right now, I need to use
    the application, not debug it.

    Thanks,
    Chris


  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: 12.1, Gnome 3.2 - problems with file type association

    Quote Originally Posted by cfrick
    On 5/3/2012 9:03 AM, malcolmlewis wrote:
    >
    Quote Originally Posted by cfrick
    On 5/2/2012 10:02 AM, malcolmlewis wrote:
    >>
    Quote Originally Posted by cfrick
    I want to associate a specific file extension with an
    >> application that was installed as a self contained entity. ie not
    >> through Yast.
    >>
    >> I can create a desktop launcher and add it to the Gnome menu, but if
    >> I try to associate a file extension with it, it does not show in the
    >> list of available applications. I used to be able to browse to the
    >> executable (prior to 12.1), but there is no longer that option. My
    >> only choice is to search online, which is totally useless.
    >>
    >> There is no option to browse the local file system for the
    >> executable.
    >>
    >> Is there some way to do this, or is this a bug?
    >>
    >> Thanks,
    >> Chris
    >>
    >> Hi
    >> You need to add the mime information in the desktop file and also
    >> update the mime database.... eg MimeType=application/x-.....
    >>

    > Hi Malcolm,
    > Thanks. I found some references on how to configure the .desktop file
    > using gedit, copy it to the correct directory and update the mime
    > database. Works perfectly.
    > Regards,
    > Chris
    >
    > Hi
    > During an rpm install there are macros that run to do this, you should
    > send some feedback to the application developers on what you did so
    > they can perhaps incorporate your steps in the install or install
    > notes.
    >

    The application is Aegisub.
    There is a 2.1.9 version on Packman that does not launch for me -
    segmentation fault.
    It is also available as source code from their site. Compiled on my
    system gives the same result. They do not make Linux packages.

    They had a 2.1.8 version available as a self-contained, no install
    required, version which included all needed libraries. This runs just
    fine. Under openSUSE 11.4, I was able to associate the .ass filetype
    with the executable using Nautilus. That ability is missing in Gnome
    3.2/openSUSE 12.1.

    The problem with the 2.1.9 version may be video driver related, but I
    haven't had a chance to troubleshoot the issue. Right now, I need to
    use the application, not debug it.

    Thanks,
    Chris
    Hi
    There is a bugzilla at packman now, worth a report when you have time
    https://bugs.links2linux.org/secure/Dashboard.jspa

    The rpm needs so post/postun macros added as well.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
    up 12:20, 5 users, load average: 0.06, 0.04, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •