Results 1 to 10 of 10

Thread: QEMU-KVM unable to use Spice

  1. #1

    Default QEMU-KVM unable to use Spice

    When I switch my Win 7 VM to use Spice I get the error:
    error starting daemon: unsupported configuration: spicevmc not supported in this QEMU binary

    Has anyone found a solution to this?

    The reason I am trying to use Spice is because I want to get audio playback & recording working from within a VM which I understand does not work over VNC.

    Thanks,
    Nick

  2. #2

    Default Re: QEMU-KVM unable to use Spice

    So no one else here using Spice drivers on openSUSE then?

  3. #3

    Default Re: QEMU-KVM unable to use Spice

    Update to the version from the Virtualization repository. It has spice support.

  4. #4

    Default Re: QEMU-KVM unable to use Spice

    Quote Originally Posted by RedDwarf View Post
    Update to the version from the Virtualization repository. It has spice support.
    Thanks RedDwarf,

    Tried that but didn't quite go as expected, now get error: No module named spiceclientgtk.

    I added what I guess was the Virtualization repo: /repositories/virtualization/openSUSE.12.1/ to my repositories but none of the applications from that seemed to be visible in Software manager. I therefore installed the following RPM's manually:
    Kvm- 1.1.1-141.1.x86_64
    Libspice-server1
    Vm-install.0.6.3-119.1
    Virt-viewer-0.5.2-44.1
    Virt-manager-0.9.1-99.1
    Spice-client-0.10.1-38.1
    Qemu-1.0.0-65.5
    Hyper-v-3.5.1

    Any idea what to try next,
    Nick

  5. #5

    Default Re: QEMU-KVM unable to use Spice

    From what I have read 'No module named spiceclientgtk' is caused by a missing dependency to python-spice-client-gtk. Question is where do I get that from it's not in Software manager and not in virtualization repo.

    Nick

  6. #6

    Default Re: QEMU-KVM unable to use Spice

    Last time I checked nobody had packaged it. virt-viewer could not use spice, but you could always use the spice client manually outside of virt-viewer.

  7. #7

    Default Re: QEMU-KVM unable to use Spice

    Quote Originally Posted by RedDwarf View Post
    Last time I checked nobody had packaged it. virt-viewer could not use spice, but you could always use the spice client manually outside of virt-viewer.
    How do I do that?

  8. #8

    Default Re: QEMU-KVM unable to use Spice

    Quote Originally Posted by Nick_C View Post
    How do I do that?
    spicec --host localhost --port 5900

    You can specify the port or look which one is select automatically in the details window. But it's usually 5900...

  9. #9

    Default Re: QEMU-KVM unable to use Spice

    Quote Originally Posted by RedDwarf View Post
    Last time I checked nobody had packaged it.
    FWIW I fixed this for Factory/12.2. If it's really important for you you could open a bug report asking for spice-gtk to be built for 12.1.

  10. #10

    Default Re: QEMU-KVM unable to use Spice

    Quote Originally Posted by RedDwarf View Post
    spicec --host localhost --port 5900

    You can specify the port or look which one is select automatically in the details window. But it's usually 5900...
    That works, thanks RedDwarf.

    Unfortunately still no Microphone recording device present in my Win 7 Professional, just line-in.

    Nick

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •