Hi everybody,

I trying send my cctv camera to Ustream using ffmpeg.
I have running Opensuse 11.4, ffmpeg 0.10 (errors tested over 0.7 0.9 versions)

In a konsole i write this:
Code:
ffmpeg -f v4l2 -s qvga -i /dev/video2 -f alsa -i micro -ac 1 -acodec libmp3lame -ab 32k -ar 11025 -threads 0 -f flv "rtmp://blablabla"
ffmpeg start saying "alsa @ 0x80787e0] ALSA buffer xrun." but the stream is sending and i can to see my webmcam on ustream.tv
ok

About 2 minutes later when the streaming size take about 28000kB ( 27000 - 32000kB)
ffmeg is stopped, blocked ... and I must pressed CTLR+C for cancel the current operation.
I can repeat this process a lot of time, always start running fine and always fail near of 30000kB.

ALSA is not the problem. When i start ffmpeg without sound and fail too.

Whereis the problem? The system log is clear.
The terminal dont show any error.

Here you can to see some lines before the crash.
In the last line you can to see character of CTLR+C and finished ffmpeg.
Code:
ffmpeg -f v4l2 -s qvga -i /dev/video2 -f alsa -i micro -ac 1 -acodec libmp3lame -ab 32k -ar 11025 -threads 0 -f flv "rtmp://xxxxxx" 
Input #0, video4linux2,v4l2, from '/dev/video2': 
Duration: N/A, start: 1335205444.432508, bitrate: 23039 kb/s 
Stream #0:0: Video: rawvideo (I420 / 0x30323449), yuv420p, 320x240, 23039 kb/s, 25 tbr, 1000k tbn, 25 tbc 
[alsa @ 0x80787e0] Estimating duration from bitrate, this may be inaccurate 
Input #1, alsa, from 'micro': 
Duration: N/A, start: 1335205444.448176, bitrate: N/A 
Stream #1:0: Audio: pcm_s16le, 44100 Hz, 2 channels, s16, 1411 kb/s 
[buffer @ 0x8084e20] w:320 h:240 pixfmt:yuv420p tb:1/1000000 sar:0/1 sws_param: 
Output #0, flv, to "rtmp://xxxxxx" Metadata: encoder : Lavf53.32.100 
Stream #0:0: Video: flv1 ([2][0][0][0] / 0x0002), yuv420p, 320x240, q=2-31, 200 kb/s, 1k tbn, 25 tbc 
Stream #0:1: Audio: mp3 ([2][0][0][0] / 0x0002), 11025 Hz, 1 channels, s16, 32 kb/s 
Stream mapping: 
Stream #0:0 -> #0:0 (rawvideo -> flv) 
Stream #1:0 -> #0:1 (pcm_s16le -> libmp3lame) 
Press [q] to stop, [?] for help [alsa @ 0x80787e0] 
ALSA buffer xrun.
 ^L^Ce= 3819 fps= 25 q=0.0 size= 28621kB time=00:02:31.40 bitrate=1548.6kbits/s
Any suggestions are wellcome.
Thank you.