Results 1 to 5 of 5

Thread: How to share a folder with Samba?

  1. #1

    Default How to share a folder with Samba?

    Hello,

    My goal is simple. I just want to share a folder, so that other people can connect, read from it and write to it.

    I've been strunggling with this for ages, following random internet tutorials, trying things etc. with little success. Now I'd like to find the 'correct' way. I've deleted /etc/samba/smb.conf to start fresh.

    Here's what I did (in the last attempt):
    1) delete /etc/samba/smb.conf
    2) start Yast/Samba Server
    3) entered WORKGROUP as the domain name
    4) selected No domain controller
    5) checked "allow users to share their directories" and "allow guest access". See the first picture (sorry for the language, starting yast with "LANG=en yast2" started it in Czech (why on earth does not it respect LANG?))
    6) clicked OK
    7) entered samba root password as prompted
    8) in Dolphin, I've selected the folder, opened the properties and enabled sharing with Samba, see the second picture.
    9) if I open it again, my settings are lost, see the third picture.

    There is only 'netlogon' share available on my Samba server that requires authentication.

    What shall I do to share a folder?

    It would be great if it didn't require any messing with config files. It is very embarassing when I come to a pub, ask a friend to copy some files to my laptop and then spend an hour in the CLI...




  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: How to share a folder with Samba?

    So you need the smb.conf file if if you want to use Samba. If you want to share between to Linux computers, you can just use nsf. For Samba help, why not look at these blogs on the subject?

    Samba S.W.A.T. - Samba Web Administration Tool Setup for openSUSE - Blogs - openSUSE Forums

    SWAT - Samba Web Administration Tool - Setup & Creation Script - 1.03 - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: How to share a folder with Samba?

    Thank you jdmcdaniel3 for your post and for the links. I hoped that there is some 'easy' way that I've just missed, like three clicks or something .

    I see that I'll have to edit smb.conf by hand in the end. That should be pretty simple, it's just a single share. The problem is that it never worked, the guest was always given 'permission denied' error on write. See below for my current attempt of smb.conf.

    Second, what about the Dolphin issue? Is there a reason for this behavoiur, or shall I file a bug report (though I'd be surprised that nobody noticed this yet)?

    smb.conf:
    User 'tadeas' is my regular user as well as existing smbuser (added with 'smbpasswd tadeas -a').
    Code:
    [global]
            map to guest = tadeas
            add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
            domain logons = No
            domain master = No
            security = user
            usershare allow guests = Yes
            usershare max shares = 100
            workgroup = WORKGROUP
            passdb backend = smbpasswd
            wins support = No
    
    ## Share disabled by YaST
    # [netlogon]
    #       comment = Network Logon Service
    #       path = /var/lib/samba/netlogon
    #       write list = root
    
    [shared]
            browseable = Yes
            comment = shared
            guest ok = Yes
            path = /srv/smb
            read only = No
            writeable = Yes
            create mask = 0644
            directory mask = 0775
            guest account = tadeas
            force user = tadeas
            guest only = Yes
    Last edited by tmoravec; 17-Apr-2012 at 00:01. Reason: Fix typo

  4. #4

    Default Re: How to share a folder with Samba?

    Ah! Got it! It really is dead simple. Just Dolphin is buggy.

    It works as expected, just right click the folder and select sharing. However I need the permission on all contents of the folder and it's subfolders - and I didn't have them. The folder is OK, it was mine with 777, but there was a file somewhere deep inside that didn't belong to me.

    Sharing the folder as root was fine. Nautilus showed a 'permission denied' error, but Dolphin just silently failed, instead of informing the user that something's wrong.

    Shall I fill a bug report?

  5. #5

    Default Re: How to share a folder with Samba?

    Hello, have you started both services? smb and nmb? , could you please provide me some logs from both services. So far I can see that the first line is unnecesary "map to guest = tadeas" as you are using "security = user" . From a console type:

    smbclient -NL YourIPhere

    and post the output here too, ty.


    [Added]Didn't see your reply, I'm glad you sorted it out.
    Last edited by pasaporte; 17-Apr-2012 at 01:25. Reason: Seeing previous post too late

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •