Results 1 to 5 of 5

Thread: WebGL and GPU acceleration blocked in Firefox

  1. #1
    Join Date
    Aug 2008
    Location
    Hill Country Texas
    Posts
    71

    Default WebGL and GPU acceleration blocked in Firefox

    In attempt to improve poor Firefox 11.0 performance (4-5 times slower than Chrome 18 for same url retrieval), I installed the 4.2.0 Nvidia 295.40 driver for my Nvidia GeForce GTX 460 SE video card using the latest lnvhw installer tool. When I go to Firefox/Help/Troubleshooting Information/Graphics, it reports that
    (1) "WebGL Renderer: Blocked for your graphics card because of unresolved driver issues" and
    (2) "GPU Accelerated Windows:0. Blocked for your graphics driver version. Try updating your graphics driver to version <Anything with EXT_texture_from_pixmap support> or newer."

    How do I fix this?

    My environment is 64-bit:
    Opensuse 11.4
    Kernel 2.6.37.6
    Nvidia GeForce GTX 460 SE video card

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: WebGL and GPU acceleration blocked in Firefox

    Quote Originally Posted by DonMLewis View Post
    In attempt to improve poor Firefox 11.0 performance (4-5 times slower than Chrome 18 for same url retrieval), I installed the 4.2.0 Nvidia 295.40 driver for my Nvidia GeForce GTX 460 SE video card using the latest lnvhw installer tool. When I go to Firefox/Help/Troubleshooting Information/Graphics, it reports that
    (1) "WebGL Renderer: Blocked for your graphics card because of unresolved driver issues" and
    (2) "GPU Accelerated Windows:0. Blocked for your graphics driver version. Try updating your graphics driver to version <Anything with EXT_texture_from_pixmap support> or newer."

    How do I fix this?

    My environment is 64-bit:
    Opensuse 11.4
    Kernel 2.6.37.6
    Nvidia GeForce GTX 460 SE video card
    So, as the author of lnvhw, I have install the latest nVIDIA driver. When I look at the same location, here is what I see:

    Code:
    Graphics:
          
    Adapter Description:     NVIDIA Corporation -- GeForce GTX 560/PCIe/SSE2
    Driver Version:          4.2.0 NVIDIA 295.40
    WebGL Renderer:          NVIDIA Corporation -- GeForce GTX 560/PCIe/SSE2 -- 4.2.0 NVIDIA 295.40
    GPU Accelerated Windows: 0
    If you open up a terminal session and run this, what do you see:

    Code:
    nvidia-smi -q | less
    Here are the first few lines on my computer:

    Code:
    Driver Version                  : 295.40
    
    Attached GPUs                   : 1
    
    GPU 0000:01:00.0
        Product Name                : GeForce GTX 560
        Display Mode                : N/A
        Persistence Mode            : Disabled
        Driver Model
            Current                 : N/A
            Pending                 : N/A
        Serial Number               : N/A
        GPU UUID                    : N/A
        VBIOS Version               : 70.24.18.00.60
        Inforom Version
            OEM Object              : N/A
            ECC Object              : N/A
            Power Management Object : N/A
        PCI
            Bus                     : 0x01
            Device                  : 0x00
            Domain                  : 0x0000
            Device Id               : 0x120110DE
            Bus Id                  : 0000:01:00.0
            Sub System Id           : 0x14603842
            GPU Link Info
                PCIe Generation
                    Max             : N/A
                    Current         : N/A
                Link Width
                    Max             : N/A
                    Current         : N/A
        Fan Speed                   : 40 %
        Performance State           : N/A
        Memory Usage
            Total                   : 1023 MB
            Used                    : 229 MB
            Free                    : 793 MB
        Compute Mode                : Default
    Now I am running kernel 3.3.1 right now and loaded it using SAKC and not sure if that really matters or not.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Aug 2008
    Location
    Hill Country Texas
    Posts
    71

    Default Re: WebGL and GPU acceleration blocked in Firefox

    James, thank you for your reply. Since posting, things have changed. Firefox/Help/Troubleshooting information/Graphics now seems to look ok:
    Code:
    Graphics
            
    Adapter Description:              NVIDIA Corporation -- GeForce GTX 460 SE/PCIe/SSE2
    Driver Version:                       4.2.0 NVIDIA 295.40
    WebGL Renderer:                 NVIDIA Corporation -- GeForce GTX 460 SE/PCIe/SSE2 -- 4.2.0 NVIDIA 295.40
    GPU Accelerated Windows:  0
    Here's the output from nvidia-smi -q
    Code:
    ==============NVSMI LOG==============
    
    Timestamp                       : Sat Apr 14 18:27:04 2012
    
    Driver Version                  : 295.40
    
    Attached GPUs                   : 1
    
    GPU 0000:01:00.0
        Product Name                : GeForce GTX 460 SE
        Display Mode                : N/A
        Persistence Mode            : Disabled
        Driver Model
            Current                 : N/A
            Pending                 : N/A
        Serial Number               : N/A
        GPU UUID                    : N/A
        VBIOS Version               : 70.04.29.00.62
        Inforom Version
            OEM Object              : N/A
            ECC Object              : N/A
            Power Management Object : N/A
        PCI
            Bus                     : 0x01
            Device                  : 0x00
            Domain                  : 0x0000
            Device Id               : 0x0E2310DE
            Bus Id                  : 0000:01:00.0
            Sub System Id           : 0x13663842
            GPU Link Info
                PCIe Generation
                    Max             : N/A
                    Current         : N/A
                Link Width
                    Max             : N/A
                    Current         : N/A
        Fan Speed                   : 40 %
        Performance State           : N/A
        Memory Usage
            Total                   : 1023 MB
            Used                    : 187 MB
            Free                    : 835 MB
        Compute Mode                : Default
        Utilization
            Gpu                     : N/A
            Memory                  : N/A
        Ecc Mode
            Current                 : N/A
            Pending                 : N/A
        ECC Errors
            Volatile
                Single Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
                Double Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
            Aggregate
                Single Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
                Double Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
        Temperature
            Gpu                     : 28 C
        Power Readings
            Power Management        : N/A
            Power Draw              : N/A
            Power Limit             : N/A
        Clocks
            Graphics                : N/A
            SM                      : N/A
            Memory                  : N/A
        Max Clocks
            Graphics                : N/A
            SM                      : N/A
            Memory                  : N/A
        Compute Processes           : Not Supported
    The things that have changed are that some updates came down and I've booted the system a couple of times. I'm still on the hunt as to why Firefox is so slow.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: WebGL and GPU acceleration blocked in Firefox

    Quote Originally Posted by DonMLewis View Post
    James, thank you for your reply. Since posting, things have changed. Firefox/Help/Troubleshooting information/Graphics now seems to look ok:
    Code:
    Graphics
            
    Adapter Description:              NVIDIA Corporation -- GeForce GTX 460 SE/PCIe/SSE2
    Driver Version:                       4.2.0 NVIDIA 295.40
    WebGL Renderer:                 NVIDIA Corporation -- GeForce GTX 460 SE/PCIe/SSE2 -- 4.2.0 NVIDIA 295.40
    GPU Accelerated Windows:  0
    Here's the output from nvidia-smi -q
    Code:
    ==============NVSMI LOG==============
    
    Timestamp                       : Sat Apr 14 18:27:04 2012
    
    Driver Version                  : 295.40
    
    Attached GPUs                   : 1
    
    GPU 0000:01:00.0
        Product Name                : GeForce GTX 460 SE
        Display Mode                : N/A
        Persistence Mode            : Disabled
        Driver Model
            Current                 : N/A
            Pending                 : N/A
        Serial Number               : N/A
        GPU UUID                    : N/A
        VBIOS Version               : 70.04.29.00.62
        Inforom Version
            OEM Object              : N/A
            ECC Object              : N/A
            Power Management Object : N/A
        PCI
            Bus                     : 0x01
            Device                  : 0x00
            Domain                  : 0x0000
            Device Id               : 0x0E2310DE
            Bus Id                  : 0000:01:00.0
            Sub System Id           : 0x13663842
            GPU Link Info
                PCIe Generation
                    Max             : N/A
                    Current         : N/A
                Link Width
                    Max             : N/A
                    Current         : N/A
        Fan Speed                   : 40 %
        Performance State           : N/A
        Memory Usage
            Total                   : 1023 MB
            Used                    : 187 MB
            Free                    : 835 MB
        Compute Mode                : Default
        Utilization
            Gpu                     : N/A
            Memory                  : N/A
        Ecc Mode
            Current                 : N/A
            Pending                 : N/A
        ECC Errors
            Volatile
                Single Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
                Double Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
            Aggregate
                Single Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
                Double Bit            
                    Device Memory   : N/A
                    Register File   : N/A
                    L1 Cache        : N/A
                    L2 Cache        : N/A
                    Total           : N/A
        Temperature
            Gpu                     : 28 C
        Power Readings
            Power Management        : N/A
            Power Draw              : N/A
            Power Limit             : N/A
        Clocks
            Graphics                : N/A
            SM                      : N/A
            Memory                  : N/A
        Max Clocks
            Graphics                : N/A
            SM                      : N/A
            Memory                  : N/A
        Compute Processes           : Not Supported
    The things that have changed are that some updates came down and I've booted the system a couple of times. I'm still on the hunt as to why Firefox is so slow.
    Well, let us know if we can help again. Sorry to get back so late, but I was out of town the last couple of days.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Jul 2011
    Location
    Ukraine
    Posts
    12

    Default Re: WebGL and GPU acceleration blocked in Firefox


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •