Results 1 to 10 of 10

Thread: GnuCash 2.4.0 settings

  1. #1

    Default GnuCash 2.4.0 settings

    Can anyone help with the following questions on GnuCash?

    I am running GnuCash 2.4.0 on OpenSuse 11.4/Gnome 2

    1. How do I set the Language to German? (I have downloaded the GnuCash Language package)

    2. Where may I get a version of Kontenrahmen SKR03 for importing into GnuCash?

    3. Where may I replace the decimal to a decimal comma?

    4. If the decimal comma cannot be used, may there be problems when importing German bank data via HCBI?

    Any ideas anyone?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GnuCash 2.4.0 settings

    On 2012-04-09 21:16, hnimmo wrote:
    > 1. How do I set the Language to German? (I have downloaded the GnuCash
    > Language package)


    In general, in Linux, you change the language on the desktop, both
    KDE/Gnome have their ways. You can customize the settings from the terminal
    upwards, by creating a ~/.i18n file - mine has, for Spanish:

    LC_TIME=en_DK.UTF-8
    LC_MONETARY=es_ES@euro
    LC_NUMERIC=es_ES@euro
    LC_PAPER=es_ES@euro
    LC_TELEPHONE=es_ES@euro
    LC_MEASUREMENT=es_ES@euro
    LC_NAME=es_ES@euro


    This is inherited by gnome and applications such as mozilla/thunderbird.
    KDE used a different variable: KDE_LANG=es_ES

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Default Re: GnuCash 2.4.0 settings

    Quote Originally Posted by robin_listas View Post
    On 2012-04-09 21:16, hnimmo wrote:
    > 1. How do I set the Language to German? (I have downloaded the GnuCash
    > Language package)


    In general, in Linux, you change the language on the desktop, both
    KDE/Gnome have their ways. You can customize the settings from the terminal
    upwards, by creating a ~/.i18n file - mine has, for Spanish:

    LC_TIME=en_DK.UTF-8
    LC_MONETARY=es_ES@euro
    LC_NUMERIC=es_ES@euro
    LC_PAPER=es_ES@euro
    LC_TELEPHONE=es_ES@euro
    LC_MEASUREMENT=es_ES@euro
    LC_NAME=es_ES@euro


    This is inherited by gnome and applications such as mozilla/thunderbird.
    KDE used a different variable: KDE_LANG=es_ES
    Many thanks for the answer! If I understand you right, what you suggest could be achieved via the etc/sysconfig file under System / Environment / Language. However, my editor does not describe what the format of the variable would be. Would 'de_DE@euro' be correct do you think?

    Cheers
    hn

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GnuCash 2.4.0 settings

    On 2012-04-09 22:06, hnimmo wrote:

    > Many thanks for the answer! If I understand you right, what you
    > suggest could be achieved via the etc/sysconfig file under System /
    > Environment / Language.


    That would be for all users, systemwide. My suggestion only affects one
    user, and allows fine tuning. Me, I have the system language set to
    English, but I have somethings changed to Spanish, and the time to "Denmark
    English", which happens to be ISO standard.

    > However, my editor does not describe what the
    > format of the variable would be. Would 'de_DE@euro' be correct do you
    > think?


    You have all the possible settings on "/usr/lib/locale/". However, if you
    do it systemwide in YaST, you get an easy to click list of choices.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: GnuCash 2.4.0 settings

    Quote Originally Posted by robin_listas View Post

    You have all the possible settings on "/usr/lib/locale/". However, if you
    do it systemwide in YaST, you get an easy to click list of choices.
    Thanks. I found the /usr/lib/locale with all the options.

    However, on changing the default value for the parameters RC_LC_NUMERIC and RC_LC_MONETARY to 'de_DE@euro' under the Yast /etc/config editor, there is no effect on gnucash. What am I missing still?

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GnuCash 2.4.0 settings

    On 2012-04-10 19:26, hnimmo wrote:

    > Thanks. I found the /usr/lib/locale with all the options.
    >
    > However, on changing the default value for the parameters RC_LC_NUMERIC
    > and RC_LC_MONETARY to 'de_DE@euro' under the Yast /etc/config editor,
    > there is no effect on gnucash. What am I missing still?


    You can open a terminal in your desktop, run "locale", and see if it prints
    what you expect.

    Maybe the desktop settings overrides the system settings. Or maybe - I
    don't use gnucash myself, remember - the program has its own settings like
    LibreOffice has, and thus it ignores outside settings.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7

    Default Re: GnuCash 2.4.0 settings

    Quote Originally Posted by robin_listas View Post

    You can open a terminal in your desktop, run "locale", and see if it prints
    what you expect.
    All settings are 'en_GB.utf8' in spite of the changes I made in Yast. But the variable names are different! (e.g. LC_MONETARY (Locale) as opposed to RC_LC_MONETARY (Yast)

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GnuCash 2.4.0 settings

    On 2012-04-10 20:16, hnimmo wrote:
    >
    > robin_listas;2455198 Wrote:
    >>
    >>
    >> You can open a terminal in your desktop, run "locale", and see if it
    >> prints what you expect.

    >
    > All settings are 'en_GB.utf8' in spite of the changes I made in Yast.
    > But the variable names are different! (e.g. LC_MONETARY (Locale) as
    > opposed to RC_LC_MONETARY (Yast)


    Well, that is to be expected. The changes done in sysconfig are applied to
    the real variables later. No matter (the names, not the contents).

    You may have to run:

    [CODE]
    su -
    SuSEconfig
    [CODE]

    and then log out and log in. I don't know if you need to reboot (I believe
    not). This should work for gnome, at least, probably others.

    For KDE, I think it still remembers that you used it under another
    language, and may ignore the change. In that case, you need to change it
    somewhere else - sorry, I'm not that used to KDE to remember exactly where.
    Language settings, probably.

    You can make sure the setting was applied by running "locale" in the text
    console (ctrl-alt-f1). If that is correct, try again logged in the graphic
    desktop of your choice, and run "locale" in a terminal. If it is what you
    expect, fine, if not, you know that you have to search for the desktop
    /different/ method :-)


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9

    Default Re: GnuCash 2.4.0 settings

    The problem has been solved (at least in part), by resetting the Sysconfig environment parameters to their defaults via Yast, except LC_LANG which I set to de_DE.UTF-8. A reboot was necessary.

    Now Gnucash shows a mixture of English (e.g. menus, windows, accounts etc, as before) and German (Account handling texts, e.g. debit, credit => Soll, Haben etc). More importantly, the money values are shown with decimal comma instead of decimal point (good for reporting and import/export in my German context). I can live with that, although I may look for further language improvements.

    Many thanks for your help, robin_listas

    Cheers
    HN

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GnuCash 2.4.0 settings

    On 2012-04-11 12:46, hnimmo wrote:
    >
    > The problem has been solved (at least in part), by resetting the
    > Sysconfig environment parameters to their defaults via Yast, except
    > LC_LANG which I set to de_DE.UTF-8. A reboot was necessary.
    >
    > Now Gnucash shows a mixture of English (e.g. menus, windows, accounts
    > etc, as before) and German (Account handling texts, e.g. debit, credit
    > => Soll, Haben etc). More importantly, the money values are shown with
    > decimal comma instead of decimal point (good for reporting and
    > import/export in my German context). I can live with that, although I
    > may look for further language improvements.


    Mmm.

    There is another method I forgot to mention. You can launch a single
    application in a different language than the default by launching it like this:

    Code:
    LANG=DE.UTF-8 application
    For example, I have a script "/usr/local/bin/espaniol" with this content:

    #!/bin/sh
    #LANG=es_ES $*
    LANG=es_ES.UTF-8 LC_ALL=es_ES.UTF-8 DICTIONARY=espanol KDE_LANG=es_ES $*


    With this trick you can keep the entire desktop in English and launch
    certain programs in German.

    >
    > Many thanks for your help, robin_listas


    Welcome, glad to have been of help.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •