Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Virtualbox does not start on 32 bit version of 12.1

  1. #11
    Join Date
    Feb 2009
    Location
    Poulsbo WA
    Posts
    23

    Post Re: Virtualbox does not start on 32 bit version of 12.1

    Quote Originally Posted by caf4926 View Post
    Those repos look OK

    You need to double check the details in post #4 by James

    And is the log error the same?

    Also please post result of

    uname -a
    Running a double check as I enter this message
    1) YaST / Software / Software Management
    Development

    [X] Base Development
    [X] Linux Kernel Development
    [X] C/C++ Development
    All are present.

    2) Trying sudo /etc/init.d/vboxdrv setup
    Result is
    Code:
    55> sudo /etc/init.d/vboxdrv setup | tee ~/tmp/setup.txt
    root's password:
    Stopping VirtualBox kernel modules..done
    Uninstalling old VirtualBox DKMS kernel modules..done
    Trying to register the VirtualBox kernel modules using DKMS
    Error! Your kernel headers for kernel 3.1.9-1.4-default cannot be found at
    /lib/modules/3.1.9-1.4-default/build or /lib/modules/3.1.9-1.4-default/source.
    ..failed
      (Failed, trying without DKMS)
    Recompiling VirtualBox kernel modules..failed
      (Look at /var/log/vbox-install.log to find out what went wrong)
    bill@baldar: [/home/bill]
    56>
    The log file is
    Code:
    Uninstalling modules from DKMS
      removing old DKMS module vboxhost version  4.1.12
    
    ------------------------------
    Deleting module version: 4.1.12
    completely from the DKMS tree.
    ------------------------------
    Done.
    Attempting to install using DKMS
    
    Creating symlink /var/lib/dkms/vboxhost/4.1.12/source ->
                     /usr/src/vboxhost-4.1.12
    
    DKMS: add Completed.
    You can use the --kernelsourcedir option to tell DKMS where it's located.
    Failed to install using DKMS, attempting to install without
    Makefile:175: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
    make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /usr/src/linux modules
    test -e include/generated/autoconf.h -a -e include/config/auto.conf || (		\
    echo;								\
    echo "  ERROR: Kernel configuration is invalid.";		\
    echo "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
    echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";	\
    echo;								\
    /bin/false)
    
      ERROR: Kernel configuration is invalid.
             include/generated/autoconf.h or include/config/auto.conf are missing.
             Run 'make oldconfig && make prepare' on kernel src to fix it.
    
    mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
    
      WARNING: Symbol version dump /usr/src/linux-3.3.1-jng5/Module.symvers
               is missing; modules will have no dependencies and modversions.
    
    make -f scripts/Makefile.build obj=/tmp/vbox.0
    /tmp/vbox.0/Makefile:175: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
      gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d  -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.6/include -I/usr/src/linux-3.3.1-jng5/arch/x86/include -Iarch/x86/include/generated -Iinclude  -include /usr/src/linux-3.3.1-jng5/include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-red-zone -mcmodel=kernel -maccumulate-outgoing-args -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fomit-frame-pointer -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/usr/src/linux/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.0/linux/SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
    /tmp/vbox.0/linux/SUPDrv-linux.c:1:0: error: code model ‘kernel’ not supported in the 32 bit mode
    /tmp/vbox.0/linux/SUPDrv-linux.c:1:0: sorry, unimplemented: 64-bit mode not compiled in
    make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
    make[1]: *** [_module_/tmp/vbox.0] Error 2
    make: *** [vboxdrv] Error 2
    From this, it looks like something might be wrong with the kernel source code. Could that indicate that there is an error with the j.eng repository?

    3) Next, to automatically load the kernel drivers for you go into: instructions for loading dkms from Packman. I checked, and dkms is currently loaded from packman (version 2.1.1.2-1.1-noarch from packman).

    4) Ever so often I get a report that the VirtualBox script is not marked executable so you can try this if that is the case:
    Not the problem. I can start virtual box, and the VB window comes up, and shows my virtual machine as being powered off. But when I try to start it, I get the errors mentioned in my original post.

    Oh, and here is the uname info you asked for.
    Code:
    52> uname -a
    Linux baldar.site 3.1.9-1.4-default #1 SMP Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux
    [1]+  Done                    klipper
    bill@baldar: [/home/bill]
    53>
    Again, thanks for your assistance.

  2. #12
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Virtualbox does not start on 32 bit version of 12.1

    Quote Originally Posted by billrclarity View Post
    Running a double check as I enter this message
    1) YaST / Software / Software Management
    Development

    [X] Base Development
    [X] Linux Kernel Development
    [X] C/C++ Development
    All are present.

    2) Trying sudo /etc/init.d/vboxdrv setup
    Result is
    Code:
    55> sudo /etc/init.d/vboxdrv setup | tee ~/tmp/setup.txt
    root's password:
    Stopping VirtualBox kernel modules..done
    Uninstalling old VirtualBox DKMS kernel modules..done
    Trying to register the VirtualBox kernel modules using DKMS
    Error! Your kernel headers for kernel 3.1.9-1.4-default cannot be found at
    /lib/modules/3.1.9-1.4-default/build or /lib/modules/3.1.9-1.4-default/source.
    ..failed
      (Failed, trying without DKMS)
    Recompiling VirtualBox kernel modules..failed
      (Look at /var/log/vbox-install.log to find out what went wrong)
    bill@baldar: [/home/bill]
    56>
    The log file is
    Code:
    Uninstalling modules from DKMS
      removing old DKMS module vboxhost version  4.1.12
    
    ------------------------------
    Deleting module version: 4.1.12
    completely from the DKMS tree.
    ------------------------------
    Done.
    Attempting to install using DKMS
    
    Creating symlink /var/lib/dkms/vboxhost/4.1.12/source ->
                     /usr/src/vboxhost-4.1.12
    
    DKMS: add Completed.
    You can use the --kernelsourcedir option to tell DKMS where it's located.
    Failed to install using DKMS, attempting to install without
    Makefile:175: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
    make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /usr/src/linux modules
    test -e include/generated/autoconf.h -a -e include/config/auto.conf || (        \
    echo;                                \
    echo "  ERROR: Kernel configuration is invalid.";        \
    echo "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
    echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";    \
    echo;                                \
    /bin/false)
    
      ERROR: Kernel configuration is invalid.
             include/generated/autoconf.h or include/config/auto.conf are missing.
             Run 'make oldconfig && make prepare' on kernel src to fix it.
    
    mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
    
      WARNING: Symbol version dump /usr/src/linux-3.3.1-jng5/Module.symvers
               is missing; modules will have no dependencies and modversions.
    
    make -f scripts/Makefile.build obj=/tmp/vbox.0
    /tmp/vbox.0/Makefile:175: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
      gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d  -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.6/include -I/usr/src/linux-3.3.1-jng5/arch/x86/include -Iarch/x86/include/generated -Iinclude  -include /usr/src/linux-3.3.1-jng5/include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-red-zone -mcmodel=kernel -maccumulate-outgoing-args -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fomit-frame-pointer -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/usr/src/linux/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.0/linux/SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
    /tmp/vbox.0/linux/SUPDrv-linux.c:1:0: error: code model ‘kernel’ not supported in the 32 bit mode
    /tmp/vbox.0/linux/SUPDrv-linux.c:1:0: sorry, unimplemented: 64-bit mode not compiled in
    make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
    make[1]: *** [_module_/tmp/vbox.0] Error 2
    make: *** [vboxdrv] Error 2
    From this, it looks like something might be wrong with the kernel source code. Could that indicate that there is an error with the j.eng repository?

    3) Next, to automatically load the kernel drivers for you go into: instructions for loading dkms from Packman. I checked, and dkms is currently loaded from packman (version 2.1.1.2-1.1-noarch from packman).

    4) Ever so often I get a report that the VirtualBox script is not marked executable so you can try this if that is the case:
    Not the problem. I can start virtual box, and the VB window comes up, and shows my virtual machine as being powered off. But when I try to start it, I get the errors mentioned in my original post.

    Oh, and here is the uname info you asked for.
    Code:
    52> uname -a
    Linux baldar.site 3.1.9-1.4-default #1 SMP Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux
    [1]+  Done                    klipper
    bill@baldar: [/home/bill]
    53>
    Again, thanks for your assistance.
    So, if you want my opinion on this, I would go for a much newer kernel. Perhaps any kernel 3.2 would work better. We are up to stable 3.3.2, but it has an issue (without extra effort) if using the nVIDIA video driver, which I can't recall if that is true or not. Here are some pointers:

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.62 - Blogs - openSUSE Forums

    DKMS, systemd & Virtual Box - How to get Dynamic Kernel Module Support to work in openSUSE 12.1 - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #13
    Join Date
    Feb 2009
    Location
    Poulsbo WA
    Posts
    23

    Default Re: Virtualbox does not start on 32 bit version of 12.1

    Quote Originally Posted by jdmcdaniel3 View Post
    So, if you want my opinion on this, I would go for a much newer kernel. Perhaps any kernel 3.2 would work better. We are up to stable 3.3.2, but it has an issue (without extra effort) if using the nVIDIA video driver, which I can't recall if that is true or not. Here are some pointers:

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.62 - Blogs - openSUSE Forums

    DKMS, systemd & Virtual Box - How to get Dynamic Kernel Module Support to work in openSUSE 12.1 - Blogs - openSUSE Forums

    Thank You,
    I followed your advice, kind of. Since I am not real hot to compile my own kernel, I decided to try something else first. I checked to see what I would get if I used Yast to reload the kernel. I noticed that there was a kernel-desktop that wasn't loaded, and it was from the j.eng repository. I loaded that and, after restarting, tried starting my already existing virtual machine. It ran. This is opensuse 3.3.1-jng5.

    Again, thanks for your help and all your time. Since my total reason for the laptop is so I can run the only windows program I use regularly (Quicken) when I am away from home but attach to my data files at home, I needed vbox to run windows which connects home over openvpn. The whole thing was interesting to set up, but my data files are not on the laptop, in case it gets stolen, and the connection is vpn protected against eavesdropping even with a public wireless connection.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •