Results 1 to 6 of 6

Thread: Tracker.

  1. #1
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default Tracker.

    Hi,

    I had an old Opensuse 11.4 64bit pc running on a KDE Desktop and started to used it for about two weeks.
    The systems was slower then previous Opensuse installs and I was starting to get annoyed by it. I had to run htop and system Monitor to find out what was wrong and the culprit was ... tracker.

    Tracker "eats" about 5% cpu even after a long time running his database thing.
    On boot the thing takes 100% CPU.
    After searching this forum I made the right decision to remove it entirely.
    Now the KDE startup/login is Much faster and even programs like Opera got much better startup times.
    I really recommend people to Uninstall Tracker, specially in systems that are more limited then a full blown desktop.


    Regards.

  2. #2

    Default Re: Tracker.

    Tracker being a Gnome app shouldn't be installed by default with KDE, you must of had Gnome installed in parallel or earlier

    If you need desktop search in KDE see http://forums.opensuse.org/english/g...ghlight=recoll
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  3. #3
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default Re: Tracker.

    Hi,

    Quote Originally Posted by google01103 View Post
    Tracker being a Gnome app shouldn't be installed by default with KDE, you must of had Gnome installed in parallel or earlier

    If you need desktop search in KDE see http://forums.opensuse.org/english/g...ghlight=recoll
    I always install several desktop environments, in order to be able to choose and test stuff.
    And I really do not need any desktop search.
    Other desktop I installed was lxde that I find very simple and effective for things like software development.
    But I really prefer KDE as a Desktop environment so I had to see what was going on with the slowness of the thing

    Regards.

  4. #4

    Default Re: Tracker.

    Thanks for the tip. I just noted the other day that it's installed on an old slow machine I have running XFCE, and in addition to consuming the CPU it seemed to cause at least one problem with Firefox. Think I'll get rid of it.

  5. #5
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Tracker.

    I have created a tutorial for romanian users here in order to delete and disable Tracker Tutorial: dezactivare Meta Tracker sub openSUSE | Linux pentru incepatori here is how you suppose to do:
    1. open Yast -> Software management -> in search you type tracker-miner and delete all packages he find with one exception libtracker-miner-x_yy-z
    2. open a terminal and go to /etc/xdg/autostart
    3. using a text editor like pico for e.g, edit each tracker-*.desktop and add to the end of each file Hidden=true
    4. save settings and execute log out and log in in to your desktop

    No more Tracker at startup
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  6. #6

    Default Re: Tracker.

    Quote Originally Posted by gumb View Post
    Thanks for the tip. I just noted the other day that it's installed on an old slow machine I have running XFCE, and in addition to consuming the CPU it seemed to cause at least one problem with Firefox. Think I'll get rid of it.
    Just go to the xfce4-settings (settings-manager)
    In session and startup-autostart applications
    Untick tracker.

    In my case before with xfce I removed tracker in yast software management.
    People who do not break things first will never learn to create anything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •