Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: VLC 2 sound problems

  1. #1

    Default VLC 2 sound problems

    Using opensuse 12.1 gnome3 x64bit on a laptop with intel hd audio.
    VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)

    Upgraded to the latest vlc 2.0.1 (packman repository) and experience sound issues.
    Playback of any mp3 or video file appears to be muted. But after letting a mp3 file continue play with no sound I discovered that approximately once per minute there is a fraction of audio playback, just for a second or so. If using the progress bar to jump forward I can hear some click sound from the speakers as if vlc tries to activate sound but does not succeed.

    Did a complete uninstall and removed all vlc cache/config files and re-installed the application but the problem remains.

    Sound works perfectly fine in other media applications like totem, banshee, xine, mplayer.
    Never had any issues with the previous versions of vlc (1.1.3)

    Anyone else experiencing this issue with vlc 2?

  2. #2
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: VLC 2 sound problems

    On Fri, 06 Apr 2012 14:56:02 +0530, hjultomten
    <hjultomten@no-mx.forums.opensuse.org> wrote:

    >
    > Using opensuse 12.1 gnome3 x64bit on a laptop with intel hd audio.
    > VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)
    >
    > Upgraded to the latest vlc 2.0.1 (packman repository) and experience
    > sound issues.
    > Playback of any mp3 or video file appears to be muted. But after
    > letting a mp3 file continue play with no sound I discovered that
    > approximately once per minute there is a fraction of audio playback,
    > just for a second or so. If using the progress bar to jump forward I can
    > hear some click sound from the speakers as if vlc tries to activate
    > sound but does not succeed.
    >
    > Did a complete uninstall and removed all vlc cache/config files and
    > re-installed the application but the problem remains.
    >
    > Sound works perfectly fine in other media applications like totem,
    > banshee, xine, mplayer.
    > Never had any issues with the previous versions of vlc (1.1.3)
    >
    > Anyone else experiencing this issue with vlc 2?
    >
    >


    yes, happens to me, too.

    i found that after opening pavucontrol and touching some sliders under the
    "playback" and "output" tabs, vlc sound started after a few seconds, and
    as long as the pavucontrol window remains open, sound continues to play.
    closing pavucontrol, sound stops again. appears that there's a problem
    with vlc & pulseaudio, at least in my case.

    where to report bugs for this (packman) version of vlc?

    --
    phani.

  3. #3

    Default Re: VLC 2 sound problems

    Quote Originally Posted by hjultomten View Post
    ...Anyone else experiencing this issue with vlc 2?
    Yes.
    I think it is because of VLC backend for Phonon. I had to remove phonon-backend-vlc during upgrade.

    openSUSE Tumbleweed x64, KDE 4.8, VLC 2.0.1

  4. #4
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: VLC 2 sound problems

    On Fri, 06 Apr 2012 15:56:03 +0530, afshine
    <afshine@no-mx.forums.opensuse.org> wrote:

    >
    > hjultomten;2454107 Wrote:
    >> ...Anyone else experiencing this issue with vlc 2?

    >
    > Yes.
    > I think it is because of VLC backend for Phonon. I had to remove
    > phonon-backend-vlc during upgrade.
    >
    > openSUSE Tumbleweed x64, KDE 4.8, VLC 2.0.1
    >
    >


    i removed that, too, but still have sound problems with vlc2.

    --
    phani.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VLC 2 sound problems

    Go to prefs > Audio
    Output Mode > Select ALSA,
    then in the drop down select you default audio device
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: VLC 2 sound problems

    On Fri, 06 Apr 2012 17:26:02 +0530, caf4926
    <caf4926@no-mx.forums.opensuse.org> wrote:

    >
    > Go to prefs > Audio
    > Output Mode > Select ALSA,
    > then in the drop down select you default audio device
    >


    i did that, but still sound stops playing when i close the pavucontrol
    window. nothing i can't live with, since i mostly use smplayer these days,
    and keeping pavucontrol open doesn't hurt in case i want to use vlc.
    still, puzzling...

    --
    phani.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VLC 2 sound problems

    I don't use anything but kmix
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: VLC 2 sound problems

    Quote Originally Posted by phanisvara View Post
    On Fri, 06 Apr 2012 17:26:02 +0530, caf4926
    <caf4926@no-mx.forums.opensuse.org> wrote:

    >
    > Go to prefs > Audio
    > Output Mode > Select ALSA,
    > then in the drop down select you default audio device
    >


    i did that, but still sound stops playing when i close the pavucontrol
    window. nothing i can't live with, since i mostly use smplayer these days,
    and keeping pavucontrol open doesn't hurt in case i want to use vlc.
    still, puzzling...

    phani.
    I also checked this audio setting in vlc but it is already set to the default alsa (pulseaudio server). Since I have the short bursts of audio every 46sec or so that indicates the right output device is already set.

    Haven't tried or installed the pavucontrol because I never had the need for it (so far).

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VLC 2 sound problems

    Working here
    I use gstreamer backend in kde settings
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: VLC 2 sound problems

    Update: Seems I got the audio working now after another clean install of vlc 2. When looking in yast for vlc packages there was one package called "vlc-aout-pulse" which wasn't added by default. With this addition my sound is fully functional in vlc.

    Now it seems quite obvious for me that that should have been installed in the first place. But I don't recall ever having this installed with older versions of vlc (which was done according this Restricted Multimedia guide)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •