I have no clue why, but while polipo does start normally, privoxy in 12.1 64bit seems broken. As seems broken also tor.
In yast trying to start the service you get :
failed - error 1 - unspecified error.

Tor can be started by hand. But although it has been granted access rights either as file system as by apparmor to /etc/tor/torrc it claims:
Code:
pr 04 07:57:39.123 [notice] Tor v0.2.2.35 (git-b04388f9e7546a9f). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)
Apr 04 07:57:39.123 [warn] Could not open "/etc/tor/torrc": Permission denied
Apr 04 07:57:39.123 [notice] Configuration file "/etc/tor/torrc" not present, using reasonable defaults.
Apr 04 07:57:39.124 [notice] Initialized libevent version 2.0.10-stable using method epoll. Good.
Apr 04 07:57:39.124 [notice] Opening Socks listener on 127.0.0.1:9050
Apr 04 07:57:39.177 [notice] Parsing GEOIP file /usr/share/tor/geoip.
Apr 04 07:57:39.371 [notice] OpenSSL OpenSSL 1.0.0e 6 Sep 2011 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Apr 04 07:57:39.953 [notice] We now have enough directory information to build circuits.
Apr 04 07:57:39.953 [notice] Bootstrapped 80%: Connecting to the Tor network.
Apr 04 07:57:41.138 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Apr 04 07:57:42.709 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Apr 04 07:57:44.891 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.   
Apr 04 07:57:44.891 [notice] Bootstrapped 100%: Done.
But why, it has full access to /etc/tor/torrc??????

And then when you try with privoxy it fails miserably without giving you great explanation on why:
Code:
# rcprivoxy start
redirecting to systemctl
Job failed. See system logs and 'systemctl status' for details.
So you go to system logs:
Code:
Apr  4 09:43:40  privoxyd[16468]: Starting Privoxy..failed
Apr  4 09:43:40 systemd[1]: privoxyd.service: control process exited, code=exited status=7
Apr  4 09:43:40  systemd[1]: Unit privoxyd.service entered failed state.
Apr  4 09:44:08  kernel: [ 6646.665328] intel ips 0000:00:1f.6: MCP limit exceeded: Avg power 35143, limit 35000
So, what is the issue, this seems all connected. Please if you can help me on this, I will be grateful.

P.S. The MCP is a kernel/acpi issue that arrives with strigi activating. So it has already reported and is not connected.