Results 1 to 3 of 3

Thread: SSH

  1. #1

    Default SSH

    I managed to install and sort out the SSH on OpenSUSE 12.1...
    After knowing what I had to do, I had a newly installed server up and running just 45min
    Thats impressive for a Linux Newbie like me. Which only goes to prove what a good job the guys behind OpenSUSE are doing.

    Anyways every time I login through the SSH on my Mac, just before the prompt I get this line

    /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    Any idea what this means. I'm able to login and work on the server without a problem, its just that this message comes in on the terminal every time I login and I don't know if there was a problem with the installation or if that means something else that needs adjusting...

  2. #2

    Default Re: SSH

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    I assume you're SSH-ing in from the Mac to the OpenSUSE box. On your
    Mac do you have (before SSH-ing) environment variables named LANG and
    things starting with LC_? Find out with the `env` command I presume
    (like on Linux). These variables are usually passed from client to
    server which is nice since that usually means your server will use your
    language settings and not whatever the system defaults are. If your
    client is not sending those, though, not sure how the server will
    respond. Perhaps the server can be set to use defaults, but yours is
    not... perhaps. Try SSH-ing from the OpenSUSE box to itself to see if
    the problem happens; if not, fix the Mac client.

    Good luck.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.18 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJPdLYBAAoJEF+XTK08PnB5G5MQAIQWhu5KwK3gDhDbGcBfhSI6
    zE9QJnDowcUJI5VH8VwWgxM1petKSMk47+pGhUUsQUjVYTXL3ya8VqwLrle//x24
    Ih8YnkugPWxs+E82R68bNEQF7tVQLdJqG73nQCQCpnbgITbof5GRZ3C2ATVsJeMO
    loqvNyGGv9jp0UxAjjKlIHf2yoMVljROW2l30BzgO9EEQogqBYeYH1At1c7Hn5//
    AdzSV2HQrWU255OBU32oofQEQofLifcj3TH0eYRhIDe2D21l/3XDrka0f6dsDleI
    wKmBL8zXrN9B0gOu6rlDxEZ3PTDqIOwrjB5Y7wPR2iHm06RPnG8ZLHOI6wsDuxSS
    0NyEl6spqOJc+NCwFwi1vFEbRRwzFPnNpKVubZAXuMBPO88dau6AFlXGBJNPw0me
    u1ZTdCawRtLPaCkDMeSGgDiC4piYYp3aWQyr330ZNI/DQrvc1WXwpmxx/fZ0JJX3
    CG4JhufPcQNjcd/XfcWNMkOgRz9aCF+/y9ltE3duHWvr9UbDJlyIeysbuLaRBwkb
    Oxx9DzgqzDfm7gT8HjyOFXe3GFujxAr45kK6t/LE5tp7ecYNL2EHZvcpuTSMNNTo
    J/cwBm79L7VP/saEHqBZi1i9CjrzWvXIbZ0/pbCRtIy87kwO6eXqCGJH5G+LqlOn
    LeiwAF/LXVjdRoFZEnmV
    =DtcL
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: SSH

    As I understand you want to connect to your Mac from Opensuse. I have a Mac but never encountered these errors. I would suggest to try conneting to yourself first as ab suggested and then if you don't have a problem let me know and I will try in my network the same so we can figure it out what's going on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •