Results 1 to 7 of 7

Thread: bad looking fonts in Opensuse 12.1 KDE

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default bad looking fonts in Opensuse 12.1 KDE

    a couple of years back I posted about some bad looking fonts in opensuse / firefox.
    see here
    http://forums.opensuse.org/english/g...ome-fonts.html

    The issue was basically that some websites suggested helvetica as a font and Opensuse mapped that to Nimbus which is a pretty ugly font.
    The solution as posted here
    http://forums.opensuse.org/english/g...ml#post2086079
    has worked for me ever since up until recently.

    Now it seems to have no effect in 12.1

    See this website for example
    Simongriggdotinfo - Pagan Records' Singles

    to me the fonts look really bad



    has the way fonts are mapped changed in Opensuse 12.1?

    Does anybody know of a new workaround in 12.1 to get things looking as they should?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: bad looking fonts in Opensuse 12.1 KDE

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: bad looking fonts in Opensuse 12.1 KDE

    Am 29.03.2012 16:06, schrieb farcusnz:
    >
    > a couple of years back I posted about some bad looking fonts in
    > opensuse / firefox. see here http://tinyurl.com/c97ckex
    >
    > The issue was basically that some websites suggested helvetica as a
    > font and Opensuse mapped that to Nimbus which is a pretty ugly font.
    > The solution as posted here http://tinyurl.com/c42kdh6 has worked for
    > me ever since up until recently.
    >

    I am not sure if it has no effect, can you try to set it to something
    other than Arial, e.g. DejaVu Sans?
    Myself I just untick the checkbox in FF in the advanced settings for the
    fonts which allows webpages to use there own fonts, it falls back then
    to what I configured myself as standard fonts in Firefox which are the
    Dejavu fonts.
    The page you linked looks pretty on my machine.

    --
    PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
    GeForce GT 420
    Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.1
    | nVidia ION
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
    xf86-video-geode

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: bad looking fonts in Opensuse 12.1 KDE

    Quote Originally Posted by martin_helm View Post
    Am 29.03.2012 16:06, schrieb farcusnz:
    >
    > a couple of years back I posted about some bad looking fonts in
    > opensuse / firefox. see here change some fonts
    >
    > The issue was basically that some websites suggested helvetica as a
    > font and Opensuse mapped that to Nimbus which is a pretty ugly font.
    > The solution as posted here change some fonts - Page 2 has worked for
    > me ever since up until recently.
    >

    I am not sure if it has no effect, can you try to set it to something
    other than Arial, e.g. DejaVu Sans?
    Myself I just untick the checkbox in FF in the advanced settings for the
    fonts which allows webpages to use there own fonts, it falls back then
    to what I configured myself as standard fonts in Firefox which are the
    Dejavu fonts.
    The page you linked looks pretty on my machine.

    --
    PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
    GeForce GT 420
    Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.1
    | nVidia ION
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
    xf86-video-geode

    Yes, If I uncheck the box in firefox then arial fonts are loaded and it looks fine.
    I'm a little uncomfortable using this setting though because sometimes you should see what the developer specifies.

    I guess my query is more specific to why does the addition to the fontsconfig file not work any longer in 12.1 when it worked in previous versions of opensuse?

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: bad looking fonts in Opensuse 12.1 KDE

    Quote Originally Posted by farcusnz View Post
    Yes, If I uncheck the box in firefox then arial fonts are loaded and it looks fine.
    I'm a little uncomfortable using this setting though because sometimes you should see what the developer specifies.

    I guess my query is more specific to why does the addition to the fontsconfig file not work any longer in 12.1 when it worked in previous versions of opensuse?
    Things seem to have corrected themselves now - although I am not sure how.

    I copied the entire contents of the fontsconfig file. Deleted the file and created a new one. I then copied the contents into the new file - rebooted - and now everything seems fine.

  6. #6
    Join Date
    Dec 2008
    Location
    WI
    Posts
    32

    Default Re: bad looking fonts in Opensuse 12.1 KDE

    I agree your font does look pretty terrible in the condition that it is currently rendered. Here's how mine are being rendered.

    Firefox



    Chrome



    These are both set to the default zoom levels.

    So, to try and iron this out, what is your screen resolution set to currently? When you run Firefox in the console are there any errors being pushed to the prompt? Did you try using Chrome and if so did it exhibit the same symptoms? Is it just in Firefox that all of your fonts look bad or do they follow suit when being displayed in libreoffice? Did you try 1) creating a new user account in yast and 2) log into that account 3) open Firefox to the same page to see if the fonts are still being displayed the same.
    Just trying to help.

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: bad looking fonts in Opensuse 12.1 KDE

    Quote Originally Posted by msounhein View Post
    I agree your font does look pretty terrible in the condition that it is currently rendered. Here's how mine are being rendered.

    Firefox



    Chrome



    These are both set to the default zoom levels.

    So, to try and iron this out, what is your screen resolution set to currently? When you run Firefox in the console are there any errors being pushed to the prompt? Did you try using Chrome and if so did it exhibit the same symptoms? Is it just in Firefox that all of your fonts look bad or do they follow suit when being displayed in libreoffice? Did you try 1) creating a new user account in yast and 2) log into that account 3) open Firefox to the same page to see if the fonts are still being displayed the same.

    fonts looked bad in both chrome and firefox. Libreoffice was fine.

    I should specify that most website display fine.
    Having a play around it seems that whenever making any kind of font change in configure desktop it is adding a few lines to the end of the fontconfig file which is rendering anything above it invalid.
    If I go in and delete the few lines that were added I have things displaying again as I like.
    Whether this is caused by some corruption in my install or not I am not sure - but things seem ok for the moment.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •