Results 1 to 8 of 8

Thread: re-install software with yast

  1. #1

    Default re-install software with yast

    How do you reinstall software using yast. I have several corrupted installations do to my computer freezing during updating. If I uninstall first i will have to deal with dependency issues which is to complicated.

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: re-install software with yast

    Quote Originally Posted by bigrockcrasher View Post
    How do you reinstall software using yast. I have several corrupted installations do to my computer freezing during updating. If I uninstall first i will have to deal with dependency issues which is to complicated.
    You can force a reinstallation with zypper,

    Code:
    zypper in -f package
    Hope this works.

  3. #3

    Default Re: re-install software with yast

    still get the same errors here is what happened when I did an update. does anyone have any suggestions on how to fix this


    Installing: opencv-doc-2.3.1a-4.1.2 [done]
    Installing: glibc-2.14.1-14.27.1 [done]
    Installing: glibc-32bit-2.14.1-14.27.1 [done]
    Installing: glibc-i18ndata-2.14.1-14.27.1 [done]
    Installing: libxml2-2.7.8+git20110708-3.5.1 [error]
    Installation of libxml2-2.7.8+git20110708-3.5.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Invalid answer 'u i'. [a/r/i] (a): i
    Installing: libpng14-14-1.4.10-3.6.1 [done]
    Installing: libpng12-0-1.2.48-9.6.1 [done]
    Installing: glibc-locale-2.14.1-14.27.1 [done]
    Installing: glibc-devel-2.14.1-14.27.1 [error]
    Installation of glibc-devel-2.14.1-14.27.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: flash-player-11.2.202.228-12.1 [error]
    Installation of flash-player-11.2.202.228-12.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libpng14-14-32bit-1.4.10-3.6.1 [done]
    Installing: libpng12-0-32bit-1.2.48-9.6.1 [done]
    Installing: glibc-locale-32bit-2.14.1-14.27.1 [done]
    Installing: php5-5.3.8-4.9.2 [done]
    Installing: libpng14-devel-1.4.10-3.6.1 [error]
    Installation of libpng14-devel-1.4.10-3.6.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libpng12-devel-1.2.48-9.6.1 [error]
    Installation of libpng12-devel-1.2.48-9.6.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: flash-player-kde4-11.2.202.228-12.1 [done]
    Installing: flash-player-gnome-11.2.202.228-12.1 [done]
    Installing: php5-xmlwriter-5.3.8-4.9.2 [done]
    Installing: php5-tokenizer-5.3.8-4.9.2 [done]
    Installing: php5-pdo-5.3.8-4.9.2 [done]
    Installing: php5-json-5.3.8-4.9.2 [done]
    Installing: php5-iconv-5.3.8-4.9.2 [done]
    Installing: php5-gettext-5.3.8-4.9.2 [done]
    Installing: php5-dom-5.3.8-4.9.2 [done]
    Installing: php5-ctype-5.3.8-4.9.2 [done]
    Installing: apache2-mod_php5-5.3.8-4.9.2 [done]
    Installing: libpng12-compat-devel-1.2.48-9.6.1 [done]
    Installing: php5-sqlite-5.3.8-4.9.2 [done]
    Installing: php5-mysql-5.3.8-4.9.2 [done]
    Installing: php5-xmlreader-5.3.8-4.9.2 [done]
    Installing: libkcompactdisc4-4.7.2-2.1.2 [error]
    Installation of libkcompactdisc4-4.7.2-2.1.2 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libgstapp-0_10-0-0.10.36-60.6 [done]
    Installing: libxvidcore4-1.3.2-2.2 [done]
    Installing: libmad0-0.15.1b-2.6 [error]
    Installation of libmad0-0.15.1b-2.6 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libslv2-9-0.6.6-3.21 [done]
    Installing: libmp3lame0-3.98.4-7.2 [done]
    Installing: libfaac0-1.28-7.2 [done]
    Installing: libwavpack1-4.60.1-34.2 [done]
    Installing: kmix-4.7.2-3.1.7 [error]
    Installation of kmix-4.7.2-3.1.7 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libkcddb4-4.7.2-3.1.7 [error]
    Installation of libkcddb4-4.7.2-3.1.7 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: liba52-0-0.7.5svn-8.2 [done]
    Installing: libxine1-1.1.20.1-58.3 [error]
    Installation of libxine1-1.1.20.1-58.3 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libportaudio2-19-554.2 [done]
    Installing: libx264-120-0.120svn20120126-2.2 [done]
    Installing: libvlccore4-1.1.13-13.10 [done]
    Installing: libmpeg2-0-0.5.1-1.5 [error]
    Installation of libmpeg2-0-0.5.1-1.5 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libgstinterfaces-0_10-0-0.10.36-60.6 [done]
    Installing: libtwolame0-0.3.13-2.2 [done]
    Installing: libdca0-0.0.5-3.2 [done]
    Installing: ffmpeg-0.10.2-2.1 [error]
    Installation of ffmpeg-0.10.2-2.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libmms0-0.6.2-5.2 [error]
    Installation of libmms0-0.6.2-5.2 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libgstapp-0_10-0-32bit-0.10.36-60.5 [done]
    Installing: libgstinterfaces-0_10-0-32bit-0.10.36-60.5 [done]
    Installing: amarok-2.5.0-19.2 [error]
    Installation of amarok-2.5.0-19.2 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: kscd-4.7.2-3.1.7 [error]
    Installation of kscd-4.7.2-3.1.7 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: kio_audiocd-4.7.2-3.1.7 [error]
    Installation of kio_audiocd-4.7.2-3.1.7 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libquicktime0-1.2.4-66.2 [error]
    Installation of libquicktime0-1.2.4-66.2 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libvlc5-1.1.13-13.10 [done]
    Installing: libopencv2_3-2.3.1a-4.1.2 [done]
    Installing: gstreamer-0_10-plugin-esd-0.10.31-61.3 [done]
    Installing: gstreamer-0_10-plugin-gnomevfs-0.10.36-60.6 [done]
    Installing: MPlayer-1.0rc4_r34818-1.2 [error]
    Installation of MPlayer-1.0rc4_r34818-1.2 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libmjpegutils-2_0-0-2.0.0-39.4 [error]
    Installation of libmjpegutils-2_0-0-2.0.0-39.4 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: opencv-2.3.1a-4.1.2 [done]
    Installing: python-opencv-2.3.1a-4.1.2 [done]
    Installing: vlc-noX-1.1.13-13.10 [error]
    Installation of vlc-noX-1.1.13-13.10 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: gmplayer-1.0rc4_r34818-1.2 [error]
    Installation of gmplayer-1.0rc4_r34818-1.2 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: opencv-devel-2.3.1a-4.1.2 [done]
    Installing: vlc-qt-1.1.13-13.10 [done]
    Installing: vlc-1.1.13-13.10 [done]
    Installing: sox-14.3.2-33.7 [error]
    Installation of sox-14.3.2-33.7 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libreoffice-icon-theme-tango-3.4.5.5-2.4.1 [done]
    Installing: libreoffice-icon-theme-oxygen-3.4.5.5-2.4.1 [done]
    Installing: libreoffice-icon-theme-hicontrast-3.4.5.5-2.4.1 [done]
    Installing: libreoffice-icon-theme-galaxy-3.4.5.5-2.4.1 [done]
    Installing: libreoffice-icon-theme-crystal-3.4.5.5-2.4.1 [done]
    Installing: libreoffice-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-base-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-base-drivers-mysql-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-base-extensions-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-math-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-writer-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-impress-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-draw-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-draw-extensions-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-calc-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-pyuno-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-calc-extensions-3.4.5.5-4.5.1 [error]
    Installation of libreoffice-calc-extensions-3.4.5.5-4.5.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Command was killed by signal 11 (Segmentation fault).

    Abort, retry, ignore? [a/r/i] (a): i
    Installing: libreoffice-mailmerge-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-help-en-US-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-filters-optional-3.4.5.5-4.5.1 [done]
    Additional rpm output:
    Unregistering the older LibreOffice optional filter extensions...


    Installing: libreoffice-impress-extensions-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-writer-extensions-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-kde4-3.4.5.5-4.5.1 [done]
    Installing: libreoffice-gnome-3.4.5.5-4.5.1 [done]
    There are some running programs that use files deleted by recent upgrade. You may wish to restart some of them. Run 'zypper ps' to list these programs.

  4. #4

    Default Re: re-install software with yast

    If I will do it in yast I will just enable the oss, non-oss and update repositories
    If there are some multimedia issues involving third party repository I will leave the packman
    repo enable also and will do the re-installation/update of package in a selective manner.

    Before re-installation of the package you can look at the versions also to choose which one
    to be installed. You can find it in one of the options in yast2.

    Note:
    You did not specify what DE you are using (kde/gnome etc) so it is hard to find out
    exactly how you can do the right move.
    People who do not break things first will never learn to create anything

  5. #5
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: re-install software with yast

    Will you please show a list of your repositories? Show the results of

    Code:
    zypper lr -d

  6. #6

    Default Re: re-install software with yast

    just to let you know the system crashed because of a mistake I made. I was updating the computer when I was debugging some programs. the program caused the computer to stop responding and I did a hard shutdown. I am using Gnome 3. it would be nice if I can use KDE but once i started using Gnome KDE would not start up. Gnome is way to buggy.

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+--------------------+----------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | google | google | Yes | No | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/x86_64 |
    2 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
    3 | nvidia | nvidia | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/12.1/ |
    4 | packman-essentials | packman-essentials | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_12.1/Essentials/ |
    5 | packman-multimedia | packman-multimedia | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_12.1/Multimedia/ |
    6 | repo-debug | openSUSE-12.1-Debug | No | Yes | 99 | yast2 | Index of /debug/distribution/12.1/repo/oss |
    7 | repo-debug-update | openSUSE-12.1-Update-Debug | No | Yes | 99 | rpm-md | Index of /debug/update/12.1 |
    8 | repo-non-oss | openSUSE-12.1-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/non-oss |
    9 | repo-oss | openSUSE-12.1-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/oss |
    10 | repo-source | openSUSE-12.1-Source | No | Yes | 99 | yast2 | Index of /source/distribution/12.1/repo/oss |
    11 | repo-update | openSUSE-12.1-Update | Yes | Yes | 99 | rpm-md | Index of /update/12.1 |

  7. #7
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: re-install software with yast

    Quote Originally Posted by bigrockcrasher View Post
    just to let you know the system crashed because of a mistake I made. I was updating the computer when I was debugging some programs. the program caused the computer to stop responding and I did a hard shutdown. I am using Gnome 3. it would be nice if I can use KDE but once i started using Gnome KDE would not start up. Gnome is way to buggy.

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+--------------------+----------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | google | google | Yes | No | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/x86_64 |
    2 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
    3 | nvidia | nvidia | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/12.1/ |
    4 | packman-essentials | packman-essentials | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_12.1/Essentials/ |
    5 | packman-multimedia | packman-multimedia | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_12.1/Multimedia/ |
    6 | repo-debug | openSUSE-12.1-Debug | No | Yes | 99 | yast2 | Index of /debug/distribution/12.1/repo/oss |
    7 | repo-debug-update | openSUSE-12.1-Update-Debug | No | Yes | 99 | rpm-md | Index of /debug/update/12.1 |
    8 | repo-non-oss | openSUSE-12.1-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/non-oss |
    9 | repo-oss | openSUSE-12.1-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/oss |
    10 | repo-source | openSUSE-12.1-Source | No | Yes | 99 | yast2 | Index of /source/distribution/12.1/repo/oss |
    11 | repo-update | openSUSE-12.1-Update | Yes | Yes | 99 | rpm-md | Index of /update/12.1 |
    Next time, please wrap it in CODE tags. Remove or disable all repositories except #s 4, 5, 8, 9 and 11. Then first try

    Code:
    rpm --rebuilddb
    and see if you can reinstall the software after that. If not, do a distribution upgrade,

    Code:
    zypper dup
    This will install the original versions from the official and Packman repos.

  8. #8

    Default Re: re-install software with yast

    cool it worked thanks dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •