Results 1 to 4 of 4

Thread: Problems installing/running menmosyne

  1. #1
    Join Date
    Feb 2010
    Location
    Florida,USA
    Posts
    80

    Default Problems installing/running menmosyne

    I downloaded this application Welcome to the Mnemosyne Project | The Mnemosyne Project and I'm trying to get it to work.
    According to the readme these are the dependencies. :
    Code:
     
    -Python 2.4 or later (http://www.python.org)
    -PyQt 3.x (http://www.riverbankcomputing.co.uk/software/pyqt/download3)
    -pygame and its dependencies (http://www.pygame.org)
    -If you want to be able to enter formulas using latex syntax, make sure that
     latex is installed.
    -EasyInstall from http://peak.telecommunity.com/DevCenter/EasyInstall
    I installed all except for Latex. and proceeded to run the python installer. everything went well, apparently, but when trying to run the app I get the following error.
    Code:
     
    Traceback (most recent call last):
      File "/usr/local/bin/mnemosyne", line 5, in <module>
        pkg_resources.run_script('Mnemosyne==1.2.2', 'mnemosyne')
      File "build/bdist.linux-i686/egg/pkg_resources.py", line 489, in run_script
        yield ep
      File "build/bdist.linux-i686/egg/pkg_resources.py", line 1207, in run_script
        
      File "/usr/local/lib/python2.7/site-packages/Mnemosyne-1.2.2-py2.7.egg/EGG-INFO/scripts/mnemosyne", line 11, in <module>
        from qt import *
    ImportError: No module named qt
    This is what I hate about linux. Installing applications that aren't included in your distro's repositories is a hell.
    for now I just downloaded the windows version and ran it through wine. However it feels wrong having to do this when a native version is available.

    I would appreciate any help in getting this to work.
    Many thanks.

    PS: I'm running openSuse 12.1 x86_64 and Kde 4.8.1. Kernel 3.1.9-1.4-desktop.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,996

    Default Re: Problems installing/running menmosyne

    What about looking here and installing from there?
    software.opensuse.org: Search Results
    Henk van Velden

  3. #3
    Join Date
    Feb 2010
    Location
    Florida,USA
    Posts
    80

    Default Re: Problems installing/running menmosyne

    Thank you !

    I wasn't aware of that package search tool. In the future, I will make sure to use that service to find out if the application I want to install already exists in other repositories, before trying to install from source.
    software.opensuse.org: Download openSUSE 12.1

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,996

    Default Re: Problems installing/running menmosyne

    You are welcome.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •