Results 1 to 5 of 5

Thread: OCTAVE-ODEPKG

  1. #1

    Default OCTAVE-ODEPKG

    I have noticed that there is no ODEPKG in any repository for OpenSuse11.4

    Why is that?

    Helio

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: OCTAVE-ODEPKG

    Am 26.03.2012 14:36, schrieb schechtman:
    >
    > I have noticed that there is no ODEPKG in any repository for
    > OpenSuse11.4
    >
    > Why is that?
    >
    > Helio
    >
    >

    From the blacklist file on the science repository
    Code:
    Following isn't packaged:
    ~~~~~~~~~~~~~~~~~~~~~~~~~
    video -- wants proprietary libraries
    bugfix-3.0.6 -- doesn't make sense with newer versions with octave
    windows -- another os functionality
    engine -- not true octave package (from Fedora spec file)
    octproj -- requires libproj-devel from packman, but its license looks good
    spline-gcvspl -- I think license is not compatible with GPL
    dicom -- requires gdcm which doesn't exist in BS attow
    communications -- doesn't built with octave 3.4.3 (checked again with 3.6.1)
    es -- doesn't build with octave 3.4.3 (checked again with 3.6.1)
    gsl -- doesn't build with octave 3.4.3 (checked again with 3.6.1)
    pt_br -- doesn't build with octave 3.4.3 (checked again with 3.6.1)
    ad -- doesn't build with octave 3.6.1
    odepkg -- doesn't build with octave 3.6.1
    so it simply does not build for them with the current octave version. If
    you know a way how to build it I recommend you contact the maintainers
    of the science repo and tell them how to fix it.

    --
    PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
    GeForce GT 420
    Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.1
    | nVidia ION
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
    xf86-video-geode

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default AW: Re: OCTAVE-ODEPKG

    The following compiles (using the newest svn version of the odepkg package)
    Code:
    svn co https://octave.svn.sourceforge.net/svnroot/octave/trunk/octave-forge/main/odepkg odepkg
    tar -czf odepkg.tar.gz odepkg
    octave -qf --eval "pkg install odepkg.tar.gz"
    ignore the usual warnings it spits out while it builds. If you run into an error report it back, then you need to install a dependency.
    I have not yet tested how good it works.

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default AW: Re: OCTAVE-ODEPKG

    The odeexamples work for me with the exception of the "odebdi" solver in the IDE examples, everything else looks good.

  5. #5

    Default Re: AW: Re: OCTAVE-ODEPKG

    Quote Originally Posted by martin_helm View Post
    The odeexamples work for me with the exception of the "odebdi" solver in the IDE examples, everything else looks good.
    Dear Martin,

    Thank you for your help. In the meantime, what I have done is simply not update the whole octave package.

    Helio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •