Results 1 to 2 of 2

Thread: Removing the Suspend and Hibernate options from Gnome's menu

  1. #1

    Default Removing the Suspend and Hibernate options from Gnome's menu

    Hi,

    On OpenSUSE 12.1 x86_64, Gnome 3.2 . I want to remove the suspend and hibernate options from the Gnome (Shell) menu as

    - suspend makes no sense IMO for a desktop
    - hibernate has a slight tendency to lock up

    I've found that I should configure these privileges using polkit. I've dropped a file named 90-disable-suspend.conf ( also tried 90-disable-suspend.pkla ) in /etc/polkit-1/localauthority.conf.d with the following contents:
    Code:
    [Disable Suspend]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate;org.freedesktop.upower.suspend
    ResultAny=no
    ResultInactive=no
    ResultActive=no
    However, running pkcheck --action-id org.freedesktop.upower.suspend --process $$ prints nothing and has an exit code of 0 , and the menu entries are still present. AFAICT these are provided by gnome-shell-extension-alt-status-menu package.

    How can I remove the suspend and hibernate entries from the Gnome Shell menu and leave only Power Off?

    Thanks,

    Robert

  2. #2

    Default Re: Removing the Suspend and Hibernate options from Gnome's menu

    Courtesy of unix.stackexchange.com, opensuse - Removing supend and hibernate privileges - Unix and Linux - Stack Exchange :

    The directory /etc/polkit-1/localauthority.conf.d is reserved for configuration files.

    You should put your file in a subdirectory of /var/lib/polkit-1/localauthority and with extension .pkla. The directory /etc/polkit-1/localauthority should be ok too, but can be modified by updagraded/installed packages, so better to avoid it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •