Results 1 to 6 of 6

Thread: Conduit won't start

  1. #1

    Default Conduit won't start

    Hello,

    opensuse 12.1 64 bits

    I installed Conduit but it won't start

    I tried to launch it from the terminal to see some output and this is it:

    Code:
    me@mymachine:~> conduit
    Traceback (most recent call last):
      File "/usr/bin/conduit.real", line 23, in <module>
        app = conduit.Main.Application()
      File "/usr/lib/python2.7/site-packages/conduit/Main.py", line 53, in __init__
        conduit.GLOBALS.settings = Settings()
      File "/usr/lib/python2.7/site-packages/conduit/Settings.py", line 93, in __init__
        import conduit.platform.SettingsGConf as SettingsImpl
      File "/usr/lib/python2.7/site-packages/conduit/platform/SettingsGConf.py", line 7, in <module>
        from gnome import gconf
    ImportError: No module named gnome
    me@mymachine:~>
    it seems like a dependency problem.

    Any hint ?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Conduit won't start

    Quote Originally Posted by catonano
    Hello,

    opensuse 12.1 64 bits

    I installed Conduit but it won't start

    I tried to launch it from the terminal to see some output and this is
    it:


    Code:
    --------------------

    me@mymachine:~> conduit
    Traceback (most recent call last):
    File "/usr/bin/conduit.real", line 23, in <module>
    app = conduit.Main.Application()
    File "/usr/lib/python2.7/site-packages/conduit/Main.py", line 53, in
    __init__ conduit.GLOBALS.settings = Settings()
    File "/usr/lib/python2.7/site-packages/conduit/Settings.py", line 93,
    in __init__ import conduit.platform.SettingsGConf as SettingsImpl
    File
    "/usr/lib/python2.7/site-packages/conduit/platform/SettingsGConf.py",
    line 7, in <module> from gnome import gconf ImportError: No module
    named gnome me@mymachine:~>
    --------------------


    it seems like a dependency problem.

    Any hint ?

    Thanks

    Hi
    Is python-gnome installed?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
    up 5 days 20:06, 2 users, load average: 0.02, 0.04, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  3. #3

    Default Re: Conduit won't start

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Is python-gnome installed?
    Malcom,

    no, it was not installed, I installed it and now Conduit starts. Thanks

    But if python-gnome is a Conduit dependency shouldn't it be installed automatically when conduit is installed ?

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Conduit won't start

    On 2012-03-21 22:26, catonano wrote:
    > But if python-gnome is a Conduit dependency shouldn't it be installed
    > automatically when conduit is installed ?


    Yes.

    You could report that bug in Bugzilla.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Conduit won't start

    Quote Originally Posted by Carlos E. R.
    On 2012-03-21 22:26, catonano wrote:
    > But if python-gnome is a Conduit dependency shouldn't it be installed
    > automatically when conduit is installed ?


    Yes.

    You could report that bug in Bugzilla.
    Hi
    True, but I'm just confirming with the openSUSE Gnome folks on IRC,
    then if needed I will branch and fix...

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
    up 6 days 3:51, 4 users, load average: 0.10, 0.06, 0.06
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  6. #6

    Default Re: Conduit won't start

    Malcom,

    Quote Originally Posted by malcolmlewis View Post
    True, but I'm just confirming with the openSUSE Gnome folks on IRC,
    then if needed I will branch and fix...
    Thank you. Dealing with the Novell Bugzilla is a bit cumbersome for me at this stage.
    Would you please let me know if you can confirm this and possibly fix it ?

    Thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •