Results 1 to 3 of 3

Thread: New Menu Items Disappear

  1. #1
    Join Date
    Mar 2012
    Posts
    10

    Default New Menu Items Disappear

    I will use xscreensaver for this example, but the same thing happens regardless of the application involved.

    I "installed" xscreensaver and its related packages because the GNOME default screensaver has few choices in it; I just don't like it as much.

    But during the installation process, no menu items for either xscreensaver (in order to start it up) or xscreensaver-demo (in order to configure xscreensaver) were created for me. So, ok, I said to myself, "Fine. No problem. I will just find a way to create the menu items myself."

    Going into the Control Center (I'm using openSUSE 11.3.....and please don't send me replies geared towards, "oh, well use openSUSE 12.1; it works fine there"; I don't want to use openSUSE 12.1 or whatever the latest version is - I have very specific reasons why I'm using 11.3 and I will not upgrade to the latest version unless openSUSE makes its GNOME desktop look like the GNOME desktop in CentOS 6.2 or Fedora Core 16 or RHEL W 6.2 or Ubuntu 10.04 Netbook) and going to the Look and Feel section, I started up the application called Main Menu.

    Within the Main Menu application, I expanded out Preferences and highlighted Look and Feel by clicking on it. Then I did a "New Item" and created a menu item for xscreensaver and then I did another "New Item" and created a menu item for xscreensaver-demo. Then I closed the Main Menu application.

    But when I went into the Control Panel, the new menu items weren't there. And when I went back into the Main Menu application and looked in "Look and Feel", they weren't there either. So I went to create them again and as soon as I created one of them, the two missing ones showed back up. So, I closed the Main Menu application and went back into the Control Center and they still weren't there. Then I went back into the Main Menu application and now all three new items had disappeared.

    Now this may be a bug or maybe I'm missing a step that needs to be done. But whatever the problem is, surely someone must be familiar with this problem and can tell me how to fix it. Any help would be greatly appreciated.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: New Menu Items Disappear

    On 2012-03-19 16:56, sktd wrote:

    > Going into the Control Center (I'm using openSUSE 11.3.....and please
    > don't send me replies geared towards, "oh, well use openSUSE 12.1; it


    I won't. Nevertheless, you have to be warned that 11.3 is out of
    maintenance. I will try to replicate what you do, but as I don't have 11.3,
    I may fail.

    > RHEL W 6.2 or Ubuntu 10.04 Netbook) and going to the Look and Feel
    > section, I started up the application called Main Menu.


    I have something in the panel called "Traditional Main Menu". Is that it?

    > Within the Main Menu application, I expanded out Preferences and


    I see no preferences, so it is not that "main menu". You will have to find
    the executable file name and tell me.


    For the record, I use "xscreensaver", "xscreensaver-command -prefs"
    directly from the command line.

    > highlighted Look and Feel by
    > But when I went into the Control Panel, the new menu items weren't
    > there. And when I went back into the Main Menu application and looked in
    > "Look and Feel", they weren't there either. So I went to create them
    > again and as soon as I created one of them, the two missing ones showed
    > back up. So, I closed the Main Menu application and went back into the
    > Control Center and they still weren't there. Then I went back into the
    > Main Menu application and now all three new items had disappeared.


    So, this looks like a bug. You will not like this, but I have to say it:
    try to update, and perhaps it has been solved - or perhaps not. :-P

    > Now this may be a bug or maybe I'm missing a step that needs to be
    > done. But whatever the problem is, surely someone must be familiar with
    > this problem and can tell me how to fix it. Any help would be greatly
    > appreciated.


    No, sorry, I'm not familiar with it. I think I tried years ago to create
    menu entries and failed. I use instead a command line applet that displays
    in a list the commands I typed before. Or, I create a drawer and put inside
    apps.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,175
    Blog Entries
    14

    Default Re: New Menu Items Disappear

    Just a thing to consider: not only is openSUSE 11.3 no longer supported, you also will find that most of the people in the forums will -at least in a year from now- not have an 11.3 install available to help you out, compare your situation to that on their own system.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •