Results 1 to 7 of 7

Thread: KDE Wallet coming up right after logging in

  1. #1
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Arrow KDE Wallet coming up right after logging in

    Every time I boot up openSUSE 12.1 (KDE 4.7), even before I start going into anything, I get the following request for KDE wallet service
    Is there a way to either have it not ask for the password or not ask until I am opening kmail or kontact?

    The only reason I can think it comes up when I boot up is because of the calendar widget on the panel.

    Am I going to need to remove it from KWallet completely?
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE Wallet coming up right after logging in

    Quote Originally Posted by dragonbite View Post
    Every time I boot up openSUSE 12.1 (KDE 4.7), even before I start going into anything, I get the following request for KDE wallet service
    Is there a way to either have it not ask for the password or not ask until I am opening kmail or kontact?

    The only reason I can think it comes up when I boot up is because of the calendar widget on the panel.

    Am I going to need to remove it from KWallet completely?
    If you are not using KNetworkManager with a Wireless connection and you do not want to see or use KWalletManager then go to KDE menu / System / Desktop Applet / KWalletManager which places it into the System Tray. Between the System Tray and the Clock is a small triangle and it points up when hidden System Tray functions are not displayed. Click below it, the triangle points down and hidden System Tray functions are displayed. Select the KDE Wallet Manager. Then Pick Settings / Configure Wallet. On the Wallet Preferences Tab, un-check Enable KDE Wallet subsystem and hit Apply on the bottom right. It might freeze up for a moment, but this should disable Wallet from normal operation.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Re: KDE Wallet coming up right after logging in

    Is KNetworkManager the default application for openSUSE 12.1 installed from the LiveCD?
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: KDE Wallet coming up right after logging in

    I would say the message tells you who asks for a password: Akonadi Google Calender Resource.
    This makes me thinking that you are using something like a Google Calender. I guess that you should know you do. And you should decide if you need it and when yes if you need it to start up immedially after login.

    I do not use Google Calender whatever. But, well I am not using Akonadi. That is, every few days when I start up, it starts, but it then dies. I in fact do not even understand what it is.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: KDE Wallet coming up right after logging in

    dragonbite:
    If you have just wired (Ethernet) networking then ifhup (a.k.a. "traditional") networking control is installed. If you have wireless, then KNetworkManagement installs. (At least with DVD installs, I would assume Live CD is same)

    Wireless usually needs a passkey for the Access Point interface, KNetworkmanagement uses KDEWallet to store the passkey, and you would see an "open Wallet" prompt for that. Since your Wallet open is requested by the Calendar Widget, I'll assume you are Ethernet connected..

    Anyway, a password is required the connect to your online Google Calendar. I don't use the same Widget you are using, rather I have Google Calendar connected to my Thundebird email client using the Lightning and Google Provider plugins. In my setup, I believe Tbird caches my Google Calendar password during the Google Provider setup.

    If you choose to not use Wallet to open the Widget, you will likely have to manually enter your Google Calendar password each time, if the Widget will setup that way.
    I don't use Akondai, so can't help much. I believe Akondai is an information broker app for KDEPim, I have found it to be a resource hog and frequent crash victim in prior SuSE releases. I have not tried to make it work on 12.1.

    FYI, you can also use Wallet to secure your online passwords and the like, it integrates with Firefox using the KWallet plugin.

  6. #6
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Re: KDE Wallet coming up right after logging in

    I am connected wirelessly and I am using Akondi for my gmail, google calendar and google contacts.

    This comes up, though, without KMail or Kontact being active. If it came up when I started Kontact (or the calendar app alone) then it would make sense.

    I am thinking that somehow either appointment alerts, or attempts to integrate it into the calendar that comes up when you click on the clock, may be requesting the Google calendar and thus opening KWallet.

    I haven't tried it yet, but if whatever process is trying to open my Goolge Calendar can save my password outside of KWallet, then it should eliminate this prompt. Doesn't mean it won't prompt for the Wireless passkey when it trys to connect, but it will connect even if I don't enter my information for the Calendar.

    At least I use 2-step authorization with my Google accounts, so it isn't my actual Google password being passed, rather an application code that only allows applications access to my account apps (calendar, mail, etc.) but does not allow access through a browser (which is required to add more, or make changes to my settings).
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  7. #7
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: KDE Wallet coming up right after logging in

    OK, you are off in a space I have not played in so I can't help much.

    You might want to try booting 12.1 with systemV rather than the default, systemd.
    You hit F5 at the grub boot screen to make the selection.

    It seems to me (having just transitioned from 11.4 to 12.1) that with systemd the desktop is up and active before the network is fully up.
    SystemV orders things differently, you might find a different dynamic for getting your calendar started.

    Good luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •