Results 1 to 8 of 8

Thread: KDE Windows skew screen at edges

  1. #1

    Default KDE Windows skew screen at edges

    So I did the ultimately foolish thing a few weeks ago... I decided to edit my system configuration under the influence of alcohol.

    Basically, I've managed to change some setting so that whenever I'm dragging a window, if my cursor is near the edge of the screen - it skews the whole screen, as if getting ready to box-flip to the next desktop. I turned off the ability to switch desktops by dragging windows... And I've checked through all of the window configuration options, everything in the control panel... I genuinely have no idea what I did?

    Does anybody know what I've done? I understand that, for a first post, this is just abysmally stupid, but I would really appreciate the help! It's kinda annoying having my screen deform whenever I try and move windows around the screen!

    P.S: I'm not sure how well I've described what I mean by the "screen skewing", let me know and I'll attach a screenshot if necessary.
    P.P.S: OpenSUSE 12.1, if it's relevant at all

  2. #2
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: KDE Windows skew screen at edges

    Hmmm ... Try changing the settings in
    Systemsettings > Workspace Behaviour > Screen Edges for "Window Management". There are two checkboxes. The first says
    [] Maximize windows by dagging them to the top of the screen
    And the second:
    [] Tile windows by dragging them to the side of the screen
    Are they unchecked?

    (OK, at least there are these two checkboxes in KDE 4.8, not sure about earlier releases.)


    If that is not it, what about the "Active Screen Edge Actions" in the same place as mentioned above? Is anything set there, like "Show Desktop" or "Show Dashboard"? Although, none of these actions should be triggered when dragging windows.

  3. #3

    Default Re: KDE Windows skew screen at edges

    Those tickboxes are checked, but un-ticking them (and applying changes, obviously) doesn't change the screen-skewing.
    Same as some of the screen-edge-actions - there are some, but getting rid of them doesn't change the screen-skewing.

    I'm just now trying to take a picture to show what I mean, but finding out that print-screens are impossible when dragging windows. I'll attach a picture as soon as I work out a way around that

  4. #4
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: KDE Windows skew screen at edges

    Quote Originally Posted by MinatureCookie View Post
    Those tickboxes are checked, but un-ticking them (and applying changes, obviously) doesn't change the screen-skewing.
    Same as some of the screen-edge-actions - there are some, but getting rid of them doesn't change the screen-skewing.

    I'm just now trying to take a picture to show what I mean, but finding out that print-screens are impossible when dragging windows. I'll attach a picture as soon as I work out a way around that
    Try timed screenshots, i.e. screenshots with a delay.

  5. #5

    Default Re: KDE Windows skew screen at edges

    That was a good idea - got a print-screen now
    http://img822.imageshack.us/img822/3243/snapshot4y.png
    You can see at the top, it does actually show the desktop that is above the current one. But again, you cannot change desktop by dragging windows. That option is definitely disabled.

  6. #6
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: KDE Windows skew screen at edges

    Quote Originally Posted by MinatureCookie View Post
    That was a good idea - got a print-screen now
    http://img822.imageshack.us/img822/3243/snapshot4y.png
    You can see at the top, it does actually show the desktop that is above the current one. But again, you cannot change desktop by dragging windows. That option is definitely disabled.
    That is not a feature of the KDE desktop! That is just a bugged mess of various desktop effects. I can spot rudiments of the desktop cube, Window geometry, and everything going transparent.

    In other words, there is not that one setting that needs to be unset to undo that, because, well, that is not a KDE feature. It looks more like trying to hunt down that one shot settings file, which can be some arduous task. Maybe you could try and see what happens when you trash the KWin settings and then start a new session. The settings should be in:
    Code:
    ­~/.kde4/share/config/kwinrc
    If that fails, then try to trash anything in that directory with 'kwin' in its name.



    ETA: The tilde '~' means your home directory.

  7. #7

    Default Re: KDE Windows skew screen at edges

    Ahh, yeah this got rid of it!
    Would have been nice to know what was causing it specifically, I suppose... But ah well

    Thanks so much!

  8. #8
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: KDE Windows skew screen at edges

    Quote Originally Posted by MinatureCookie View Post
    Ahh, yeah this got rid of it!
    Would have been nice to know what was causing it specifically, I suppose... But ah well

    Thanks so much!
    Good to hear that everything is back to normal. If you still have the old KWin config file, then nothing prevents you from opening it in KWrite or so and comparing it with the new config file. Maybe that gives you some kind of hint.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •