Results 1 to 6 of 6

Thread: 12.1 can't change languages properly

  1. #1

    Default 12.1 can't change languages properly

    I'm trying to switch my desktop permanently from English to German. In 11.4 I could do this with absolutely no problems through Yast.

    In 12.1 I did the same thing and ended up with an annoying incomplete mix -- 75% of my computer is in German and the other 25% in English. As an example, the different "tabs" of the KDE menu (Favorites, Applications, Computer, History, Shutdown) are translated, but most of the application entries themselves are not. (LibreOffice is pretty humorously categorized under "Anwendungen" -> "Office" rather than "Anwendungen" -> "Büro".)
    Most applications (all KDE apps, LibreOffice, Wine) are translated completely themselves, but a few others such as Firefox and (interestingly) the Yast menu are not translated at all. Perhaps there is some setting that I am still missing?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,271

    Default Re: 12.1 can't change languages properly

    Do yo have all the language packages for German belonging to those applications installed?
    YaST> Software > Software management and then the use the View menu to choose the Languages view.
    Henk van Velden

  3. #3

    Default Re: 12.1 can't change languages properly

    Quote Originally Posted by hcvv View Post
    Do yo have all the language packages for German belonging to those applications installed?
    YaST> Software > Software management and then the use the View menu to choose the Languages view.

    Thanks. I knew I was missing something! That fixed most of the still untranslated applications as far as I can tell.

    What about my KDE menu as I mentioned? Items having to do with location (home folder, network) are translated but those relating to actual programs ("Web Browser" - firefox, "Audio Player" - amarok) are still not. Under 11.4 I seem to recall those menu items being translated and re-ordered.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,271

    Default Re: 12.1 can't change languages properly

    My idea is that when you switch KDE to another language, it actively seraches for the translations it has to use in the application items in it's menu.
    Also when you install an application, that is a trigger for adding something to the menu (in the correct language when possible).
    But when you change the language and the proper translation can not be found (as you did earlier) either nothing is changed or it falls back to a default language (which I assume to come out as english in your case).
    When you then install a language package, I guess that is not a trigger at all.
    Thus IMHO you should change KDE back to english and then again to german to reinstate things to be done in the cortrect sequence.
    Just a suggestion.
    Henk van Velden

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 12.1 can't change languages properly

    On 2012-03-13 10:16, hcvv wrote:
    >
    > My idea is that when you switch KDE to another language, it actively
    > seraches for the translations it has to use in the application items in
    > it's menu.


    As a translator myself, I'm interested. I think the menus are translated
    (when they are) in a branch named "packages" or perhaps in the
    "update-desktop-files-*.po" files. My personal though on these, when I
    tried once, is that they are thousands of strings that you translate once
    and next year you have to translate again from scratch almost, so it is
    disappointing and in the end translators abandon that task.

    I don't know if that is the case for German, but it is for Spanish, AFAIK.


    For the "layman" I'll say that translation is done by volunteers and it is
    a somwehat boring task. Even devs forget the task, tools to do this are
    incomplete, and some devs do not help when they create confusing strings
    without context comments for translators.

    > Thus IMHO you should change KDE back to english and then again to
    > german to reinstate things to be done in the cortrect sequence.
    > Just a suggestion.


    By the way: you can change the language for the user independently from the
    system (yast). KDE should have its own setting.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6

    Default Re: 12.1 can't change languages properly

    Quote Originally Posted by hcvv View Post
    Thus IMHO you should change KDE back to english and then again to german to reinstate things to be done in the cortrect sequence.
    This worked. I also discovered that for some reason I had translations for both KDE3 and KDE4 installed. I guess that might have caused some problems. Removing the KDE3 translations and switching to English and back to German fixed the problem.

    So, for anyone else who comes across the same issue, the moral of the story is double- and triple-check the packages you have installed...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •