Results 1 to 10 of 10

Thread: Strange landscape printing problem

  1. #1
    Join Date
    Mar 2011
    Location
    Mesa, AZ
    Posts
    15

    Post Strange landscape printing problem

    I've searched through the forums and don't seem to find one that matches my problem.

    It's been so long since I've had a printer problem, I don't know what
    more to do to figure out this one. Two computers, both running openSUSE
    11.4 and WindowMaker and sharing a Samsung ML-2525 printer. When we
    select 'landscape' from most programs (LibreOffice, Okular, Firefox and
    others) it will not print in landscape.

    I can print landscape from command line:

    lp -o landscape [filename]

    and, so far, the only GUI program that prints landscape is the old
    Quanta 3+. I was going to setup a second printer to be defaulted to
    landscape, but there is no way to set that in YaST->Hardware->Printer
    or in CUPS.

    I have verified that the correct driver is installed and have even
    downloaded (from Samsung) and installed their latest driver -- which
    was the same version number, anyway.

    Everything I found with a web search was either wrong printer driver or
    even command line printing not doing landscape. None of them seemed to
    mirror my problem. This same printer under 11.3 had no problem with
    this. Since we don't print landscape that often, the command line
    option is workable, but not optimal. :-)

    Any ideas where to go with this, next?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Strange landscape printing problem

    I have seen mention of this somewhere before but only in 12.1 L.Office
    Users who export to .pdf can then print in landscape
    So it's not quite the same as your problem
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2011
    Location
    Mesa, AZ
    Posts
    15

    Default Re: Strange landscape printing problem

    I have seen mention of this somewhere before but only in 12.1 L.Office
    Users who export to .pdf can then print in landscape
    So it's not quite the same as your problem
    Yes, that's what I have found, too. I save or export the file as Postscript, generally, but tried PDF as well. Same thing, though. I can only print landscape from command line and the old Quanta 3+. The other programs are *trying* to print landscape but they are not switching orientation 90 degrees...

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,496

    Default Re: Strange landscape printing problem

    After I upgraded to LO 3.4, I had a problem with all my landscape documents which I eventually solved by going into Printer Settings and checking Properties on each which usually said Portrait; changing that to Landscape and saving the document solved the problem.

    I have never got Okular to print in landscape properly though there is alleged to be a workaround; so I install KPDF from kdegraphics3 which prints landscape perfectly.

    Can't help in any other areas.

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,431
    Blog Entries
    14

    Default Re: Strange landscape printing problem

    The solution for LO is to set the device properties of the printer to Postscript instead of PDF
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Strange landscape printing problem

    On 2012-03-12 07:46, knathan54 wrote:
    > I've searched through the forums and don't seem to find one that matches
    > my problem.


    View this thread: http://forums.opensuse.org/showthread.php?t=472640

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Mar 2011
    Location
    Mesa, AZ
    Posts
    15

    Default Re: Strange landscape printing problem

    Quote Originally Posted by john_hudson View Post
    After I upgraded to LO 3.4, I had a problem with all my landscape documents which I eventually solved by going into Printer Settings and checking Properties on each which usually said Portrait; changing that to Landscape and saving the document solved the problem.
    This didn't work for me -- it would not save the Landscape setting no matter what I tried. :-)

  8. #8
    Join Date
    Mar 2011
    Location
    Mesa, AZ
    Posts
    15

    Default Re: Strange landscape printing problem

    Quote Originally Posted by Knurpht View Post
    The solution for LO is to set the device properties of the printer to Postscript instead of PDF
    This worked for LO -- thanks! Now I just have to figure out the other programs; it will probably be a similar solution.

  9. #9
    Join Date
    Mar 2011
    Location
    Mesa, AZ
    Posts
    15

    Default Re: Strange landscape printing problem

    Quote Originally Posted by robin_listas View Post
    This thread had the answer, but I missed it among all the replies until I saw Knurpht's reply, above. :-)

  10. #10
    Join Date
    Mar 2011
    Location
    Mesa, AZ
    Posts
    15

    Cool Re: Strange landscape printing problem

    Thanks to all those that replied! Very helpful!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •