Results 1 to 7 of 7

Thread: Issue when trying to update packages from Yast

  1. #1

    Default Issue when trying to update packages from Yast

    Hi again.

    I was about to update my system using the Yast manual method: applying switch to installed repos, leaving Packman the last, and at the very last updating packages in @System repo. But when applying switch to Packman a message popped out saying:

    A problem has been encountered with installed package portaudio-19-273.1.3.x86_64
    -uninstall portaudio-19-273.1.3.x86_64
    -keep old portaudio-19-273.1.3.x86_64

    Until now I've only used Packman to install the multimedia stuff from mr. Caf's guide and aMSN. I also installed Goldendict but not by using Yast, but downloading the RPM file from the Education repo and running it. It downloaded some additional stuff I don't remember before installing, and I don't know whether it had negative effect on Packman packages.

    What's that portaudio problem? Did I did something wrong according to what I have installed?
    Thanks for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Issue when trying to update packages from Yast

    keep old version
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Issue when trying to update packages from Yast

    Hi, I updated my system again and got the same portaudio issue with the same question and choices. I chose to keep old version.
    Why did I get the same issue? Is something wrong with previous installed packages from other repos, or will I get that message each time I update packages by applying switch to Packman?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,985
    Blog Entries
    14

    Default Re: Issue when trying to update packages from Yast

    Quote Originally Posted by F_style View Post
    or will I get that message each time I update packages by applying switch to Packman?
    it

    Yep. More elaborate: first you tell Yast to switch all possible packages to the Packman repo. Doesn't work for the portaudio package, so that's still from the OSS repo. Next time you tell Yast to make the switch, it will meet the same package issues, unless Packman has a newer version that does not conflict.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Issue when trying to update packages from Yast

    Quote Originally Posted by caf4926 View Post
    keep old version
    Problem: problem with installed package portaudio-19-273.1.3.x86_64
    Solution 1: deinstallation of portaudio-19-273.1.3.x86_64
    Solution 2: keep obsolete portaudio-19-273.1.3.x86_64

    I selected solution 1. portaudio was removed, but it was replaced by libportaudio2.
    According to Software Management the two packages have identical description.

    So, why is one supposed to keep the old version? Thanks.

  6. #6

    Default Re: Issue when trying to update packages from Yast

    Quote Originally Posted by afshine View Post
    Problem: problem with installed package portaudio-19-273.1.3.x86_64
    Solution 1: deinstallation of portaudio-19-273.1.3.x86_64
    Solution 2: keep obsolete portaudio-19-273.1.3.x86_64

    I selected solution 1. portaudio was removed, but it was replaced by libportaudio2.
    According to Software Management the two packages have identical description.

    So, why is one supposed to keep the old version? Thanks.
    You are not. portaudio package was renamed to libportaudio2, but:
    a) Packman packaged it for a reason unknown to me
    b) There was a packaging error in multimedia:libs. Packman tried to fix it locally (instead of submitting the fix to multimedia:libs)... and did it wrongly.

    So it just a (or a few of them...) packaging error. Personally I just block the Packman package since I see no reason to update it.

  7. #7

    Default Re: Issue when trying to update packages from Yast

    Quote Originally Posted by RedDwarf View Post
    So it just a (or a few of them...) packaging error. Personally I just block the Packman package since I see no reason to update it.
    I still avoid the Packman version. But anyway now it's fixed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •