Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problems with glibc.so.6 versions missing in OS 11.4

  1. #1

    Default Problems with glibc.so.6 versions missing in OS 11.4

    I'm getting into the multimedia and as I do I'm finding that various things keep asking for an upgraded version of libc.so.6 that I don't ever seem to have a source for.

    For example when I tried to run Pitivi it asked for version 2.24 or later of the GTK+ which I believe is glibc. When I tried to install Gnome 3 it asked for 2.14 which it couldn't find (I don't really need Gnome 3, I just tried it as an exercise thinking it might upgrade my glibc.). That's just two of several times that this has happened.

    My system has the standard 2.11 of glibc that comes with OS 11.4 and looking around I have not been able to find any upgraded versions of it for 11.4.

    If it's built into some of these things I am upgrading then it's not getting upgraded when it should for some reason.

    What would be nice would be to list everything on my system that requires a version of glibc that's not 2.11, perhaps that way I can see a pattern, or just uninstall or downgrade those apps.

    As it is right now, I'm not sure how to get out of this stuck situation where everything I try asks for a different version of glibc.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    On 2012-03-08 22:06, Reg gie wrote:
    >
    > I'm getting into the multimedia and as I do I'm finding that various
    > things keep asking for an upgraded version of libc.so.6 that I don't
    > ever seem to have a source for.


    libc is not updatable. Upgrade the system instead.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    Quote Originally Posted by robin_listas View Post
    ibc is not updatable. Upgrade the system instead.
    I don't see that being the solution because even the Factory version of OS is only on 2.14 of glibc. That's not going to help with a piece of software that requires version 2.24. If it's not updatable then the only solution I see is to find versions of the software I want to use that will work with 2.11.

    Why is glibc not updatable and how do you when something is not updatable?

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    Am 08.03.2012 23:06, schrieb Reg gie:
    > Why is glibc not updatable and how do you when something is not
    > updatable?
    >

    I wonder what can require a glibc 2.24 which does not even exist
    upstream. The newest development version of glibc is 2.16
    http://www.gnu.org/software/libc/


    --
    PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
    GeForce GT 420
    Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.1
    | nVidia ION
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
    xf86-video-geode

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    On 2012-03-08 23:06, Reg gie wrote:
    > Why is glibc not updatable and how do you when something is not
    > updatable?


    Because all programs and libraries in the system depend on it. You would
    have to update all the programs and libraries, or what is the same, upgrade
    the system instead.

    In fact, it is easier to replace the kernel than glibc. There is a
    procedure to replace it, of course. zypper has to do it, after all, with
    zypper dup from one version to another, but it is a risky operation, as you
    learn if it stops midways.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    martin_helm:

    Actually just pitivi. However I am sure it is from some advanced repo. I installed. In any case, I did downgrade the version and it works now.

    There are some things I don't get: first, I don't see any repos. out of the ordinary, 2nd once I downgraded it the higher version of it disappeared from my list of versions. I guess the only conclusion is that that newer version came from some repo. I had and then removed -- probably because I saw it had all these version conflicts so I got rid of it but it must have left some stuff behind.

    robin_listas

    Thanks for that, very helpful.

    I have one last question. Is there way to list all apps (and other things I suppose) that rely on a version of a file greater than nn. In this case that would mean finding all apps that are installed that are relying on a version of glibc that's greater than 2.11. Perhaps that way I can clean up all these -yet to be found- issues at once.

    I just did a "zypper verify" and it came up clean -- I've been looking around for ways to test this.

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    Am 09.03.2012 00:06, schrieb Reg gie:
    >
    > martin_helm:
    >
    > Actually just pitivi. However I am sure it is from some advanced repo.
    > I installed. In any case, I did downgrade the version and it works now.
    >

    You did not get the point. Something like a glibc 2.24 simply does not
    exist anywhere in this universe.

    --
    PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
    GeForce GT 420
    Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.1
    | nVidia ION
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
    xf86-video-geode

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    On 2012-03-09 00:06, Reg gie wrote:

    > Thanks for that, very helpful.


    Welcome.

    > I have one last question. Is there way to list all apps (and other
    > things I suppose) that rely on a version of a file greater than nn.


    I don't know. Have a look at the manual of rpm, whatrequire and similar things.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    Quote Originally Posted by Reg_gie View Post
    I'm getting into the multimedia and as I do I'm finding that various things keep asking for an upgraded version of libc.so.6 that I don't ever seem to have a source for.
    You added the openSUSE 12.1 or Factory version of the repo, use the openSUSE 11.4 version.

    Quote Originally Posted by Reg_gie View Post
    For example when I tried to run Pitivi it asked for version 2.24 or later of the GTK+ which I believe is glibc.
    No, GTK+ and glibc are not related.

  10. #10

    Default Re: Problems with glibc.so.6 versions missing in OS 11.4

    Okay, that explains some. GTK+ 2.24 does exist, I thought they were the same thing for some reason.

    Then GTK+ can be upgraded?

    Here GTK+ Download: GNU/Linux there's a GLIB of a later version too. I gather is has no relation to GLibc.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •