Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: kmail 4.8.1 crash a lot

  1. #1
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default kmail 4.8.1 crash a lot

    hi

    don't know why but since i updated to kmail 4.8.1, it crash a lot....

    does somebody have the same problem?

    thanks

  2. #2
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: kmail 4.8.1 crash a lot

    You didn't post enough about this to get any reasonable responses. The crystal ball is broken today

    Run kmail from the command line and use susepaste to paste the results.

  3. #3
    -G- NNTP User

    Default Re: kmail 4.8.1 crash a lot

    collinm wrote:
    > don't know why but since i updated to kmail 4.8.1, it crash a lot....
    > does somebody have the same problem?


    Unfortunately yes :-(
    -G-

  4. #4

    Default Re: kmail 4.8.1 crash a lot

    Check whether you have any "Last Search" in your kmail folder tree and remove it. Posting a backtrace (install debuginfo packages) might also help to get to the source of the problem.

  5. #5

    Default Re: kmail 4.8.1 crash a lot

    I'm also having problems with Kmail2 or Akonadi. It doesn't crash, but mail bodies are not shown -- I even think that one mail body may have been stripped away by either Kmail2 or Akonadi. I recorded following console output:

    Code:
    user@localhost:~> kmail
    QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
    QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
    kmail2(6490)/kdepimlibs (mailtransport): Could not access Outbox. 
    kmail2(6490)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
    kmail2(6490)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
    kmail2(6490) MessageViewer::Util::fileNameForMimetype: unknown mimetype ""
    .xsession-errors shows problems with the database of Akonadi:

    Code:
    found 1 item parts to expire in collection "INBOX" 
    Error during updating record with id 11438  in table "PartTable" "Cannot execute statement: impossible to write to binary log since BINLOG_FORMAT = STATEMENT and at least one table uses a storage engine limited to row-based logging. InnoDB is limited to row-logging when transaction isolation level is READ COMMITTED or READ UNCOMMITTED. QMYSQL3: Unable to execute statement" 
    failed to update item part 11438 
    found 1 item parts to expire in collection "INBOX" 
    Error during updating record with id 11435  in table "PartTable" "Cannot execute statement: impossible to write to binary log since BINLOG_FORMAT = STATEMENT and at least one table uses a storage engine limited to row-based logging. InnoDB is limited to row-logging when transaction isolation level is READ COMMITTED or READ UNCOMMITTED. QMYSQL3: Unable to execute statement" 
    failed to update item part 11435 
    ...
    Version of akonadi and kmail is 4.8.1-331.2, installed from .../KDE:/Release:/48/openSUSE_12.1.

    Any help appreciated.

  6. #6

    Default Re: kmail 4.8.1 crash a lot

    KDE SC 4.8.1 packages for openSUSE

    and

    Help on KDE PIM data loss bugs

    might be helpful. Yet the crashes have nothing to do with that, hence a new thread might be more useful to not mix two issues.

  7. #7
    -G- NNTP User

    Default Re: kmail 4.8.1 crash a lot

    rabauke wrote:
    > Check whether you have any "Last Search" in your kmail folder tree and
    > remove it.


    Thanks! I had one, and it appeared to be empty (deleted it anyway) I will
    report back when (if) I have a new crash.

    > Posting a backtrace (install debuginfo packages) might also
    > help to get to the source of the problem.


    I will have to look into this, because I do not know what needs be done
    after installing a debuginfo package. Is it just install the package and
    looking for some log?

    BTW, my crashes happen when I try to read one unread message, but not every
    time.

    -G-

  8. #8

    Default Re: kmail 4.8.1 crash a lot

    Quote Originally Posted by -G- View Post
    rabauke wrote:[color=blue]
    I will have to look into this, because I do not know what needs be done
    after installing a debuginfo package. Is it just install the package and
    looking for some log?
    -G-
    If a KDE app crashes dr. konqi comes-up and tries to create a backtrace. You can click on the respective tab when it opens. It will rate the backtrace and offer to instell debuginfo packages. Without debuginfo the backtrace will be useless, i.e. does not contain any info that could hint at the cause o the crash.

    Usually you could report the crash directly via fr. konqi. However because the bugzilla installation on bugs.kde.org was just updated that feature is currently broken.

  9. #9
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: kmail 4.8.1 crash a lot

    rabauke wrote:
    [color=blue]
    >
    > -G-;2447050 Wrote:
    >> rabauke wrote:
    >> I will have to look into this, because I do not know what needs be done
    >> after installing a debuginfo package. Is it just install the package
    >> and
    >> looking for some log?
    >> -G-

    >
    > If a KDE app crashes dr. konqi comes-up and tries to create a
    > backtrace. You can click on the respective tab when it opens. It will
    > rate the backtrace and offer to instell debuginfo packages. Without
    > debuginfo the backtrace will be useless, i.e. does not contain any info
    > that could hint at the cause o the crash.
    >
    > Usually you could report the crash directly via fr. konqi. However
    > because the bugzilla installation on bugs.kde.org was just updated that
    > feature is currently broken.
    >
    >

    In my case kmail (Kontact just disappears from the screen. No crash wizzard
    comes up, no log info and restarting it work fine. Happens mainly when
    selecting an email to read or when deleting emails.

    Only thing I noticed that I question is Help about on help tab shows kontact
    4.8.0, knode 4.8.0 and kmail 4.8.0 but YaST and Zypper show 4.8.1-331.2 for
    each installed.

    Code
    -------
    info kmail
    Repository 'Iscan' is out-of-date. You can run 'zypper refresh' as root to
    update it.
    Loading repository data...
    Reading installed packages...


    Information for package kmail:

    Repository: KDE4.8_Release
    Name: kmail
    Version: 4.8.1-331.2
    Arch: x86_64
    Vendor: obs://build.opensuse.org/KDE
    Installed: Yes
    Status: up-to-date
    Installed Size: 3.5 MiB
    Summary: Mail Client
    Description:
    KMail is the KDE mail client.
    /Code
    ---------

    Using repo:
    http://download.opensuse.org/reposit...openSUSE_12.1/

    This started after update from 4.8.0 to 4.8.1 yesterday.



  10. #10

    Default Re: kmail 4.8.1 crash a lot

    I have seen one kontact crash since upgrading last night. I do have "last search" active. I will leave it be and see if I can get another crash, then will delete it again as a test and maybe see about getting a backtrace.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •