Results 1 to 10 of 10

Thread: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

  1. #1

    Default Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    Hey, Folks:

    Why is it such a difficult task to change a setting in System Settings in KDE that will leave the display on all the time? Can someone give me some pointers, please?

    Thank you,
    theAdmiral

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    system settings > display and monitor > screen saver
    uncheck start auto

    also in power management I set like this
    http://dl.dropbox.com/u/10573557/SUS...rsettings.jpeg
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    Quote Originally Posted by theAdmiral View Post
    Why is it such a difficult task to change a setting in System Settings in KDE that will leave the display on all the time? Can someone give me some pointers, please?
    Which version of openSUSE and which version of KDE are you using ?

    My experience in any OS and any GNU/Linux distro, is a display is switched OFF either due to :
    • screen saver setting, and/or
    • power management setting

    Accordingly did you go to the Power Management settings AND/OR the screen saver settings, and ensure there is nothing set there that would cause your display to keep turning OFF ?

    Edit: Beaten to the punch by caf4926, who gave better details as well !!

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    I have been having very intermittent issues with my 12.1/KDE4.8 laptop that may be what you are experiencing - frequent (after perhaps 30 seconds) screen blanking that responds immediately (turns back on ) to a mouse movement or keyboard hit.
    It seems like a Monitor powerdown ( as in Screen Energy Saving ), not screen saver, but I have none set.

    I have managed to "stop" it by Opening: System Settings - Power management and in the tab associated with my current configuration (usually On AC Power) selecting: Screen Energy Saving- 360 Minutes, then Apply, then deselecting Screen Energy Saving and Apply again. Since I had it set to "off", I wanted to forced a new "off" write.
    Something seems (seemed)to be randomly restarting the Screen Energy Saving function with a very brief (30 secs or less) time interval.

    I must also observe that I have not experienced this issue in perhaps 2 or 3 days, sort of thought it went away.

    I was contemplating a bug report, but was not even sure what to report it as.

    Try the above hack - see if it stops the blanking, at least for a while.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    This issue may also relate to which graphics card and driver is in use.

  6. #6
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    Yes, I thought of that, although I had been using Catalyst (ATI) 12.1 since my recent upgrade to SuSE 12.1 perhaps 3 weeks ago now.
    I did not have any issues after SuSE 12.1 was fully up and updated.

    My issues started during an interval while I was migrating the installed SuSE and Windows7 systems to a new set of hard drives and partition configurations. Both systems stabilized but the screen blanking would come and go over a few days span.
    The above hack seemed to work, at least for a while; I was unable to identify any particular action that would retrigger the blanking.

    I use Sleep (STR) most often on this machine.
    I performed a hard reboot last night, it still appears that the issue for me has disappeared.

    Perhaps an update in the past few days cleared it for good. ?

  7. #7

    Default Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    I just made the suggested adjustment. I will try it for the next day or so and see how it goes. It should work out fine, though. Big thanks,

    theAdmiral

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    In KDE there is another setting that, if not present, can allow your screen to go blank. There are three places that can cause this in KDE:

    1. Screen Saver Settings: Menu / Configure Desktop / Hardware / Display and Monitor / Screen Saver
    2. Power Settings: Menu / Configure Desktop / Hardware / Power Management
    3. KDE Screen Saver Settings in kscreensaverrc:

    Edit the file (in the hidden $HOME folder) ~/.kde4/share/config/kscreensaverrc

    [ScreenSaver]
    PlasmaEnabled=true
    Saver=glmatrix.desktop
    Timeout=600
    DPMS-dependent=false

    Add the setting DPMS-dependent=false to any other existing entries which will be based on your screen saver settings. This setting can apparently only be added manually as shown in this example. Log out and back into KDE for the setting to take effect immediately.

    Thank You,
    Last edited by jdmcdaniel3; 01-Jul-2012 at 05:43.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    I am probably remembering from when I was running 11.4.

    "Personal Settings" --> "Startup and Shutdown" --> "Service Manager"

    Uncheck the box for "power management", then if it still shows as running, click the "Stop" button.

    I have used that trick when watching video. Then I can turn power management back on afterward.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Display keeps turning off. Don't know how to change setting. Can't find it in System Settings.

    Quote Originally Posted by nrickert View Post
    I am probably remembering from when I was running 11.4.

    "Personal Settings" --> "Startup and Shutdown" --> "Service Manager"

    Uncheck the box for "power management", then if it still shows as running, click the "Stop" button.

    I have used that trick when watching video. Then I can turn power management back on afterward.
    Yes, the KDE setting is still there as: Menu / Configure Desktop / System Administration / Startup and Shutdown / Service Manager / Power Management (Check to use), but I am not sure I want to turn it off as it had other undesirable problems such as allowing the built-in kernel blanker to start working. This was a long time ago, in fact it may have been with openSUSE 11.3, but in any event, the steps mentioned before seem to be enough to prevent unwanted screen blanking without turning off Power Management. Thanks for your comments nrickert. In my case, I like to set a screen saver and would just as soon it does not shut off and this was what I have achieved so far, but every time a new version of openSUSE arrives, I seem to have to rediscover how to get this to work.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •