Results 1 to 3 of 3

Thread: Amarok mysql database question

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Amarok mysql database question

    Hi,

    I wanted to play some music, so I started amarok this time instead of
    banshee. I noticed that for the database it said it can use mysql instead
    of a localdatabase, so I tried. I created the database as the instructions
    on the help of the configuration window say:

    Code:
    
    > Telcontar:~ # mysql --password=******
    > Welcome to the MySQL monitor.  Commands end with ; or \g.
    > Your MySQL connection id is 4
    > Server version: 5.1.57-log SUSE MySQL RPM
    >
    > Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
    > This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    > and you are welcome to modify and redistribute it under the GPL v2 license
    >
    > Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    >
    > mysql> CREATE DATABASE amarokdb;
    > Query OK, 1 row affected (0.12 sec)
    >
    > mysql> GRANT ALL PRIVILEGES ON amarokdb.* TO 'amarokuser' IDENTIFIED BY 'hola2';
    > Query OK, 0 rows affected (0.09 sec)
    >
    > mysql> FLUDH PRIVILEGES;
    > ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FLUDH PRIVILEGES' at line 1
    > mysql> FLUSH PRIVILEGES;
    > Query OK, 0 rows affected (0.03 sec)
    >
    > mysql> exit
    > Bye
    Then I exited amarok, restarted it, and saw some process scanning the disk.
    But I see no music in the database, and there are no new files in
    "/var/lib/mysql/amarokdb/" except "db.opt" (61 bytes). So I tried:

    Code:
    
    > Telcontar:~ # mysql --user=amarokuser --password=hola2
    > ERROR 1045 (28000): Access denied for user 'amarokuser'@'localhost' (using password: YES)
    > Telcontar:~ #
    It is not working. Perhaps the user "amarokuser" has to also exist as a
    system user? Or should I use the same user as my normal user instead?


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Amarok mysql database question

    On 2012-03-04 15:18, Carlos E. R. wrote:

    > It is not working. Perhaps the user "amarokuser" has to also exist as a
    > system user? Or should I use the same user as my normal user instead?


    I tried again using my own user, and it is working...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Amarok mysql database question

    On 2012-03-04 15:33, Carlos E. R. wrote:
    > On 2012-03-04 15:18, Carlos E. R. wrote:


    > I tried again using my own user, and it is working...


    And continues working... for two hours already, the "amarokcollectio" at
    100% at one core, and only 37% scanned, with a not so large collection.

    The disk is not taxed at all, less than 100KB/s briefly.

    This is very inefficient.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •